
 

 

Tutorial 

SemTalk  

Version 4.4 

 

SharePoint Integration for SemTalk 

 

 

 

 

 

 

 

 

 

 



        SharePoint Manual 

Page 2 of 30 

 

 

 

 

Table of Contents 

Introduction ............................................................................................................................................. 3 

Document Management Features .......................................................................................................... 3 

Saving Documents to SharePoint ........................................................................................................ 5 

Open Documents from SharePoint ..................................................................................................... 7 

SaveAs HTML ....................................................................................................................................... 8 

Attaching Documents ........................................................................................................................ 11 

SharePoint Library Options ............................................................................................................... 12 

Repository Features .............................................................................................................................. 13 

Integration of SharePoint Lists with SemTalk ................................................................................... 14 

Using SharePoint list items in SemTalk ............................................................................................. 18 

Mapping Classes to SharePoint Lists ................................................................................................. 22 

SharePoint Configuration file ............................................................................................................ 29 

Generate default SharePoint Repository structure with SemTalk .................................................... 30 

 

 

  



        SharePoint Manual 

Page 3 of 30 

 

Introduction 

This tutorial is divided into two parts. The first part explains the login, save, load file and attach file 
connections between SemTalk and SharePoint.  The second part is about how to use SharePoint lists 
as an object repository.  Both parts contain links to a short demo video. 

Document Management Features  

SharePoint Video Part 1: http://www.youtube.com/watch?v=XGiAgh9AoFs  

Please make sure you have access to a SharePoint document library where you are allowed to save 

Visio documents. You may use predefined libraries such as “Shared Documents” or create your own 

document library1. 

  

We recommend creating a second document library named “XML”. This library is used by SemTalk to 

store SemTalk XML files. Versioning and Check-in/Check-out should be disabled. The library can be 

hidden from the menu. 

 

  

                                                           
1 To create a library use  Site Actions and choose New Document Library  

http://www.youtube.com/watch?v=XGiAgh9AoFs
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SharePoint integration in SemTalk must be enabled before it can be used. Options-> SemTalk 

Options ->General: Option ‘Use SharePoint Integration’ 

 

If you do not have direct access to SharePoint using your Windows credentials, SemTalk will prompt 

you for your SharePoint credentials. You can also add your credentials from the menu:  SharePoint -> 

Credentials. 

 

Please make sure to enter the domain part of your credentials in the textbox „Domain“.  This is 

specifically the Domain, not the URL of your SharePoint server. If you log into SharePoint, similar to 

the “SHAREPOINT\username”, the textbox “Domain” should have the value “SHAREPOINT” and the 

textbox “User name” should get the value “username”.  
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Saving Documents to SharePoint 

Documents can be saved to a SharePoint document library from SemTalk. Please use for Visio 2010 

the function File  Save & Send  Save to SharePoint (SemTalk). 

 

If you use Visio 2013 then you find this function under File  Save As  Save to SharePoint 

(SemTalk) 
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Next select the library or folder.  

  

After selection of the library you will be asked for the document name. 

 

The document is now saved to the SharePoint library. The default format of documents saved to 

SharePoint is VSD for Visio 2010 and VSDX for Visio 2013. If you need other formats such as VDW or 

VDX, you can choose the desired extension while saving. 

Depending on the configuration of the library, the document may still be checked-out. This happens 

if the library has required columns or if check-in/check-out is required in by this library. If this is the 

case, newly saved documents are not visible to others until they are checked-in. 

 

Once your document is saved to SharePoint, or has been opened from SharePoint, you can just use 

File->Save or the Save button to save it again. 
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Open Documents from SharePoint 

Opening a document from SharePoint is done using for Visio 2010 File  Open & Import  

SharePoint 

 

and for Visio 2013 use File  Open  SharePoint (SemTalk) 

 

After that select the Site, the Library and the File  

 



        SharePoint Manual 

Page 8 of 30 

 

Also you can Open the File directly from SharePoint 

 

SaveAs HTML 

If the document library has views, you can filter documents to publish your documents as HTML. In 

the SharePoint library you cannot simply upload HTML files, you must use the SharePoint integration 

found in the SaveAs HTML dialog. 

HTML pages should have a dedicated library.  Simply name them “HTML”.  Similar to the XML library, 

this library can be hidden from end user navigation views. 

Open the HTML Export for Visio 2010 with File-> Save & Send  Save As HTML.  

 
 

And for Visio 2013 with File  Export  Save as HTML 
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Click the “SP” (SharePoint) button to select the HTML library. 
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After generating HTML and automatic upload, the page can be found in the HTML library.  

 

When creating a small portal you just need to add a Page Viewer and link it to the start page of your 

HTML. 
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Attaching Documents 

Documents are attached to SemTalk objects using the Hyperlink button in the toolbar or by using the 

edit dialog. To attach Documents saved to SharePoint libraries you apply the “SP” (SharePoint) 

button in the hyperlink dialog. 

 

Documents can be selected from any SharePoint site and they do not have to be stored in the same 

site as the Visio document. You may add as many hyperlinks to an object as you like. 

Beyond attaching documents you also have the option to create links to list items. The intended use 

is to open a SharePoint form on the selected item. As with other hyperlink, these hyperlinks are also 

available in the HTML export.  Items are selected using the button “SP Viewer”. 

 

If you are attaching multiple documents from SharePoint, you can use the Document Explorer (Tools-

> Documents (SharePoint)) to make this easier. 
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In the Documents (SharePoint) Window you can select the library which contains the documents. If 

you drag them onto SemTalk objects a new hyperlink is created. 

  

SharePoint Library Options 

Options->SemTalk Options->SharePoint is the place to configure the SharePoint libraries in SemTalk. 
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Website Default website, website containing the 
document 

Library of this Document for Document Meta 
Data 

Document library where the Visio document is 
stored. Read / Write Meta Data allows users to 
specify if SemTalk is supposed to import 
SharePoint Meta e.g. for a Background page. 
Write meta data to fill columns in SharePoint 
with data from SemTalk if applicable. 

Library to upload Attachments Default Library for Attachments (not the Visio 
documents) 

SharePoint Viewer SharePoint Form which is used for attached list 
items. This can be overwritten on each class  

SharePoint Viewer Caption 

 

Caption in menus for links to list items 

SharePoint SemTalk Mapping XML configuration file containing mappings 
from SemTalk objects to lists. Used at File-
>SharePoint->Assign SharePoint Lists 

Max Row Limit Maximum number of rows to return in 
SharePoint 2010 

Good List Plus filters show which libraries are visible in 
the SharePoint dialog 

Bad List Negative filters determine which libraries are 
visible in the SharePoint dialog <???> 

Repository Features 

SharePoint Video Part 2: http://www.youtube.com/watch?v=yDRdrgTlH0I  

  

http://www.youtube.com/watch?v=yDRdrgTlH0I
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Integration of SharePoint Lists with SemTalk 

In order to load SharePoint lists as external objects you have to select Options-> SemTalk Options-

>Ext. Models->SharePoint List. Do not select SharePoint since this would load simply a XML file 

stored in SharePoint. 

 

 

Use the SP (SharePoint) button in the Link to SharePoint List dialog to choose a site and then a list. In 

this example we have prepared a list named “Role”, containing a list of SAP role names. You may 

create various lists with content you may have in some Excel sheets. 
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The items in the list will be mapped as instances to the class “Role” in SemTalk. 

 

You may link multiple SharePoint lists to a SemTalk model. Simply select “SharePoint List” again to 

add more lists. For this tutorial we add a list of objects (taken from the BPMN tutorial). 

You may assign any SharePoint list to any SemTalk object type. If column names match attribute 

names in SemTalk, values will be updated. Lookup columns are mapped to associations. 
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In order to create a well-engineered professional repository in SharePoint, we highly recommend our 

SemTalk solution “SemTalk SharePoint Site Builder” which graphically specifies and generates those 

lists from predefined SemTalk Content Types. 

 

Items of the added lists can be found in the SemTalk Explorer: 
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“Open” and “Save” allows users to store lists of external files or libraries in a file. “SP” are used for 

opening and saving this file to SharePoint. 

 

If you wish to preselect a list for all models, it can be specified on the “Path” tab. 

 

You can also use a path relative to the document library where the file is being saved. 
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If you change the location of your external libraries (e.g. migration from pilot to production), you can 

update all the references to the new list using the “Refresh” button. 

 

Using SharePoint list items in SemTalk 

You have now several ways to use the SharePoint items in your model: 

1. Dragging items to the drawing area.  

- If you drag and drop “Administrator” to the drawing area it will be displayed as a swim 

lane. 
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- Drag now an object from the external list “Objects” to the drawing. E.g. „Order“. The 

Compose Dialog opens and you only have to select a method (verb) to create an activity 

on the lane. 

 
 

2. Directly select items from SharePoint  

- On many elements in SemTalk you have the option to make a reference to a SharePoint 

library. If you add a new lane, you can right click “Select” and find all the items of the 

SharePoint lists to pick an item. 
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- For activities, events and gateways you may use the SemTalk Compose function and pick 

business objects from the external list.  

 

3. Selection of individual items without preselecting the list in SemTalk options. 

You may select individual items from SharePoint without assigning the complete list in the 

way described above. In this case you will need to select the list for each individual object. 

This makes sense if you need individual objects from SharePoint and want to avoid loading 

the complete list from SharePoint each time you startup your model. 

Again, use the Select menu entry.  Now use the SP (SharePoint) button on the dialog and 

select a list and then select the items of your choice. 
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- The same applies for activities. The “Compose” dialog has also an „SP“-button where you 

can directly select objects from SharePoint lists. 

  

Once you rename / change an object in SharePoint, these changes will be reflected in SemTalk after 

refreshing the model. 
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To refresh use the Refresh button  

 

  

 

Mapping Classes to SharePoint Lists 

You can map SemTalk classes directly to SharePoint lists. The idea is that all SemTalk instances of 

those classes have a corresponding items in such a list. For new instances in SemTalk new items in 

SharePoint will be created and vice versa. This requires some configuration since you must specify 

which lists and how items will be mapped for SemTalk classes. 
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This mapping will be specified on the SharePoint tab of the edit dialog for a class. If this tab is not 

visible, you can make it visible using the Customize dialog. Select the class in the Explorer, choose 

“Customize (Dialog)”. 

 

Using the Customize dialog, please check the option SharePoint on the tab Class Edit Dialog.  

If you edit the class you should be able to see the SharePoint tab.  

 

The SharePoint tab has several sub-tabs. The most important one is Export Import where you select 

the list with the SP (SharePoint) button and decide if items will correspond to subclasses or to 
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instances. For Object/Information the mapping is supposed to be subclasses and for roles or IT-

systems it should be instances. You also may specify views in order to select a subset of items. 

The buttons “Export only”, “Import only” and “Refresh” create and merge to respective objects or 

item in the list. Refresh is actually the same as the Refresh button in the toolbar. For Refresh you 

may enter more detailed information. Checkboxes for Export and Import specify that objects should 

be exported or imported. SemTalk override means that objects are first exported and then imported 

again.  

Other options allow exporting more information to SharePoint if specific columns exist: Document is 

the name of the document. Diagram is the page on which the object is being displayed. Activity 

refers to Activities that may be related. Other possible columns in SharePoint are Class, System Class 

or Refinement. 

Relations & Attributes is a very special option designed for sites having a specific structure to 

represent class models. The class list is supposed to have columns for attributes, SuperClasses 

methods and states.  All of them are lookup columns on other lists. 

 

Since these sites have a fixed structure which is understood by SemTalk, we highly recommend 

generating them with SemTalk Site Builder, a tool which creates the structure including content types 

and lookups from a graphical specification. Once you have created such a structure, it will serve as an 

object repository or ontology for many processes. 

Make references on Import makes sure that objects newly created in SemTalk get a reference to a 

SharePoint list item from where it can be updated later on. 

Import Lookups specifies that items which are related by lookup columns in SharePoint will also be 

imported. If a lists named “Car” relates to another list name “Person” and you might have lookups 

like “hasOwner” or “hasDriver” and you import a car to SemTalk, then the person(s) will also be 

imported. 
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The next sub-tab is Content Type. On this tab you have the option to select a content type for the 

items in the assigned list. In case the site was generated from a default template of SemTalk Site 

Builder it will have content types matching all the base (“System”) types of SemTalk having columns 

with matching names. Those content types are named per default like “SemTalk ..”. 

 

For any object in SemTalk you may assign a corresponding SharePoint item using the SP (SharePoint) 

button. Per default SemTalk will offer you all lists in a site to pick from, but in virtually any situation 

you might know which lists belong to your current object type since you have lists of roles, list of IT-

Systems etc. This is the reason why you can assign have Good List and Bad List for each class. 

 

  



        SharePoint Manual 

Page 26 of 30 

 

 SP Dialog tab gives you the option to restrict those lists. 

  

Good List is a positive restriction. Only those lists mentioned as Good Lists are allowed. Bad lists are 

bit weaker:  Lists marked as Bad list are not allowed. Multiple list names may be entered but must be 

separated by semicolon. GoodSite specifies a different site to pick objects from. 

 

 

The HTML tab gives you the option to assign specific SharePoint forms to classes. The meaning is to 
determine which SharePoint forms will be used to edit the SharePoint item corresponding to the 
SemTalk object. 
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These forms will be opened e.g. from the HTML representation of the document. SharePoint Viewer 
Caption is the name of the HTML menu entry. 

 

Check this option to generate links to SharePoint forms at Save As HTML: 
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The generated HTML will have an extra menu entry linking to the SharePoint form and item. 
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SharePoint Configuration file 

In order to transfer the configuration settings mentioned above to another SemTalk model they can 
be specified in a configuration file. 

 

Select a SharePoint settings file at SemTalk options->SharePoint: 

  

To apply such a setting file to SemTalk you may use SharePoint->Assign SharePoint Lists.  
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Generate default SharePoint Repository structure with SemTalk 

With the Button “Generate SharePoint Libraries” under the Tab “SharePoint”, you can create a 

default repository structure for SemTalk in SharePoint.  

 

Select the Website where you create the structure 

 

After press on the OK Semtalk will create the structure on the SharePoint Server.  

 


