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1. Introduction 
 

The main purpose of the SemTalk Simulation Toolkit is to offer an open and readily adaptable 

platform to investigate the dynamic behaviour of business processes.  Process threads are 

interpreted by a colored Petri-Nets discrete simulation engine.  Simulation helps analysts to 

understand the dynamic structure of a process by identifying weaknesses, media breaks or 

bottlenecks.  It also provides a more reliable process trace to better compute and analyse 

activity-based costing. Simulation data is being used to support a variety of business 

processes activities. 

 

Simulated processes are analysed in either a single stepping mode or by running the 

simulation over multiple processes at once. Instances of object behaviour such as in the 

processing of a specific “purchase order” object are created and their associated attribute 

values are manipulated as the process is being executed. VBScript Macros can be attached to 

every process step in order to program sophisticated computations or to open custom dialogs .  

 

The SemTalk Simulation Toolkit may be used with SemTalk KSA Edition and all other 

related BPM methods which have a compatible meta model such as SemTalk FlowChart 

Edition, SemTalk BPMN Edition. The simulation functionality for EPC is limited by the 

restricted expressiveness of the language. 

 

1.1 The SemTalk Simulation Window 

 

You can open the SemTalk Simulation window via the Tools->Simulation->Show: 
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In case you cannot see the Simulation tab, you should activate it with Options->SemTalk 

Options 

 
 

The window consists of two areas: 

 Buttons to start and step the simulation 

 A list of events 

 

The Simulation Menu and the Button Bar of the Simulation Window has the following 

options: 

 

 

Initialize simulation. Using this command you will start a new 

simulation. All existing simulation data is kept in memory so that 

you can compare the results. The simulation engine is being reset 

and a first simulation step is being executed. The simulation engine 

is in stepping mode. To continue with simulation you can either 

executed another step using the “Next/Step” command or enter the 

running mode using “Last / Run” 

 

This command is used to navigate in a completed or stopped 

simulation trace. Works as above to navigate backward. 

 

This command is used to navigate in a completed or stopped 

simulation trace. Same as above to navigate forward.  

If the simulator is in stepping mode, a single step of the simulation 

engine is being executed. 

 

The simulation continues until there are no more tasks to execute, 

or the user interrupts the simulation 

 

This command interrupts the simulation. The simulation is in step 

mode 
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Save the current simulation data to an XML file. You may apply 

XSLT to simulation data for your own purpose.  

 

Opening previously saved simulation data allows to compare the 

results in a Simulation report 

 

Options for the simulation protocol: 

 

 

 

 
 

New 
An entry in the trace list is made for 

each activity to be executed 

Done 
An Entry in the trace list is created 

for each completed activity 

Waiting 
Shows an entry if an activity is 

waiting for a resource 

Using 
Shows an entry if  an activity is 

using/occupying a resource 

Storing 
Information is being stored to a 

buffer 

Interrupt 

An activity has been interrupted by a 

process of higher priority or an 

activity has been resumed after 

interruption 
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Releasing 
Shows an entry if  an activity is not 

using/releasing a resource 

Sync 
An activity is waiting for multiple 

inputs 

Flow 

An entry in the trace list is made for 

each new flow of information to be 

executed 

Flushing  

Buffer is being flushed, existing or 

new information is being sent. This 

can happen because a threshold has 

been reached or it is periodic 

Accessing 
Information is being retrieved / 

removed 

Off-time 

Off-time has been entered or 

finished. Resources will 

break/resume their current jobs 

Interactive 

In interactive mode, the user can 

manually select a specific process 

flow in a stepwise fashion. In non-

interactive mode the simulation 

engine is using probabilities 

specified on the control flow links. 

Default setting is non-interactive. 

Animation 

Each activity, resource of buffer 

which is touched by simulation will 

be selected and greyed 

Sync. Visio 

Adds Simulation data to shapes, so 

that it can be displayed with Visio 

Data Graphics  

 

 

 

Using “Up” and “Down” arrow keys in the protocol trace list behaves similar to the “Next” / 

“Back” commands. If possible, the current focus in the list is moved to another object and the 

object is being displayed in the drawing.  

 

Please note that the simulation engine cannot simulate until you specify input parameters in 

the Measures tab for each EntryPoint object.  

 

2. Preparing a Simulation 
 

Since edit dialogs can be customized in SemTalk you may not directly see all tabs mentioned 

in the following chapters in all documents. Customization of dialogs is easy and does not 

harm existing documents.  Select the system class in the SemTalk Explorer e.g. “Activity” 

and choose Object->ProcessElement->Activity->Customize (Dialog) from the menu. 
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Please select the tabs you need for simulation. For simulation of activities please select 

“ObjectFlow” and “ScriptProperties” may be useful in some situations. For (human & 

physical) resources “OffTime” may be needed. 

 

3. Basic Simulation Elements 
 

The starting elements for the SemTalk Simulation Toolkit are “Entry Points” (“Inputs” in 

CSA or “Events” in EPC notation and BPMN) which trigger the simulation by a certain 

amount of tokens. Activities are the process steps being executed. The execution of activities 

(tasks, functions, process steps…) is called a “Job” and takes a specified amount of time. 

Physical or human resources may be needed to execute an activity. These resources can have 

a limited capacity, which act as a constrained resource that determines the maximum number 

of activities that can be executed in parallel. As soon as a resource is not available, a process 

instance has to wait for the resource. Processes and activities may have an assigned priority. 

Jobs with lower priority will be interrupted. The priority of a job (process thread) is the sum 

of the priorities of the process (specified by its entry point) plus the priority of the activity.   

 

In order to explain simulation elements we will create a simple process.  Please add an entry 

point and some activities as shown in the following picture. 
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3.1 Entry Points 

  

Open the “Edit” dialog of the entry point (“Price Quote requested”) and select the “Measures” 

tab. 

 

Trigger Type BPMN ONLY 

Start day Begin time of this event 

End day End time of this event 

Period After each period the entry point is firing events 

Inputs The number of process instances (tokens) to create from this entry 

point while simulation. You must set this value to something higher 

than zero in order to activate the entry point. 

Priority Process instances with higher priority interrupt jobs with lower priority 

events  

Distribution Choose the distribution type from: 

 Constant Value 

 Even Distribution 

 Normal Distribution 

 Exponential Distribution 

 Values 

 Evenly spaced 

Distribution  Parameters for the distribution: For a constant distribution this is simply 

the time. For an even distribution we have min time and max time. A 

normal distribution needs a mean and a std. deviation. 
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File For the distribution type “Values” a text file is specified containing all the 

times is entry is supposed to fire (e.g. a flight plan of an airport). Units a 

seconds. 

 

 

 
 

 

 

Please make sure you have specified at least one input. 

 

You may also use the property window (Home->Properties) to enter and review your settings. 
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3.2 Activities (FlowChart: “Process”) 

 

Open the “Edit” dialog of an activity (“process Price Quote”) and select the “Measures” tab 

(or just select it, if you are using the property window) 

 

Cost Driver Just for documentation  

Priority The priority is added to the priority of the process instance which was 

specified at the entry 

Distribution Choose the distribution type from: 

 Constant 

 Even Distribution 

 Normal Distribution 

 Exponential Distribution 

Distribution 

Parameters 

Parameters for the distribution: For a constant distribution this is simply 

the time. For an even distribution we have min time and max time. A 

normal distribution needs a mean and a std. deviation. 

Waiting Time Waiting time is not a simulation parameter. It can be used in reports to 

compare estimated times with simulated times 

Interruption Specifies the behaviour after the activity was interrupted. “Resume” 

continues with the remaining time and “Restart” will start the activity 

again. 
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Your first simulation is already executable now. Please open the Simulator Window if you 

have not opened it yet. Select Simulation->New to execute the first step of the simulation. 

 

 
 

 

In the simulation window you will notice, that the entry point has been fired and the first 

information flow has been started. You can proceed now in the single step mode Simulation 

 Next  or run it with Simulator->Run.  
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Once the simulation is finished or interrupted, you can navigate in the simulation trace using 

arrow keys or the command buttons. SemTalk will highlight the current object in the drawing. 

 

The trace shows the ID of the process instance, the name of the object, the type of simulation 

event (started, finished etc.) and the current simulation time. By default all processes are 

shown. You can filter out single processes by using the “Process” combo box in the Options 

Dialog.. 

 

Refined activities (sub processes) are being interpreted by the simulation engine. 

3.3 Information flow 

  

The SemTalk Simulation engine not only supports the working time at activities but also the 

transportation time on the information flow. 

On the “Object Flow” tab of an information flow you can specify the type of information, 

which is passed from activity to activity. Using the “Measures” tab you can specify the 

transportation time and costs for the information flow. 

 

Transportation Time Constant Distribution only 

Fixed Cost To be used in reports. Cost per usage (e.g. a letter) 

Variable Cost To be used in reports. Cost depending on flow time (e.g. a phone call) 

Probability The probability for this information flow, if it is an outbound control 

flow of an activity with outbound OR or XOR setting (see next 

chapter) 
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Control of the information flow may also depend on the values of object attributes or states as 

they are specified in the Object Flow tab. This functionality is described in Chapter 3. 

 

You can visualize the probability of flows by customizing the layout of sends info link 

(Object  Customize (Shape). Select “Probability” in the list of visible attributes. 

3.4 Input and Output Logic of Activities 

 

For notations which do not have explicit operators or decision SemTalk specifies the logic for 

the control flow in the Condition tab of an activity. 
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The Condition tab allows the specification of input and output conditions. Input and output 

conditions are used to set the simulation rules. 

 

 

Input conditions: 

 

AND The process waits until tokens come in from all inbound sends info links. 

OR The process waits until a token comes in from one of the inbound sends info 

links. 

AND (sync) The process waits until a token from the same original Entry Point (color) 

comes in from all inbound sends info links. The option is used for 

synchronization. 

  

Output condition: 

 

AND A token will be sent to all outbound sends info links 

OR This is a non-exclusive OR. A token will be randomly sent to single or 

multiple outbound sends info links depending on whether the random 

number is lower than the probability specified on the sends info link. 

XOR A token will be sent to the first outbound sends info link where the random 

number is lower than the probability specified on the sends info link.  

INFO A token will be sent to those outbound sends info links where the object 

expression specified on the object flow tab of the send info link is true e.g. 

Person.Age>10 
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In notations which have operators such as EPC or in notations using explicit decision 

(“Gateway”) nodes, the input and output conditions will be only specified at those 

operators/decisions. The Input/Output tab is usually hidden in pre-defined methods. 

 

BPMN use operators to express to logic 

 

 
 

BPMN Input conditions: 

 

Parallel-

AND 

The process waits until tokens come in from all inbound sends info links. 

Data-Based 

XOR, Event-

Based XOR, 

Inclusive- 

OR 

The process waits until a token comes in from one of the inbound sends info 

links. 

Parallel-

AND (sync) 

The process waits until a token from the same original Entry Point (color) 

comes in from all inbound sends info links. The option is used for 

synchronization. 

  

BPMN Output condition: 

 

Parallel-

AND 

A token will be sent to all outbound sends info links 

Inclusive- 

OR 

This is a non-exclusive OR. A token will be randomly sent to single or 

multiple outbound sends info links depending on whether the random 

number is lower than the probability specified on the sends info link. 

Data-Based 

XOR, Event-

Based XOR 

A token will be sent to the first outbound sends info link where the random 

number is lower than the probability specified on the sends info link.  

Data-Based 

XOR, Event-

Based XOR 

(with Object 

Flow) 

A token will be sent to those outbound sends info links where the object 

expression specified on the object flow tab of the send info link is true e.g. 

Person.Age>10 

Complex Can not be simulated 
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The default behavior for activities with multiple outputs is AND. For activities with multiple 

inputs the default behavior is OR: 

 

Examples: 

 

 
A Parallel-AND synchronizes 2 branches 

 

 
A Data based-XOR with branches and probabilities 

 

 
Object model for the following flow samples 
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Decisions based on object types. Large Orders take the upper branch, small orders take the 

lower branch. The gateway must be set to “Object Flow”. 

 

 
 

Decision based on attribute values. 

 

3.5 Resources 
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The next step is to add the human or physical resources required to execute the activities.  

There are multiple ways to assign human or physical resources to activities in SemTalk. In all 

methods you may use the “Hum. Resource” tab (New Button) of the activity to create/assign 

human resources. They can also be assigned by using Swim lanes or directly by a graphical 

representation (EPC). Physical Resources such as a hammer or a PC are usually assigned 

graphically. Please refer to the manual of your preferred modelling method. 

 

 
 

  

 

For each resource you can specify the number of units needed. 
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By double-clicking the resource (Sales) in the left list box you can edit its attributes.  

 

For each resource we can specify the following attributes: 

 

 
 

 

Capacity The number of activities which can be executed in parallel using the 

resource. For organizational units or positions this should correspond 

to the number of people. Default value is 1. Please make sure that 

the value is at least 1 to use the resource in simulation. The 

process will stop if no resource is available. 

Fixed Cost To be used in reports. Cost per usage  

Variable Cost To be used in reports. Cost depending on working time  

Setup Time Amount of time needed additional to the working time to set-up 

Strategy Processing strategy is not supported. Resources always execute the 

job first in first out unless a job arrives with a higher  priority 

 

 

Off-times (unavailability times for resources) can also be added. 
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Off-times have a start time and an end time. If an off-time is reached in a simulation, 

resources will break and then resume when the off-time is over. 

 

In the demo model, Sales is assigned as a resource in the first activity.  The work time is 

changed in this example to one day in order to show the impact of a lunch break. (The 

resource only breaks for lunch but works through the night in our demo…)   

 

In order to work with Off-times in a meaningful way you must use 24 hour mode of SemTalk 

instead of the default 8h mode. If it looks strange, please check Options->SemTalk Options-

>General->Hours per day. SemTalk only stores seconds as time unit. This option simply 

specifies how it is displayed.  
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It is also possible to manipulate off-time definitions using the SemTalk Explorer.  The off-

time attributes for start and end times are available by double-clicking on the named off-time. 
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Please use either the swim lanes or the Hum. Resource tab for activities to assign human 

resources to activities.  Then add a processing time to the existing activities “Accept Inquiry” 

and “Check Discount” and increase the number of inputs in the entry point to 5. 
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In the simulation trace you will notice now that some process instances are waiting for 

resources (process instance 2 is waiting for Sales, which is already busy processing the price 

quote in process instance 1). 

 
 

 

You can now vary the capacities of your resources or you can move tasks from one resource 

to another in order to optimize your business process.  In order to get a better overview of 

where processes use time and/ or increase costs, you can use the simulation reports described 

in chapter 5. 

 

3.6  Setting Priorities 

 

In the last chapter we saw how activities may be interrupted by off-times. In case you work 

with priorities you can express situations like this: An activity with a high priority can 

interrupt an activity with a lower priority if they compete for the same resource. It “steals” the 

resources instead of waiting. The activity with the lower priority is resumed afterwards. 

The priority of a process is maintained at an entry point. The priority of an activity will be 

added to the priority of the process. 

The lowest priority is “1”, any activity having the priority “2” or higher can interrupt it. 
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3.7 Object Instances 

  

In the sample process, objects (information instances) are being created for each process 

instance.  For each process instance, an information instance for each information type is 

created as the process is being executed. This only happens for those classes that are included 

in the process flow.  In this process there is a “Offer” and a “Price Quote”.  For each class 

exactly one instance is created during simulation.  

When you restart simulation, all information instances will be deleted. 
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Activities can have post-execution conditions, which are able to change attribute values or 

states of the information instances after the activity has been executed. 
1
 

 

 

 
 

 

An activity can have multiple post-conditions. 

 

                                                 
1
  The post conditions are specified using the Object flow tab on activities.  This tab needs to be made visible 

using Object “Customize” when the  “Activity” is selected in the explorer  
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On the “Object Flow” tab of an information flow you can also specify attribute values 

constraints.  

 

 
 

 

 

If attribute or state constraints are assigned, they will only be interpreted if the output 

condition of the preceding activity is set to INFO (for CSA) . At BPMN you must Select XOR 

or OR and check “Object Flow”. 

 

 
 

 This will overwrite any given probabilities that have been assigned. 

 

Using attribute values you can more exactly specify the dynamic behaviour of a process at a 

much higher level of detail compared using simply probabilities.  
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You also can change attribute values when preparing more detailed Reports. Setting post-

conditions is a simple way to mark objects and branches of a process. If you run an 

Information Instance SemTalk Report, you will get a list of objects and their attribute values. 
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4. Buffers 
 

Buffers are used to store information. Buffers are usually used to read or write information in 

and out of databases or ITsystems such as an ERP system. 
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Each time “Accept Inquiry” is executed, associated information is stored in the CRM system. 

“Make Offer” reads from this buffer.  It can only execute if the required information is 

contained in the Buffer.  
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If you choose the „Remove“ option, designated information is removed from the buffer and it 

will not be available to other activities anymore (e.g. removing  a book from the shelf).  Use 

the Copy option if you want the information to remain in the buffer (record in a database) so it 

will continue to be available for other activities. 

 

After, or while a simulation runs, you can watch the contents in the buffer: 

 

 
 

You can also use “sends info / Message flow” with buffers. Information can flow from and to 

buffers and activities.  
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Buffers also may need to be emptied (flushed).  If this is the case, please specify at which 

Flush interval (time) or at which Flush level (count) the buffer should be emptied. 
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Flush Level The buffer sends all contained information into outbound information 

flows if a certain threshold is reached. e.g. Make a sales forecast after 

every 4 bids. 

Flush Interval The buffer sends all contained information into outbound information 

flows if a certain time interval of is reached. e.g. Make a sales 

forecast every week. 

Initial Contents This is the content of the buffer at the start of simulation run.  If the 

information is being read by a job that has a process ID, the 

information will be assigned the same process ID as the job that it is 

processing. Flushing such information instances will actually start a 

new process with a new ID.   

 

A more complex sample is: 
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4.1 Process Independent Buffers 

 

Buffers used in the tutorial so far are process related. This means only the process instance 

which writes to a buffer can read it later on. This is the most important case since an object 

like e.g. a bill must be assigned to the “right” customer, which came from the same entry 

point or order. 

 

Process independent buffers are able to store anonymous things like money or goods.  
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In the following example you will see a purchase and a sales process (so called “Supercycle” 

of accounting). This purchase process has two process dependent buffers “Purchase Orders” 

and “Creditors”. The sales process also has two process dependent buffers - “Sales Orders” 

and “Debitors”. Both of them access the commonlyshared process independent buffers 

“Money” and “Goods”. 

 
 

 

The sales process can only deliver goods which have been ordered by the purchase process. 

For process independent buffers only the overall number of stored tokens is relevant. 

How many tokens are stored is specified on the links to the buffers. 

 

 
 

No SemTalk unique instances are generated for money or goods. 
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5. Breakpoints 
 

Breakpoints stop a running simulation at a specific activity instead of requiring that you step 

through the simulation until you reach the desired activity.  Breakpoints are ordinary SemTalk 

objects which can be navigated, deleted, renamed or listed in a report. They are often used to 

check milestones within a process. 

 
 

To add a Breakpoint just use the Breakpoint (STOP sign) shape available in the process 

stencil and connect it to one or more activities using the “breaks” connector. 

 

6. Data Graphics  
 

Visio Data Graphics are the best way to visualize simulation data  dynamically. They have 

been available since the release of SemTalk3 and Visio 2007  

Please make sure you have checked “Sync. Visio Data”  in the simulation options. 
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Current simulation data will be copied to the Visio shapes. 

 

 
Figure 1 Shape Data 

 

This shape data can be visualized using Visio Data Graphics. 
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7. Simulation Reports 
 

 

The SemTalk Simulation reports are opened the same way as other SemTalk process reports. 

 

  

 
 

 

 

If simulation data is available, the simulation dialog will show a tab having the simulation 

reports. 
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You can select a report that covers a single process instance or you can select all process 

instances. 

  

Process Steps A list of process steps plus working times, waiting times (simulation) 

and costs taken from the resources. 

Activities A list of process steps aggregated by activity class (task) with working 

times, waiting times (simulation) and costs taken from the resources. 

Resources Process steps by resource with activities, working times, waiting times 

(simulation) and costs. 

Information All – All information types with the number of instances 

Single process  -  A list of the information objects with their attribute 

values. 

 

You can select from all available simulation runs (each simulation run is listed as a time). For 

each simulation run you can run a report for a single process instance or for all process 

instances. 
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The resulting Excel Sheet contains detailed information for each job such as start time, end 

time, waiting time for resources, synchronization time.  Duration time is the difference 

between the start time of the first job and the end time of the last job. 

  

8. Scripting 
 

The use of post conditions opens up some very powerful opportunities, but even more 

sophisticated solutions are available using scripting. VBScript is one of the most popular 

scripting environments. 

  

Before and after the execution of an activity it is possible to call a function. Inside these 

macros you have read/write access to process and simulation data. You can modify SemTalk 

objects, popup dialog boxes or even call up SAP R/3 transactions. 

 

You can add any scripting code to activities. A procedure named “Before” is executed before 

the activity starts and one called “After” is executed afterwards. 
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SemTalk Simulation binds the variable “base” to the SemTalk Object engine. The current 

simulation is bound to the object “sim”.  The variable “job” is bound to the current job which 

is being executed. 
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Programming scripts requires a user to have basic knowledge about the SemTalk API.  Some 

samples of how to use this API are in the MS Excel interface to SemTalk. 

 

“Hello World” simply pops up a message box 

“ChangeWorkTime” increases the work time of the current activity by 1 second 

“ChangeOrder” changes the class of an order dynamically and leaves a comment on the 

instance 

For additional information email: support@semtalk.com    

or call: +49 331 581 39 36 

 

 

 


