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0. Introduction 

 

The main purpose of the SemTalk Simulation Toolkit is to offer an open and readily adaptable 

platform to investigate the dynamic behaviour of business processes.  Process threads are 

interpreted by a colored Petri-Nets discrete simulation engine.  Simulation helps to understand 

the dynamic structure of a process, to identify weaknesses, media breaks or bottlenecks and it 

generates a more reliable process trace to compute activity based costing. Simulation data is 

being used to support a variety of business processes activities. 

Simulated processes will be analyzed in a single stepping mode or by running multiple 

processes at once. Object instances such as an order object are created and their attribute 

values are manipulated while the process is being executed. VBScript Macros can be attached 
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to every process step in order to program sophisticated computations or to open custom 

dialogs in a Rapid Prototyping use case.  

 

The SemTalk Simulation Toolkit may be used with SemTalk KSA Edition and all other 

related BPM methods which have a compatible meta model such as SemTalk FlowChart 

Edition, SemTalk BPMN Edition, SemTalk for E-Government or with  BCP (SemTalk IBW 

Edition). The simulation functionality for EPC is limited by the restricted expressiveness of 

the language. 

 

1. The SemTalk Simulation Window 

 

You can open the SemTalk Simulation window via the Tools->Simulation->Show: 

 

 
Figure 1: Simulator User Interface 

 

 

The window consists of two areas: 

 Buttons to start and step the simulation 

 A list of events 

 

The Simulation Menu and the Button Bar of the Simulation Window has the following 

options: 

 

New 

 

Initialize simulation. Using this command you will start a new simulation. All 

existing simulation data is kept in memory so that you can compare the results. 

The simulation engine is being reset and a first simulation step is being executed. 

The simulation engine is in stepping mode. To continue with simulation you can 

either executed another step using the “Next/Step” command or enter the running 
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mode using “Last / Run” 

Back. 

 

This command is used to navigate in a completed or stopped simulation trace. 

Same as above to navigate backward. 

Next / 

Step 

 

: This command is used to navigate in a completed or stopped simulation trace. 

Same as above to navigate forward.  

If the simulator is in stepping mode, a single step of the simulation engine is 

being executed. 

Run The simulation continues until the are no more tasks to execute, or the user 

interrupts the simulation 

Break 

 

This command interrupts the simulation. The simulation is in step mode 

Save 

 

Save the current simulation data to an XML file. You may apply XSLT to 

simulation data for your own purpose.  

Open Opening previously saved simulation data allows to compare the results in a 

Simulation report 

Probe A probe window can visualize the current usage of a resource or data container 

 

Options Option for the simulation protocol: 

 

New An entry in the trace list is made for each new activity to 

be executed 

Done An Entry for completed activities 

Waiting Shows an entry if an activity is waiting for a resource 

Using Shows an entry if  an activity is using/occupying a 

resource 

Storing Information is being stored to a buffer 

Accessing Information is being retrieved / removed 

Flushing Buffer is being flushed, existing or new information is 

being send. This can happen because a threshold has been 

reached or periodically 

Releasing Shows an entry if  an activity is not using/releasing a 

resource 

Syncing An activity is waiting for multiple inputs 

Flow An entry in the trace list is made for each new flow of 

information to be executed 

Interrupt An activity has being interrupted by a process of higher 

priority or an activity has been resumed after interruption 

Off-time Off-time has been entered or finished. Resources will 

break /resume their current jobs 

Details At each simulation step all information created in the 

current process is shown in a portion of the simulation 

window 

Interactive In interactive mode, the user can select alternative choices 

for the flow of control. In non-interactive mode the 

simulation engine is using probabilities specified on the 

control flow links. Default setting is non-interactive. 

Animation Each activity, resource of buffer which is touched by 

simulation will be selected and greyed 

Sync. Visio Adds Simulation data to shapes, so that it can be displayed 
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with Visio 2007 Data Graphics 
 

 

Using “Up” and “Down” keys in the protocol trace list behaves similar to the “Next” / “Back” 

commands. The current focus in the list the moved to another object and the object is being 

displayed in the drawing if this is possible. 

 

Please note that the simulation engine has nothing to simulate until you specify events on 

some of the entry points in the process model. 

 

2. Preparing for Simulation 

 

Since edit dialogs can be customized in SemTalk you may not directly see all tabs mentioned 

in the following chapters in all documents. Customization of dialogs is easy and does not do 

any harm to existing documents.  Select the system class in the SemTalk Explorer e.g. 

“Activity” and choose Object->Customize from the menu. 

 

 
Figure 2: Customizing dialogs 

Please select the tabs you need for simulation. For activities “ObjectFlow” and 

“ScriptProperties” may be useful in some situations. For (human & physical) resources 

“OffTime” may be needed. 



SemTalk Simulation Tutorial  04/01/2008 

Email: support@semtalk.com 

 

- 5 - 

3. Basic Elements of Simulation 

 

The starting elements for the SemTalk Simulation Toolkit are “Entry Points” (or “Events” in 

EPC notation and BPMN) which trigger the simulation by a certain amount of tokens (or 

“inputs”). Activities are the process steps being executed. The execution of activities (tasks, 

functions, process steps…) is called a “Job” and takes a specified amount of time. Physical or 

human resources may be needed to execute an activity. These resources can have a limited 

capacity, which specifies the maximum number of activities that can be executed in parallel. 

As soon as resources are not available, a process instance has to wait for resources. Processes 

and activities may have priority. Jobs with lower priority will be interrupted. The priority of a 

job is the sum of the priorities of the process (specified at its entry point) plus the priority of 

the activity.   

 

In order to explain the simulation elements we create a simple process.  Please add an entry 

point and some activities as shown in the following picture. 

 

 
Figure 3: Sample Simulation Process 

  

  

3.1. Entry Points 

  

Open the “Edit” dialog of the entry point (“Price Quote requested”) and select the 

“Simulation” tab. 

 

Start Begin time of this event 

End End time of this event 

Period After each period the entry point is firing events 

Priority Process instances with higher priority interrupt jobs with lower priority 
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events  

Inputs The number of process instances (tokens) to create from this entry 

point while simulation. You must set this value to something higher 

than zero in order to activate the entry point. 

Distribution Choose the distribution type from: 

 Constant 

 Even Distribution 

 Normal Distribution 

 Exponential Distribution 

 Values 

Distribution 

Parameters 

Parameters for the distribution: For a constant distribution this is simply 

the time. For an even distribution we have min time and max time. A 

normal distribution needs a mean and a std. deviation. 

File For the distribution type “Values” a text file is specified containing all the 

times is entry is supposed to fire (e.g. a flight plan of an airport). Units a 

seconds. 

 

 

 
Figure 4: Entry Point Simulation Tab 

 

Please make sure you have specified at least one input. 

 

You may also use the property window (Tools->Explorer->Properties) to enter and review 

your settings. 

 



SemTalk Simulation Tutorial  04/01/2008 

Email: support@semtalk.com 

 

- 7 - 

 
Figure 5: Property Window 

 

 

3.2 Activities (FlowChart: “Process”) 

 

Open the “Edit” dialog of an activity (“process Price Quote”) and select the “Simulation” tab 

(or just select it, if you are using the property window) 

 

Cost Driver Just for documentation  

Priority The priority is added to the priority of the process instance with was 

specified at the entry 

Distribution Choose the distribution type from: 

 Constant 

 Even Distribution 

 Normal Distribution 

 Exponential Distribution 

Distribution 

Parameters 

Parameters for the distribution: For a constant distribution this is simply 

the time. For an even distribution we have min time and max time. A 

normal distribution needs a mean and a std. deviation. 

Waiting Time Waiting time is not a simulation parameter. It can be used in reports to 

compare estimated times with simulated times 

Interruption Specifies the behaviour after the activity was interrupted. “Resume” 

continues with the remaining time and “Restart” will start the activity 

again. 
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Figure 6: Activity Simulation Tab 

  

 

 

Your first simulation is already executable now. Please open the Simulator User Interface 

from Tools->Simulation if you have not opened it yet. Select Simulation->New to execute the 

first step of the simulation. 

 

 
 

In the simulation window you will notice, that the entry point has been fired and the first 

information flow has been started. You can proceed now in the single step mode Simulation-

>Next ( ) or run it with Simulator->Run ( ).  
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Figure 7: Simulation Trace 

 

Once the simulation is finished or interrupted, you can navigate in the simulation trace using 

arrow keys or the command buttons. SemTalk will highlight the current object in the drawing. 

 

The trace shows the ID of the process instance, the name of the object, the type of simulation 

event (started, finished etc.) and the current simulation time. By default all processes are 

shown. You can filter out single processes by using the “Process” combo box in the Options 

Dialog.. 

 

Refined activities (sub processes) are being interpreted by the simulation engine. 

3.3 Information flow 

  

The SemTalk Simulation engine supports not only the working time at activities but also the 

transportation time on information flow links. 

On the “Model” tab of an information flow you can specify the type of information, which is 

passed from activity to activity. On the simulation tab you can specify the transportation time 

and cost. 

 

Transportation Time Constant Distribution only 

Fixed Cost To be used in reports. Cost per usage (e.g. a letter) 

Variable Cost To be used in reports. Cost depending on flow time (e.g. a phone call) 

Probability The probability for this information flow, if it is an outbound control 

flow of an activity with outbound OR or XOR setting (see next 

chapter) 
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Figure 8: Transportation Time 

 

 

The flow of control may also depend on the values of object attributes or states as specified on 

the model tab. This functionality is described in chapter 3. 

 

You can visualize the probability of flows by customizing the layout of sends info link. Select 

“Probability” in the list of visible attributes. 

3.4. Input and Output Logic of Activities 

 

 



SemTalk Simulation Tutorial  04/01/2008 

Email: support@semtalk.com 

 

- 11 - 

 
Figure 9: Input and Output Logic 

 

 

The condition tab allows the specification of input and output conditions.  Input and output 

conditions are used to set the rules for the simulation . 

 

Input conditions: 

 

AND The process waits until tokens come in from all inbound sends info links. 

OR The process waits until a token comes in from one of the inbound sends info 

links. 

AND (sync) The process waits until a token from the same original Entry Point (color)  

comes in from all inbound sends info links. The option is used for 

synchronization. 

  

Output condition: 

 

AND A token will be sent to all outbound sends info links 

OR This is a non-exclusive OR. A token will be randomly sent to single or 

multiple outbound sends info links depending on whether the random 

number is lower than the probability specified on the sends info link. 

XOR A token will be sent to the first outbound sends info link where the random 

number is lower than the probability specified on the sends info link.  

INFO A token will be sent to those outbound sends info links where the object 

expression specified on the object flow tab of the send info link is true e.g. 

Person.Age>10 
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In notations which have operators such as EPC or PROMET@work or in notations using 

explicit decision (“Gateway”) nodes, the input and output conditions will be only specified at 

those operators/decisions. The Input/Output tab is usually hidden in those methods. 

 

3.5. Resources 

 

The next step is to add the human or physical resources required to execute the activities.  

There are multiple ways to assign human or physical resources to activities in SemTalk. In all 

methods you may use the “Hum. Resource” tab (New Button) of the activity to create/assign 

human resources. They can also be assigned by using Swimlanes or directly by a graphical 

representation (EPC). Physical Resources such as a hammer or a PC are usually assigned 

graphically. Please refer to the the manual of your preferred method. 

 

 
Figure 10: Assign a resource 

 

By double-clicking the resource (Sales) in the left list box you can edit its attributes.  

 

For each resource we can specify the following attributes: 
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Figure 11: Attributes of a resource 

 

Capacity The number of activities which can be executed in parallel using the 

resource. For organizational units or positions this should correspond 

to the number of people. Default value is 0. Please make sure that 

the value is at least 1 to use the resource in simulation. The 

process will stop if no resource is available. 

Fixed Cost To be used in reports. Cost per usage  

Variable Cost To be used in reports. Cost depending on working time  

Setup Time Amount of time needed additional to the working time to set-up 

Strategy Processing strategy is not supported. Resources always execute the 

job first in first out unless a job arrives with a higher  priority 

 

 

Off-times (unavailability times for resources) can also be added. 
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Figure 12: Off-times 

 

 

Off-times have a start time and an end. If an off-time is reached in a simulation, resources will 

break and then resume when the off-time is over. 

 

In the demo model, Sales is assigned as a resource in the first activity.  The work time is 

changed in this example to one day in order to show the impact of a lunch break. (The 

resource only breaks for lunch but works through the night in our demo…)   

 

In order to work with Off-times in a meaningful way you must use 24 hour mode of SemTalk 

instead of the default 8h mode. If it looks strange, please check Tools->SemTalk Options-

>General->Hours per day. SemTalk only stores seconds as time unit. This option simply 

specifies how it is displayed.  
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Figure 13: Off-time in the protocol 

 

It is also possible to manipulate off-time definitions using the SemTalk Explorer.  The off-

time attributes for start and end times are available by double-clicking on the named off-time. 
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Figure 14: Editing an Off-Time 

 

Please use either the swim lanes or the model tab for activities to assign human resources to 

activities.  Then add a working time to the existing activities “make Bid” and “check 

Discount” and increase the number of inputs in the entry point to 5. 

 

 
Figure 15: A Process with multiple Resources 
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In the simulation trace you will notice now that some process instances are waiting for 

resources (process instance 2 is waiting for Sales, which is already busy processing the price 

quote in process instance 1). 

 
Figure 16: Process trace with multiple inputs 

 

 

You can now vary the capacities of your resources or you can move tasks from one resource 

to another in order to optimize your business process.  In order to get a better overview of 

where processes use time and/ or increase costs, you can use the simulation reports described 

in chapter 5. 

 

 

4. Object Instances 

 

  

In the sample process, objects (information instances) are being created for each process 

instance.  For each process instance, an information instance for each information type is 

created as the process is being executed. This only happens for those classes that are included 

in the process flow.  In this process there is a “Bid” and a “Price Quote”.  For each class 

exactly one instance is created during simulation.  

When you restart simulation, all information instances will be deleted. 
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Figure 17: Information Instances 

 

Activities can have post execution conditions, which are able to change attribute values or 

states of the information instances after the activity has been executed. 
1
 

 

 

 
Figure 18: Post Condition Tab 

 

An activity can have multiple post conditions. 

 

                                                 
1
  The post conditions are specified using the Object flow tab on activities.  This tab needs to be made visible 

using Object “Customize” when the  “Activity” is selected in the explorer  
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On the “Model” tab of an information flow you can also specify attribute values constraints.  

 

 
Figure 19: Value Constraint on a flow 

 

 

If attribute or state constraints are assigned they will only be interpreted if the output 

condition of the preceding activity is set to INFO. This will overwrite a any given 

probabilities that have been assigned. 

 

Using attribute values you can specify more exactly the dynamic behaviour of a process at a 

much higher level of detail compared to when you only use probabilities.  

You also can change attribute values for the purpose of preparing more detailed reports. 

Setting post conditions is a simple way to mark the objects and branches of a process. If you 

run an information instance SemTalk report, you will get a list of objects and their attribute 

values. 
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Figure 20: Attribute Constraints 

 

 

 

5. Buffers 

 

Buffers are used to store information.  Buffers are usually used to read or write information in 

and out of databases 
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Figure 21: Buffers (Read/Write) 

 

Each time “Process Price Quote” is executed, the information is stored in the CRM system. 

“Make Bid” reads from this buffer.  It can only execute if the required information is 

contained in the Buffer.  
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Figure 22: Remove / Copy 

If you choose the „Remove“ option the information is removed from the buffer and it will not 

be available to other activities anymore (e.g. removing  a book from the shelf).  Use the Copy 

option if you want the information to remain in the buffer (record in a database) so it will 

continue to be available for other activities. 

 

After or while simulation you can watch the contents of the buffer: 
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Figure 23: Contents of a Buffer 

 

 

You can also use “sends info” with buffers. Information can flow from and to buffers and 

activities.  
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Figure 24: Buffer starting an Information flow 

 

Buffers also may need to be emptied (flushed).  If this is the case, please specify at which 

Flush interval (time) or at which Flush level (count) the buffer should be emptied. 
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Figure 25: Properties of a Buffer 

 

Flush Level The buffer sends all contained information into outbound information 

flows if a certain threshold is reached. e.g. Make a sales forecast after 

every 4 bids. 

Flush Interval The buffer sends all contained information into outbound information 

flows if a certain time interval of is reached. e.g. Make a sales 

forecast every week. 

Initial Contents This is the content of the buffer at the start of simulation run.  If the 

information is being read by a job that has a process ID, the 

information will be assigned the same process ID as the job that it is 

processing. Flushing such information instances will actually start a 

new process with a new ID.   

 

6. Breakpoints 

 

Breakpoints stop a running simulation at a specific activity instead of requiring that you step 

through the simulation until you reach the desired activity.. Breakpoints are ordinary SemTalk 

objects which can be navigated, deleted, renamed or listed in a report. 
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Figure 26: A Breakpoint 

 

To add a Breakpoint just use the Breakpoint (STOP sign) shape available in the process 

stencil and connect it to one or more activities using the “breaks” connector. 

 

7. Probes 

 

Probes are tracking the actual usage of a resource, buffer or activity.  In order to open a probe 

window use Tools->Probe menu. Select an object to watch in the following dialog : 
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Figure 27: Selection of an object for a Probe 

 

Probes show the actual usage of a resource, activity or buffer during simulation. They can  

give you hints on how to better optimize your  process.   Please note that probes show real 

time and NOT simulation time. 

 

 
Figure 28:  A Probe on an activity 
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8. Simulation Reports 

 

 

The SemTalk Simulation reports are opened the same way as other SemTalk process reports. 

 

 
Figure 29: SemTalk Process Reports 

 

 

If simulation data is available, the simulation dialog will show a tab having the simulation 

reports. 
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Figure 30: Simulation Reports 

 

You can select a report that covers a single process instance or you can select all process 

instances together. 

  

Activities A list of process steps plus working times, waiting times (simulation) 

and costs taken from the resources 

Tasks A list of process steps aggregated by activity class (task) with working 

times, waiting times (simulation) and costs taken from the resources 

Resources Process steps by resource with activities, working times, waiting times 

(simulation) and costs 

Information All – All information types with the number of instances 

Single process  -  A list of the information objects with their attribute 

values 

 

You can select from all available simulation runs (each simulation run is listed as a time). For 

each simulation run you can run a report on a single process instance or on all process 

instances together. 
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Figure 31: Results of the "Activities" Report 

 

The resulting Excel Sheet contains detailed information for each job such as start time, end 

time, waiting time for resources, synchronization time.  Duration time is the difference 

between the start time of the first job and the end time of the last job. 

  

9. Scripting 

 

The use of post conditions opens up some very powerful opportunities, but even more 

sophisticated solutions are available using scripting. VBScript is one of the most popular 

scripting environments. 

  

Before and after the execution of an activity it is possible to call a function. Inside these 

macros you have read/write access to process and simulation data. You can modify SemTalk 

objects, popup dialog boxes or even call up SAP R/3 transactions. 

 

You can add any scripting code to activities. A procedure named “Before” is executed before 

the activity starts and one called “After” is executed afterwards. 

SemTalk Simulation is binding the variable “base” to the SemTalk Object engine. The current 

simulation is bound to the object “sim”.  The variable “job” is bound to the current job which 

is being executed. 

Programming scripts requires a user to have basic knowledge about the SemTalk API.  Some 

samples of how to use this API are in the MS Excel interface to SemTalk. 
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Figure 32: Before and After Macros 

 

 



SemTalk Simulation Tutorial  04/01/2008 

Email: support@semtalk.com 

 

- 32 - 

Figures 
 

Figure 1: Simulator User Interface ............................................................................................. 2 
Figure 2: Customizing dialogs ................................................................................................... 4 

Figure 3: Sample Simulation Process ......................................................................................... 5 
Figure 4: Entry Point Simulation Tab ........................................................................................ 6 
Figure 5: Property Window ........................................................................................................ 7 
Figure 6: Activity Simulation Tab ............................................................................................. 8 
Figure 7: Simulation Trace ......................................................................................................... 9 

Figure 8: Transportation Time ................................................................................................. 10 
Figure 9: Input and Output Logic ............................................................................................. 11 
Figure 10: Assign a resource .................................................................................................... 12 
Figure 11: Attributes of a resource ........................................................................................... 13 
Figure 12: Off-times ................................................................................................................. 14 

Figure 13: Off-time in the protocol .......................................................................................... 15 
Figure 14: Editing an Off-Time ............................................................................................... 16 

Figure 15: A Process with multiple Resources ........................................................................ 16 
Figure 16: Process trace with multiple inputs .......................................................................... 17 
Figure 18: Post Condition Tab ................................................................................................. 18 
Figure 19: Value Constraint on a flow ..................................................................................... 19 

Figure 20: Attribute Constraints ............................................................................................... 20 
Figure 21: Buffers (Read/Write) .............................................................................................. 21 

Figure 22: Remove / Copy ....................................................................................................... 22 
Figure 23: Contents of a Buffer ................................................................................................ 23 
Figure 24: Buffer starting an Information flow ........................................................................ 24 

Figure 25: Properties of a Buffer .............................................................................................. 25 
Figure 26: A Breakpoint ........................................................................................................... 26 

Figure 27: Selection of an object for a Probe ........................................................................... 27 
Figure 28:  A Probe on an activity ........................................................................................... 27 

Figure 29: SemTalk Process Reports ....................................................................................... 28 
Figure 30: Simulation Reports ................................................................................................. 29 
Figure 31: Results of the "Activities" Report ........................................................................... 30 
Figure 32: Before and After Macros ........................................................................................ 31 

 

 


