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1. About Communication Structure Analysis (CSA) 
 
CSA (“Communication Structure Analysis”)1 was described in the late 1980s at the Technical 
University of Berlin by Prof. H. Krallmann and his research team. 
 
CSA methodology was developed to represent and then optimize critical information flows, process 
flow sequences, and the organizational structures that support them.  CSA includes a sequence of 
phases such as analysis, simulation and optimization.  Each is performed in an iterative manner. A 
company model is created based on the definition of key objects and their relationships to one 
another such as activities performed, the role performed by each participant and a description of the 
information needed to complete an activity.  This model is then used to reengineer the organization.  
An important aspect of creating this company model is the definition of key objects by using an 
object-oriented classification system for all of the different elements used within the company 
model.  
 

 

Figure 1:  CSA Company Model [UBIS 92] 

 
There are two primary diagram types used to describe different scenarios about how a company 
operates or should operate.  The first is the Organizational chart. The Organizational Chart shows 
how people or groups of people related to one another.  It also shows all of the management 
structures that support these relationships and the mechanisms that control performance quality.  
This includes a description of who does what and the names given to the roles used to define people 
in the organization supported by a list of the names of everyone working in the organization.  The 
second type of scenario diagram is the Process Diagram.  Process diagrams show the sequence of 
activities, along with all of the physical and human resources used to perform these activities 
including the flow of information through the process.  
 
Organizational charts show the relationships between jobs or roles, business entities and actual 
employees as well as their job descriptions. Operators or groups are associated with hourly or fixed 
costs and capacities such as the hours they are available to work.  These people or groups are then 
assigned activities to perform.   
 

                                                 
1 This methodology was first described in German as „Kommunikationsstrukturanalyse“ (KSA). 
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Process diagrams represent process flows and include connections between each activity referred to 
as associations.  Input triggers are defined to show how often these activities are performed and 
their relative importance to one another so that processing priorities can be set.  These input triggers 
also describe the relationship that this sequence of activities has to the outside world or to other 
process flows.   The activities are either assembled from pre-existing activity lists stored in a task 
library (functions model) or they are dynamically created as people directly define the flow of what 
they do within a Process diagram.  Information flows are represented using information classes that 
define the exact information used and info transfer device classes that define how the information is 
moved from one place to another. If the information flows to more than one activity or output, 
output conditions can be assigned to show the probability of the information flowing one way or 
another.  Information methods allow users to create information dependent models, so it is possible 
to move information differently based on the information involved.  For example, contracts over 
$10,000 may need additional credit checks. Settings within model objects are able to recognize 
special information and reroute a process flow to an external diagram that handles the credit check 
process. 
 
Part of the CSA methodology is the use of refinements of activities or objects so that models do not 
become too complicated.  The general flow is described on the highest-level diagram.  If users want 
to see more detail, they simply open up the refinement to see all of the details.  All of the 
relationships between these objects and their refinements are kept consistent by the methodology. 
 
In SemTalk CSA is the foundation for add-on solutions developed by IbWanner GmbH (Business 
Communication Platform), Knowlogy Solutions AG (SemTalk for E-Government) and Heidorn IT-
Consulting GmbH (hispret for SAP). 
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2. Starting SemTalk CSA Edition 
 
There are two ways to use SemTalk. You can use a version which embeds Visio into a SemTalk User 
Interface or alternatively SemTalk can be used as a Visio 2010/2013/2016 Addin. The second 
approach is recommended e.g. if SemTalk is used together with SharePoint. Please make sure that 
you have installed the “SemTalk Addin for Visio 2010/ 2013/2016”.  
 

 

Figure 2:  SemTalk Addin for Visio 2010/ 2013 / 2016 

 
In order to start SemTalk simply open Visio.  The “New SemTalk” menu give an overview of 
preinstalled templates.  Select “Open Other Drawings” 
 

 
 
 
After the following screen appears, please select “CSA”. 
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Figure 3: Visio SemTalk CSA Edition Visio 2010/ 2013 / 2016 

 
If you do not have Visio 2013 or 2010 and need to use Visio 2007, use “Start->Programs->SemTalk-
>SemTalk4”.  The user interface will be slightly different. Use File->New to select the template: 
 

 

Figure 4:  SemTalk CSA Edition for Visio 2007 
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A CSA Visio SemTalk workspace looks as follows:

 

Figure 5:  Starting SemTalk CSA Edition 

 
You can show the SemTalk Explorer using the Explorer Button on the Home Tab: 
  

  

Figure 6:  SemTalk Explorer 

 
In the Explorer is a structured access to objects contained in your model. 
 
If you do not see Visio’s Pan & Zoom Window located in the lower right corner: 
 

 

Figure 7:  Visio’s Pan & Zoom Window 

 
The Explorer, the Stencil Windows and the Pan & Zoom Window can be “docked” to the borders of 
the Visio pane with or without the auto hide mode.  Turn on the ruler by selecting Ruler from the 
“View” pull-down menu.  Please refer to Visio Help for additional Visio features.  
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Now your diagram will look like this: 
 

 

Figure 8:  Modeling environment 
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3. Describing a process 

3.1. Adding Process Elements 

You can add elements to the existing page: Simply drag them from the stencil to your diagram (or 
“Process”). Objects can be renamed by selecting the object and entering the new name. 
 
A process is a sequence of activities (Activity). It has well defined interfaces. These are Entry Point and 
Exit Point. Between every two of those elements can be an information flow (sends info). You can 
specify which information is exchanged between these process elements.   
 

 

Activity.1

 

  

An Activity refer to a step in a process.  Breaking down an activity into 
more detailed activities is known in CSA as a Refinement. A (sub-) 
process for the detailed activities is being attached to that activity. For 
every inbound “sends info” connector, an (internal) entry point is added 
to the refined process. For outbound “sends info” connectors an 
(internal) exit point (output) is added. In this tutorial, the yellow shape 
will be used for Activities if human resources are to be displayed in the 
Activity.  

Decision

 

The diamond shape may be used for Decisions. 

 

Starting point in a process. The Information being sent comes from a 
different process. 

 

End of a process. Information goes to a different process. 

 
PhysResource

 

A Resource is an object which is required to execute an activity. When a 
Resource is connected to an Activity, the Activity can only be executed if 
the resource has enough capacity and is available. There are basically 
two kinds of resources: PhysResources (physical resources such as a 
laptop) and HumanResources (such as John Smith or the Accounting 
Dept.) 

 
Buffer

 

A Buffer is a storage device for information or in general for objects. 
Objects can be stored in a buffer and afterwards be read from that 
buffer. Typical buffers are the inbox of a mail client or a database. A 
buffer is a dedicated object type. 

 
Adding links is quite simple. Drop the “sends info” shape somewhere on the background. If you hover 
its ends over an object’s “connection point” you are notified by a red square that you can glue the 
relation to that object. Select an ending point and glue your relation to the objects of your choice. To 
link elements you will use the “sends info” shape for links between activities and the “store to” or 
“read from” shape for links between activities and buffers. 
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After adding some elements and connecting them with the “sends info” connector your diagram 
looks like this one: 
 

 

Figure 9:  Adding Process Elements 

 
To speed up the creation of diagrams the quick shapes and the connector tool are very useful. The 
connector tool is available from the Home-toolbar.  
 

 

Figure 10:  Connector Tool 

 
When creating links please make sure that the links are docked to the element. If you drag the end of 
a link over the connection point of a target element, you will be shown the adhesive ability (red box). 
The elements are connected correctly if both arrowheads are shown with red boxes. 

 

Figure 11:  Connecting Two Elements 
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If you do not need to connect elements anymore, quit the “Connector Tool” mode by clicking on the 
“Pointer Tool”. 

 

Figure 12:  Pointer Tool 

NOTE: If connections between object are not possible please verify with View  Snap & Glue (Click 

on the  in the group “Visual Aids”) if “Shape geometry” is checked.  If Snap & Glue is not visible, 
right-click on your Toolbar and select “Customize the Ribbon”.  Make sure you show All Commands, 
select Snap & Glue from the menu and create a Custom Group.  Move Snap & Glue to your New 
Custom Group.  Once it has been moved, drag it to the “View” pull-down menu. 
 

 
 
A first unspecified process might look like this: 
 

 

Figure 13:  A first process with unspecified objects 

 
In order to rename single process elements simply click on the object and type in a new name. 
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3.2.   Assignment of Human Resources using Swimlanes 

 
In CSA, people and organizational groups (Human Resources) are assigned to individual tasks.  
Alternatively, you can also use Visio’s Swimlanes to assign Human Resources.  
 
Let’s first add another Diagram: 

 

Figure 14:   New Process Diagram 

This will create a new “Process” Diagram. You can rename a Diagram directly by: 

• Renaming the active Diagram Tab at the bottom of your window or  

• Right clicking on the Diagram background and selecting Edit or by  

• Using the menu item “Diagram->Edit”  or by 

• Right clicking on the Diagram in your Explorer 
 
Swimlanes are a standard component of Visio’s Flowcharting stencil.  Create a Swimlane using the 
Swimlane buttons on the “Home” tab.  When you insert your first Swimlane the orientation of all 
Swimlanes will be set, vertical or horizontal.   
 

  

Figure 15:  Adding Swimlanes 
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More options can be found on Visio’s “Cross-Functional Flowchart” tab. 
 

 

Figure 16:  Cross-Functional Flowchart 

The title of the Swimlane contains the Swimlane Title name.   If you single click on the Swimlane sub-
header, you can create new roles just by typing a new name.  If you right-click on the Swimlane sub-
header and use the “Select” command, you can choose from existing HumanResources or you can 
create new HumanResources.  
 

 

Figure 17:  Adding Roles to a Swimlane 

 
If you move an Activity to the Swimlane, the Activity will be automatically assigned to the role 
designated in the Swimlane.  
 
Inputs and outputs of Activities are readily seen by viewing the Information Flow between objects.  
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A process with information flow might look like: 
 

 

Figure 18:  Process with Swimlanes and Information Flows 

It is possible to assign additional human resources to individual Activities. The additional role 
assignments only apply so long as the Activity stays in its original Swimlane. 

3.3. Object-Oriented Process Modeling 

 
If you select the toolbar menu Object->Compose or right click Compose, you specify that you are 
using Object-Oriented Activities and Entry/Exit points naming conventions. 
 

  

Figure 19:  Composing Object-Oriented Activities 
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Class Objects determine the relationship an object has to other objects and they keep naming 
conventions consistent.  Once a “Class” name has been created, it can be used many times.   
 
You can reuse existing Classes or you can create new Classes using a bottom up modeling where 
objects are defined as you model.  e.g. “Bid” is an existing class name created using Compose.  When 
it was created, it was associated with the State “completed”.  “completed Bid”  is used to describe 
the Class + State (category of the thing that is acted upon).   “Send completed Bid” is the Activity 
name that is composed by combining the Class “Bid” with the State with the Method (verb) “Send”.  
 

          
Compose to define reusable Class “Bid”         Dialog to Name new Activities using Compose 
 
State and Attribute options allow users to specify which feature will be used to create the Activity 
name.  In CSA methodology, Methods are only relevant for Activities and they are usually verbs. 
 
In the combo box Method the name of the method (or verb) can be newly entered or it can be 
selected from previously defined Methods. 
 
SemTalk always creates Classes and Method if they do not yet exist in the database. In our example a 
Class named “Solution” will be created with the method “Develop”. 
 
The advantage of using Compose is that Activity names generated from Class and Method names 
are updated automatically if any Class or Method names are renamed.  Methods (as well as 
Attributes and States) can be inherited from Superclasses.  
 
The order of how Activities are named is language specific (“Send Bid” or “Bid Send”).  Method-
Object word order is a general setting in the SemTalk Options-Language dialog. For English you will 
use “Method Object”. 
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Options-SemTalk Options-General tab is where you can specify “Compose” as your default when 
naming new objects: 
 

  

Figure 20:  Settings - Object-Orientated Modelling 

 
Here is a newly created Process with object-oriented Activities (there are not Swimlanes so the 
yellow Activity shape is used): 
 

  

Figure 21:  An Object-Oriented Process 

 

  



SemTalk CSA Tutorial 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2001-2018 
 

Page 17 of 46 

Information objects “Order” and “Customer” are created in a separate Information diagram: 
 

 

Figure 22:  Object Model 

 
If  “Special Offer” is a subclass of “Bid“ in an Information diagram, “Special Offer” will inherit all 
Methods from “Offer”.  These inherited Methods will be shown in the Method combo box in the 
Compose dialog. 
 
SemTalk ensures the consistency between Object models and Process models. If you rename a Class 
or Method, all Activities composed using the edited Class or Method will be updated to the new 
name. 
 
We recommend object-oriented process modeling especially for large projects. It is a good idea to 
define in a first step the most important business objects and build a catalogue of methods (verbs). 
This is the foundation of consistent process models.  
 
If you are going to use the same business objects in multiple projects we recommend storing object 
libraries in SharePoint or in separated files that can be published on the Intranet or Extranet.  

3.4. Editing Process Elements 

You can now edit diagram objects by: 
1. Double clicking on the object or 
2. Right Clicking “Edit”on the object or 
3. Select & Menu “Object->Edit” or 
4. Right-click on it in the Explorer as a child of “Diagrams->Process-> <YOUR PROCESS NAME>” 

or 
5. Right-click on it in the Explorer as a child of “Objects->”. 

 
If you want to rename an object, select it and type-in the new name.  
You can also use the Properties Window, to review and change values directly. (Home->Properties) 
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Figure 23:  Properties Window 

3.4.1. Activity Dialog 

 
The Activity dialog looks like this: 

 

Figure 24:  Activity Edit Dialog 

The Activity name (“Enter Order”) is automatically derived from the name of the class (“Enter 
Order”). You can assign other classes to an activity.  In order to recompose the activity, which means 
renaming parts, you should use the compose dialog.  Otherwise a new activity class will be generated 
which is not object-orientated. 
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Activity Index numbering can be changed. This is especially relevant for the MS-Project export. The 
Index is shown in the top right hand corner of the Activity. In order to renumber all activities of a 
process select the first Activity where the renumbering should start. Choose Diagram  Renumber 
in the Ribbon menu to  renumber.  Renumbering will be applied to all following Activities. 

Right mouse click “New” ( ) to add Links (hyperlinks, attachments, documents).  Links can be 

removed by right click “Remove” (  ) on the list of Links. Double clicking the link in the list box 
opens that document with the (for windows) associated application. In the new hyperlink dialog you 
specify the path of the document with the field “Address”. With properties you can specify with 
which name the document is displayed (otherwise the document path is chosen). The language 
determines whether the document is displayed generally or only in specific languages. Properties for 
HTML view determines whether the document is shown in a new window (check “New Window”) or 
not. Activities having at least one link will show up with a little marker in the upper left corner. 
 

 

Figure 25:  Assign Documents to an Activity 

Multiple documents can be attached to an Activity. 
 
NOTE: In order to change properties of all occurrences of an Activity, you must “Edit” the class itself 
using “Object->Edit Class”. 

3.4.2. Activity “Hum. Resource” Tab 

 
On the “Hum. Resource” tab you can assign “Human Resources” to the activity. These are people, 
roles or organizational units which actually execute the Activity. The left hand list box shows the 
currently assigned resources and the right hand list box shows the list of all available Human 
Resources. 
You may use the arrow buttons to add / remove resources. Double clicking in the list boxes will edit 
the resource. 
 
The right “Human Resource” combo box allows filtering resources by class. 
 The left “uses hum.resource” combo box having the selection” allows” to specify certain types of 
execution such as “controlled by” or “supervised by”.2  

                                                 
2 These could be defined as subclasses of the relation “executes” 
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Figure 26:  Activity – Hum.Resource 

Using the new button you can add new human resources and new human resource classes. 
The new instance will automatically get the class which is selected in the combo box. 
 

  

Figure 27:  Adding new Human Resources 

You can view / edit all existing resources in the Explorer as child nodes of “Human Resource”. 
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In the process the resources are now displayed in the lower section of the activity shapes: 
 

  

Figure 28:  Activity with Roles 

3.4.3. Activity “Condition” Tab 

 
The Condition tab allows input and output conditions to be specified.  Input and output conditions 
are relevant for Simulation. 
 

 

Figure 29:  Activity - Condition 
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Input condition: 
 

AND Process is waiting for tokens from all inbound sends-info links. 

OR Process is waiting for one inbound sends-info link token. 

AND (sync) Process is waiting until tokens with the same color (same original input) arrive 
from all inbound sends-info links. This option is used for synchronization. 

  
Output condition: 
 

AND A token will be sent to all outbound sends-info links 

OR A token will be sent to all outbound sends-info links if a random number is lower 
than the probability specified on the sends-info link. 

XOR A token will be sent to the first outbound sends-info link if a random number is 
lower than the probability specified on the sends-info link. If test fails, the next 
link will be tested. 

INFO A token is sent to the outbound sends-info link if the incoming object is an (direct 
or indirect) instance of the class specified on the link. 

 
Conditions are not displayed in CSA.  Some users prefer to show explicitly which activities are 
decision points. This can be done with the “Decision” Shape (similar to “Gateway”) in BPMN. 

 

Figure 30:  Using the Decision Shape 
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3.4.4. Activity “Measures” Tab 

The “Measures” tab allows the processing time, fixed cost, variable cost and probability. Some of 
these attributes are used in reports and at MS Project export. 
 

 

Figure 31:  Activity - Measures 

Relevant for simulation. “Processing Time” is especially important for Work Plan Report, MS-Project 
etc.  For all other measures, please see the Simulation 
Tutorial.(http://www.semtalk.de/manuals.html). 
 
NOTE: SemTalk uses an 8 hour day as its default.  For simulation it might be useful to change to a 24 
hour day clock. (Options  SemTalk Options  General). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.semtalk.de/fr_index.html?/manuals.htm
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3.4.5. Activity “ERP” Tab 

 

Figure 32:  Activity - ERP 

Using this tab transaction IDs and input / outputs can be specified. If you use the SAP R/3 import 
transactions will be associated from the reference model. Activities that have at least one transaction 
will be drawn with a thicker border. This tab is hidden using the default configuration. It can be 
activated by Customize (Dialog). 

3.4.6. Information Flow Dialog 

Note on CSA Methodology: 
  

Activities are related by Information Flows (“Sends Info’ + “Media”).   A control flow of type 
“Sends Info” determines the sequence or order in which Activities are executed. A sends info 
link is also an object, or dataflow, which specifies the information or output exchanged 
between two activities. An output of one Activity will be a precondition for the next 
activities. 
 
In order to analyze media breaks, it is essential to model Media which are used to transport 
Information. Typical classes of media are email, letters or other documents. 
CSA method has third level colored Petri Net semantics, which can be implemented in 
simulation engines. Activities have preconditions like synchronization and output behavior 
like parallelization. 

 



SemTalk CSA Tutorial 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2001-2018 
 

Page 25 of 46 

 

Figure 33: Information Flow - Object Flow 

The “Object Flow” tab allows you to specify the information or object which is “flowing” between the 
two connected activities. 
 
You can select existing Information (or Media) from the combo boxes. If you select an information 
type or enter a new one, you must click on the “Add” button in order to add it to the list of 
Information that flows. 
 
Object composition is done similar to the “Compose” for Activities. 
 
Root Class is the base object type: Information, Physical Resource, Media etc. The most used business 
object type is Information. 
 
Class is the object. You can reuse existing classes or create new classes in a bottom up modeling style. 
 
State (and Attribute) is the state of the object which is being send e.g. “Order entered”. 
 
You can remove an object from the list by double clicking it or by clicking the “Del” Button. 

NOTE: In SemTalk CSA Edition you may assign more than one Information for each relation.  
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Figure 34:   Information Flow - Measures 

The “Measures” tab allows the specification of transportation time, fixed cost, variable cost and 
probability. 
 
NOTE: You can glue relations to any point on the object if you select the Visio option “Glue to 
geometry” (View -> Visual Aids) 
 

 

Figure 35:  Visio’s Snap & Glue Options 

3.4.7. Edit physical resources 

 
Note on CSA Methodology: 

A Resource is an object which is required to execute an Activity. The Activity can only be 
executed if enough capacity of the Resource is available. There are basically two kinds of 
resources - Physical resources such as laptops and Human Resources like an organizational 
unit. 
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Please add a resource to the process: 
 

 

Figure 36:  Process with a Physical Resource 

Connect it to “Assign Customer” with a “uses phys.resource” connector.  
 
NOTE: You may insert the same physical resource more than once into a process using right-click 
insert and check “Insert (Model)”. You may not insert the same Activity more than once, but you can 
make multiple connection to the same Activity. 
Next step is to edit the Resource. The General tab is identical to other dialogs. 
 

 

Figure 37:  Dialog - Measures 
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PhysResource Measures tab contains fields that are primarily used for simulation purposes. Variable 
cost can vary based on the conditions that are present when the resource is used. Fixed cost is a cost 
factor that occurs each time a resource is accessed. 
 
When modeling PhysResources it makes sense to create a PhysResource Class Diagram where all 
types of resources are specified.  When these pre-defined resources are inserted into a Process 
Diagram, assigned shapes are consistently displayed. 
 
Creating Class Diagrams allows you to create specific rules for the object.  For example, if an objects 
has Printer as its super class you will be allowed to edit your Printer child object to any other subclass 
of Printer that has been previously modeled, but you cannot assign it as a subclass of Beamer.  If your 
object is both a printer AND a Beamer, you can assign both parent objects and then when you make 
changes, both printer and beamer object types will be accessible. . 
 
Class models can be created for each resource type. 
 
NOTE: Assigning shapes to your class objects only makes sense if you will be creating instances of 
that type in Process or Organizational Diagrams.   
 
NOTE2:  Subclasses of activities may be depicted by special symbols or by changing the layout of 
system shapes. 

3.4.8. Buffers (Information Storage Devices) 

 
Drag a “Buffer” onto your process diagram and name it “CRM System”.   Connect it to “Enter Order” 
with “store to” or “read from” connectors. These relations describe whether you store information to 
the buffer or whether you read information from the buffer. 
 

 

Figure 38:  Process with Buffer 
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CSA Methodology Note: 
A Buffer is a storage device for information or in general for objects. Objects can be stored in 
a buffer and afterwards be read from that buffer. Typical buffers are the inbox of a mail client 
or a database. A buffer has a dedicated type. 
 

Define which type of Information is stored in the Buffer in the Buffer’s Edit - Information tab. 
 

 

Figure 39:  Adding information to Buffer 

 

Figure 40:  Buffer "Measures" Tab 

Fixed Cost is used to assign a cost for each object of information stored or retrieved to/ from the 
buffer. Capacity of the Buffer limits the amount of Information objects that can be stored in the 
buffer. Flush level and flush number are used to specify that Information is sent via “sends info” if a 
certain number on Information objects is reached or if a certain time is exceeded.  
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The “store to” relationship lets you select the type of Information which is stored into the Buffer. 
 

 

Figure 41:  "store to" Object Flow 

 

 

Figure 42:  Access to a Buffer 

 
 
NOTE: You can also edit the label of “read from” or “store to” connectors directly to specify the 
Information flow. 

4. Org. Charts 
Org. Charts are used to graphically describe the organizational structure of your company. You may 
add new element using shapes for Org Unit and Position and connect them with the “superior of” 
connector.  
Create a new Org Chart (Diagram  New  OrgChart). Using Diagram->Insert (Model) you can add 
the existing Org Units “Sales” and “PD” to the org chart. 
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Figure 43:  Org Chart 

If you edit an Org Unit or Position, you may add Persons to the element. 
 

 

Figure 44:  Adding Persons 

 

A person can be edited directly by double clicking their name in the list.  OrgUnits are resources with 
measures like Fixed Cost, Variable Cost and Capacity. 
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Figure 45:  Org Chart with Persons 

5. Class Diagrams 
 
Open a Visio Stencil using More Shapes  Network.  Please open the Visio Stencil “Networks and 
Peripherals” to open a Visio Master Stencil.  You will find the stencil for Visio 2007 at “C:\Program 
Files\Microsoft Office \1031” or for Visio 2003 at  “C:\Program Files\Microsoft 
Office\VISIO11\1031”.3 
 
If you drag an arbitrary Visio master shape onto your process sheet, SemTalk is not able to 
automatically recognize the shape in the context of your current modeling method.  Therefore a 
dialog will open asking you to select which object type should be assigned to the new shape.  Your 
options will be limited to those object types in your current modeling methodology.  For example, if 
you drag in a new Copier shape, it should be made a subclass of PhysResource.  If you “Ignore” the 
choices, it will just remain a Visio shape without associated SemTalk dialogs and properties and it will 
not be added to the SemTalk database. 
 

                                                 
3 If you are using Visio Shapes frequently it makes sense to change file path for stencils (2003) or “My Shapes” (2007) using 
Visio’s options dialog. 
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Figure 46:  Adding a New Visio Shape to a Process 

Instead of using this bottom up approach, new classes of Resources can be defined on class pages.  
Create a new diagram of type “Phys. Resource Model” and drop some shapes onto your new 
diagram. 
 
In the new diagram you can create classes and subclasses with attributes and associations.  Add a 
new class by using the “UML Class” shape.  A “subClassOf” (or “is a”) relationship between two 
classes is created with the “subClassOf” connector. Associations are made with the “Property” 
connector. 
 
It is a special behavior of class diagrams that every class is automatically a subclass of their root class.  
In our current example the root class is PhysResource.  All objects on a Phys.Resource.Model class 
diagram is automatically a member of the PhysResource class. 
 
You can add new classes by opening a Visio stencil or search for a shape. Drop the shapes onto a 
PhysResource Model or drop them onto the document stencil in case the shapes does not exactly have 
the intended name. If the shape does not have the right name it must be renamed in the document 
stencil and afterwards dropped on the page. 
 
The document stencil (More Shapes->Show Document Stencil) will now contain copies of the used 
Visio masters. Using right click master properties on the master you can rename the master to a class 
name of your choice. Please rename “CRT projector” to “Beamer”. 
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The properties of the Visio master are becoming attributes of the class. 

  

Figure 47:  Visio Shapes for PhysResources in the Document Stencil 

 

Now you can create further subclasses and super classes. 

  

Figure 48:  Classes of PhysResources 
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We have used new Visio shapes for Printer, Plotter and Multi-function Device4.   Printing Device has 
been created using the UML Class master shape. 
 
NOTE:  Effective object-oriented models define attributes on a common superclass rather than in the 
classes that have been created using Visio masters. 

6. Refinements 
 
CSA Methodology NOTE: 

Breaking down an Activity into more detailed activities is known in the CSA as creating 
Refinements.  A Refinement of an Activity is a linked diagram that contains more details about 
how the Activity is performed.  In CSA, objects that are the Refinement of other objects are 
automatically attached to the parent object.  In process diagrams these are Activities at the 
highest level (most abstract level) of the model and sub-activities/ sub processes in the 
Refinements.  Information flowing into an Activity that is refined, executes all of the refined 
activities before it triggers the Information flow to the next highest level Activity.  This means 
that for every inbound “sends info” link an (internal) entry points are added to the refined 
process. For outbound “sends info” links an (internal) exit point is added.  

 
Right Click on “Assign Customer” and select “Refine” or select the activity and use the “Refine”-

button ( ) in the home tab of the ribbon menu.  Navigation is available on the “Home” tab.  The 
Navigation tabs allow you to go from the Refinement to the parent process. When creating a 
Refinement, a dialog will pop up asking for the name of the sub process.  In most cases it is best to 
use the automatic name provided by SemTalk. 
 

 

Figure 49:  Creating a Refinement 

 
When the new Refinement opens,  internal entry and exit point are automatically generated and any 
PhysResorces that were connected to the parent Activity will also be shown. 
 

                                                 
4 These shapes are much easier to use if you turn off  “Snap to Grid” 
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Figure 50:  A New Refinement 

 “Assign Customer” is now underlined on the top level process to show that the Activity has  a 
Refinement.  Whenever “Refine” is selected, the Refinement will open. For navigation from the 
Refinement to the parent process, use the “Go Up” in the process context menu process or click on 
the “ “ button in the Home or Diagram tab. 
 
For every Information flow coming from, or going to, a Refined Activity, internal entry point and exit 
points are generated in the sub-process. If you connect a new information flow to or from a refined 
Activity, a new entry or exit point will be created automatically in the Refinement. 
 

 

Figure 51:  Internal EntryPoint 

 
Double clink on an Internal Entry or Exit object in your Refinement.  Click on the Condition tab.  There 
you will see a “Links” list that names the Entry Activity (ies) connected to the InternalEntry object.  
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Every proceeding process connected to an InternalEntry by a “sends info” link) will appear.  The Edit 
dialog for Internal Exits is similar to the Edit dialog of Internal Entries.  Here are all valid Exits will 
appear. 
 
You can see in your Explorer that the new Refinement process is shown as a child node of the higher 
level process. 
 

 

Figure 52:  A Process Refinement Diagram 

 
NOTE:  If you use the “External” option when creating a Refinement, you can assign a process in a 
different model as the Refinement.  In this case the Refinement works like a hyperlink to the other 
model.  This option is not available for Entry or Exit objects. 
 

6.1. External Refinements 
 
In addition to being able to assign a default or an existing process diagram from your model as your 
Refinement, you can also assign diagrams from external process models (files) as an Activity 
Refinement.  When selecting the “Refine” command, click on the “External” button. Choose another 
SemTalk model (xml file) and confirm with “OK”.  The combo box “Diagram” will now show the 
diagrams of the external file. 
 
NOTE:  External Refinement is method independent which means that you can use EPC process 
models as Refinements in CSA models. 
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6.2. Attachments and Visio-Hyperlinks 

Refinements are used to create unique, structured decompositions of processes. Attachments are 
used to assign unstructured information such as documents, hyperlinks or arbitrary Visio pages to an 
object.  Select an object and add an Attachment by selecting “Home->Hyperlink” or by double-

clicking on the object and clicking on the  link in the Edit dialog.  The following dialog box will 
open: 

 

Figure 53:  Editing Hyperlinks 

 
Address is used to attach documents or Hyperlinks. Use the Subaddress option to attach other Visio 
pages.  Language associates the document with a particular language such as English or German. You 
may attach as many documents as you need. Please visit the general tutorial for further information. 
 
Document Navigation along with associated HTML representations are created via Visio-Hyperlinks. 

 

Figure 54:  Navigation with Hyperlinks 
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7. Simulation 
 
Simulation is available for SemTalk CSA Edition.  CSA is the only SemTalk method that implements all 
of SemTalk’s simulation functions.  Simulation allows testing the logical behavior of your process to 
identify optimization possibilities or to check the completeness of your model. 
 
Using colored Petri-Nets you can investigate your process in a dynamic environment with multiple 
inputs processed in parallel making it easy to find out bottlenecks or identify the need for additional 
resources. 
 
Please refer to our Simulation Tutorial for additional details.  If you would like to view Simulation 
functions and features be sure to show the Simulation Tab on your menu ribbon.  If it is not currently 
shown, go to Options and right mouse click on a blank area on the right of the toolbar and choose 
“Customize the Ribbon” and click on Simulation in the right frame of the dialog box. 

  

Figure 55:  Simulation 
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8. Reporting 
 
All process models can by analyzed by using the Report Editor. The report editor is found in the 
“Report” tab in the ribbon menu. Use the Report Editor to create individual reports for specific 
objects. In order to create more generic reports you choose the Process Editor. 
 

8.1. Process Editor 
 
To create a report use Report  Process Editor. You will see the following dialog: 

 

Figure 56:  Process Editor 

The General tab provides different report options. You can generate reports of all model objects 
(Information, HumanResources, Media, PhysResources, Buffers, Systems) . Furthermore, you can 
analyze Communication, Media Breaks and Systems Breaks in your model.  Start a Report by 
choosing one option and clicking the Execute button.  Select sub classes of parent classes by using 
the combo boxes next to the options. 
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8.2. Workplan for CSA 
 
“Workplan” tab creates Workplans for your processes.  Create an Excel Workplan by selecting the 
process and pressing the Execute button. 
 

 

Figure 57:  Process Editor - Creating Workplans 

8.3. Simulation Reports 
 
The “Simulation” tab generates simulation reports of specific process instances.   You must first run a 
simulations before generating a simulation report.  Start the simulation by using Simulation  Show 

in the ribbon menu and click the Run button or by using the symbol  in the simulation window. 
 
NOTE:   If the Simulation tab is not visible, go to Options and right mouse click on a blank area on the 
right of the toolbar and choose “Customize the Ribbon” and click on Simulation in the right frame of 
the dialog box. 
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Figure 58:  Starting a Simulation 

 
Generate a simulation report by selecting a Simulation Run from the Process Instance combo box and 
choose the object type (“Process Steps”, “Activity”, “Resources”, “Information”) you want to analyze.   
Click the Execute button.  This will open the report in an Excel sheet. 
 

 

Figure 59:  Simulation report 

 
Please refer to our Simulation Tutorial for details. 
http://www.semtalk.de/manuals.html 
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9. XPDL Export Import 
 
The XML Process Definition Language (XPDL) has it origin in the text-based workflow exchange 
format of the Workflow Management Coalition (WfMC Interface 1) 
 

• Allows tools to exchange process models 

• Formats to be able to exchange Process Definitions between  
o Components within Workflow/BPM Products 
o Different BPM/Workflow Products 
o Process Modelling/ Simulation Tools and BPM/Workflow Products 

 
In SemTalk you will find XPDL Export at File->Export->BPMN-> XPDL Export (1.0 or 2.1) or as (File-
>SaveAs->BPMN). 
 

 

Figure 60:  XPDL Export 1 
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Figure 61:  XPDL Export 2 
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