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1. About Event-driven Process Chains (EPC) 
 

 

The concept of “Event driven Process Chains” (EPC’s) was introduced by Keller, Nüttgens 

and Scheer in the early 1980’s.   

 

SemTalk EPC Edition is a standard SemTalk methodology based on the extensive project 

experience, extending the EPC method to integrate object-oriented process modeling to better 

support the creation of reference models. 

Key functions include: 

- Automatic semantic check of EPC symbols during modeling 

- Direct export / import of ARIS models 

- Automatic selection of methodologically consistent connectors and object types. 

 

Note: This tutorial assumes that the reader is familiar with basic Visio commands and the 

general SemTalk tutorial that covers information about basic SemTalk functions such as: 

• Modeling classes with attributes, associations, and inheritance, 

• Adjusting textual layouts, 

• Navigation: Expand, Search, GoTo & Paste; 

• Integrating objects from external models & 

• SemTalk implementation 

 

EPC shapes are shipped with Microsoft Visio.  While Visio-based business process modeling 

using Visio with EPC shapes is easy to use, Visio alone is of limited use because it is not 

possible to show differences between model objects or to alter how they are shown in 

diagrams. Navigation through the model is also cumbersome.  Export / import of model 

information is limited and few meaningful reports can be produced.  Sharing model 

information with others, in applications such as SharePoint, is also not possible.  Without 

adding SemTalk functionality, model consistency is difficult to maintain and model 

information is difficult to share and update.  SemTalk delivers access to EPC methodology 

rule-based modeling so models are syntactically correct, consistent and meaningful.  This 

insures that technical interface descriptions and reports are of the highest quality.  SemTalk 

integration with SharePoint makes it easy to share and maintain modeling data over time at 

minimal effort and maximal benefit 

 

  

2. Opening the SemTalk EPC Edition  
 

After installing SemTalk, open Visio.  SemTalk will start automatically.  If you are already 

using Visio, simply select “Open Other Drawings”" file menu and select “New SemTalk". For 

all Visio versions prior to Visio 2013, please make sure that you have installed the “SemTalk 

addin for Visio 2010” for Visio 2010.  In this case, use "New SemTalk" to select your desired 

template. If you have questions, please contact support@semtalk.com 

 

 

mailto:support@semtalk.com
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The “New SemTalk” menu gives an overview of preinstalled templates. Please select “EPC”. 
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After opening Visio you should see a window that looks like below: 

 

 
 

If the SemTalk Explorer is not open, click on the Explorer Button on the Home Tab. 

 

 
 

The SemTalk Explorer gives you structured access to objects in your model and can be used 

to add additional objects. 

 

 

2.1. Quick Review of Key Visio Window Commands 

 

Visio’s Pan & Zoom Window located in the lower right corner: 

 

 
 

The Explorer, Stencil Windows and pan & Zoom Window can be “docked” to the Visio pane 

borders, with or without using the Auto hide mode. 

 

The Visio Ribbon: 

SemTalk add-in for Visio supports Visio’s customized ribbon and window layouts so that 

your workspace fits your unique modeling needs. Almost all of commands found in pull-

down menus can be docked into your workspace.  Simply right click on the command and 

select your desired viewing option for the command.  Please refer to Visio documentation for 

additional help.  
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2.2. EPC Ribbon Tab 

 

When EPC Notation is used, the ribbon will display the tab “EPC“, where special options for 

EPC notation are available. 

 

2.2.1. Consistency Checks 

 

The Consistency segment of the ribbon contains options to check model consistency. 

• Check Rules continuously: Allows SemTalk to live check model content for EPC rules 

compliance while modeling. This option is best used in combination with “Mark 

Issues in Red” option so that consistency errors are immediately visualized. If enabled 

after SemTalk objects have already been created, existing objects are not re-checked, 

only newly created objects will be checked. Hit the refresh button to check all 

previously modeled objects. 

• Mark Issues in Red: Shapes that do not comply with EPC rules are shown in red. 

• Check Split/Join on Operators: EPC method defines that Operators (OR, XOR) used 

to split process flows should merge again. When enabled, SemTalk marks missing join 

Operators as issues. 

• Check Model Consistency: Checks the consistency of the entire document and opens a 

window showing all found issues. If the Consistency window is open, and “Check 

Rules continuously” is enabled, the issue list is automatically updated as the user is 

working. 

2.2.2. EPC Rules Options 

 

The Rules Dialogs segment of the ribbon contains options to extend or optimize EPC 

modeling. 

• EPC Semantics: Enables SemTalk to force users to adhere to strict rules when building 

EPC models (e.g. correctly use operators, correct number of incoming or outgoing 

flows). When enabled, certain connections are not possible. 
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• Add Start and End events at refinements: Start and End event shapes are automatically 

added to internal refinement pages if the refined Function is correctly connected to 

named events prior to the refinement being created. 

• EPC Connection Point Optimization: Checks to see if connectors leaving a 

downstream operator are attached to the correct side of the operator. This option is not 

a true consistency check, it is designed to support better data visualization.  

• Extend EPC Notation: Extends basic EPC classes in the EPC Meta model by assigning 

the following classes SemTalk object functionality: 

o Application system type 

o ERM Attribute 

o Key performance indicator instance 

o Knowledge 

o Module type 

o Risk 

o Screen 

The corresponding shapes are in the EPC stencil already included. 

 

2.3. SemTalk’s Visio EPC Stencil 

 

SemTalk’s Extended EPC Stencil contains the following objects: 

 
NOTE:  For additional information about the use of individual objects, please refer to EPC 

Reference manuals and websites such as https://en.wikipedia.org/wiki/Event-

driven_process_chain  

 

3. Opening the SemTalk EPC Edition 
 

3.1. Adding Process Elements 

 

New elements can be added to the existing processes by simply dragging desired objects from 

the Stencil to your diagram (or “process”).  Rename your new objects by double-clicking on 

https://en.wikipedia.org/wiki/Event-driven_process_chain
https://en.wikipedia.org/wiki/Event-driven_process_chain
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the object and entering the new name or by using SemTalk’s Compose feature described in 

this Tutorial under ‘Object-Oriented Process Modeling with EPCs’. 

 

3.2. EPC Methodology Review: 

 

A process is a sequence of Functions, Events, Operators and other elements.  

 

Functions are activated by one or more preceding Events and they are able to trigger  

Events. Functions can have only one incoming link (Control Flow) and one outgoing 

link. If multiple Events are involved, operators such as AND, OR; XOR must be used.   

 

3.2.1. EPC Object Types with Standard Graphical Representations 

 

 

Events are passive elements in EPC. They describe under what 

circumstances a function or a process works or which state a function or 

a process results. Examples of events are “requirement captured”, 

“material on stock”, etc. In the EPC graph an event is represented as 

hexagon 

 

Functions are active elements in EPC. They model the tasks or activities 

within the company. Functions describe transformations from an initial 

state to a resulting state. In case different resulting states can occur, the 

selection of the respective resulting state can be modeled explicitly as a 

decision function using logical connectors. Functions can be refined 

into another EPC. In this case it is called hierarchical function. 

Examples of functions are “capture requirement”, “check material on 

stock”, etc. In the EPC graph a function is represented as rounded 

rectangle. In general, a EPC diagram 'must' start with event and end 

with event. 

 Process Owner:  Usually part of the Organizational Unit who is 

responsible for a Function. 

OrgUnit.831

 

Organization units determine which person or organization within the 

structure of an enterprise is responsible for a specific function. 

Examples are “sales department”, “sales manager”, “procurement 

manager”, etc. It is represented as an ellipse with a vertical line. 

 

In the EPC, the information, material, or resource objects portray 

objects in the real world, for example business objects, entities, etc., 

which can be input data serving as the basis for a function, or output 

data produced by a function. Examples are “material”, “order”, etc. In 

the EPC graph such an object is represented as rectangle. 
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Branch and merge correspond to making decision of which path to 

choose among several control flows. A branch may have one incoming 

control flow and two or more outgoing control flows. When the 

condition is fulfilled, a branch activates exactly only one of the 

outgoing control flows and deactivates the others. The counterpart of a 

branch is a merge. A merge may have two or more incoming flows and 

one outgoing control flow. A merge synchronizes an activated and the 

deactivated alternatives. The control will then be passed to the next 

element after the merge. A branch in the EPC is represented by an 

opening XOR, whereas a merge is represented as a closing XOR 

connectors. 

 

Fork and join correspond to activating all paths in the control flow 

concurrently. A fork may have one incoming control flow and two or 

more outgoing control flows. When the condition is fulfilled, a fork 

activates all of the outgoing control flows in parallel. A join may have 

two or more incoming control flows and one outgoing control flow. A 

join synchronizes all activated incoming control flows. In the EPC 

diagram how the concurrency achieved is not a matter. In reality the 

concurrency can be achieved by true parallelism or by virtual 

concurrency achieved by interleaving. A fork in the EPC is represented 

by an opening ‘AND’, whereas a join is represented as a closing ‘AND’ 

connectors 

 

An ‘OR’ relationship corresponds to activating one or more paths 

among control flows. An opening ‘OR’ connector may have one 

incoming control flow and two or more outgoing control flows. When 

the condition is fulfilled, an opening ‘OR’ connector activates one or 

more control flows and deactivates the rest of them. The counterpart of 

this is the closing ‘OR’ connector. When at least one of the incoming 

control flows is activated, the closing ‘OR’ connector will pass the 

control to the next element after it. 

 

 

3.3. Compare Versions 

SemTalk allows users to compare two documents to display the differences between them, 

such as when comparing different versions of the same process document.  

 

Both documents need to be opened in the same Visio instance for the comparison tool to 

work. The Compare functionality is found in the Tools tab, in the Consistency segment. Use 

“Compare Versions”, to start the comparison. Here users select what kind of process 

information to compare. “Select All” compares all information. “Save Changes to File” option 

creates a .txt file which includes all comparison results. Click on the OK button to start the 

comparison.  
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All differences are listed in the subsequent pop-up window. In the screenshot example below, 

the ‘document read’ Event was renamed to ‘document saved’ and the Function “read 

document” was changed to ‘save document’. Version comparison recognizes this and displays 

these name changes as ‘missing’, meaning that a Function/Event does not exist in a version 

because when the object was renamed, it became a different object.  

Arrows to the left of the Object column indicates whether the item was in the first document 

opened or the second. An arrow pointing left refers to the first document and arrow to the 

right refers to the second document. Users can click on the rows to highlight the shapes in the 

Visio diagram. 

 

 
 

Changed Attributes and Human Resources, etc. will also be indicated, as can be seen in the 

screenshot.  

 

3.4. Relationships between EPC Elements:  

• Control flow is used when connecting Events and Functions.  

• Information Flow is created using the flow of information between Functions and 

Entities.  
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If you have created three Events and two Functions, the process would look like the 

following example: 

 

 
 

The following object descriptions are borrowed from http://en.wikipedia.org/wiki/Event-

driven_process_chain (Jan. 2007): 

 

Function 

  

A function is a task or activity using information 

objects to support one or more business objectives. 

Event 

  

An event describes a relevant state of an information 

object that controls or influences the further 

execution of the business process. It is generally 

preceded by a verb and is always followed by a 

noun (e.g. Order product). 

AND 

v

 

AND Object  

The overall statement is true when both statements 

are simultaneously true. 

OR 

v
 

OR Object  

The overall statement is true when either statement 

is true. 

XOR 

XOR

 

XOR Object  

The overall statement is true if one set of statements 

or the other set of statement is true 

 

 

3.4.1. Add a New Association Connector 

Adding Associations to your EPC diagram is quite simple. Drop a “Control Flow” association 

connector shape from your Stencil  onto your EPC diagram. If you hover its ends over one of 

the object’s “connection points”, you are notified by a green square that you can glue the 

http://en.wikipedia.org/wiki/Event-driven_process_chain
http://en.wikipedia.org/wiki/Event-driven_process_chain
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relation to the object. Then drag the connecting arrow to a connection point on your target 

object. A green square will appear when the connector is over the target object. If an 

association is not allowed, an error message will appear that the association between the 

connector and the object or between the two objects is not allowed.   

 

After adding some elements and connecting them with the “Control Flow” association 

connector, your diagram will look similar to this one: 

 

 
 

Visio’s Auto-Connect function and the Connector Tool found in the Home menu are useful 

ways to speed up modeling. When using the Connector Tool , you are in a "connection 

drawing mode".  Cancel this mode by right-clicking the background of the chart and selecting 

"pointer tool". 

 

You can also use the Auto-Connect Shape feature to link new objects to your already created 

objects.  Move the mouse to the Event or to the Function you have created.  Pale blue arrows 

will appear that point in different directions.  Click on one of the arrows to create a 

connection to an allowed connector or Objects shape you want to connect to your object.  

  

NOTE:  You can use any Visio connectors that have two endpoints.  The SemTalk add-in will 

either assign the correct relationship type to the graphic connector or, if there are no possible 

relationships between the two objects, an error message will appear stating that the objects 

cannot be connected.   

 

3.4.2. SemTalk’s EPC Syntax Rule Checklist: 

 

• Functions and Events may have only one outgoing control flow. 

• Functions and Events may have only one ingoing control flow 

• Each control flow must connect two different objects 

• It is not allowed to use an OR or XOR operator after an event, since events are passive 

elements, which can make no decisions as functions do 

• Operators may have multiple inputs (Join) or multiple outputs (Split), but not both 

• Outputs of an operator must be of all of type function or all of type event 

• Inputs of an operator must be of all of type function or all of type event 

• Events and functions must be used alternating 
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SemTalk does NOT check the following useful rules in order to make flexible graphical 

modeling possible: 

 

• Joins and Splits:  If a process was split by an operator, the process may only be joined 

be the same type of operator 

• Each EPC must start and finish with an event. (exception: Process Paths) 

• There are no isolated control flow elements. 

• At least one event must precede a function and at least one event must follow each 

function. 

 

You may turn off EPC syntax checking via Options->SemTalk Options->EPC.  This is 

recommended if you import EPC from 3rd Party Tools or from certain types of reference 

models ;-) 

 

3.4.3. Overview of Linking Rules for Multiple Functions and Events 

 

  
 

Multiple functions to an event or an event with multiple functions can also be linked.  On an 

XOR or OR, a connector must follow because events cannot make decisions as passive 

elements. 

 
NOTE: The above descriptions of EPC’s are those currently implemented in SemTalk. 

 

Triggering  
Event 

Triggered  
Event 

Triggering  
Event 

Triggered  
Event 
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3.5. Cardinalities 

 

Users can define the number of specific associations an object can have. If an object’s 

configuration exceeds the allowable limit, Consistency Check will create an issue and 

urge the user to model within the defined limit. 

 

To set the Cardinalities, go to the SemTalk Explorer and right click on a SemTalk 

Class and choose Edit. Then go to the Associations tab and check the System 

checkbox in the bottom right corner. All pre-defined associations for the class are then 

displayed (in this example for the Function class). 

 

 
 

Double click on a specific association that you want to change, such as ‘has 

Successor’. Using the dialog box shown below, you can define how many successive 

Functions a Function can have.  



SemTalk EPC Tutorial   October 2017 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2010-2017                Page 16 of 63 

 
 

Domain Cardinality sets the number of outgoing associations an object should have 

and Range Cardinality sets the number of incoming associations. 

 

NOTE 1: If a setting is left empty, SemTalk will not check cardinality. Users only 

need to change the settings type they require. All other settings are left unchanged.  

 

3.6. Adding a Human Resource to a Function:  

 

In SemTalk you can assign a HumResource (Position, an Organizational Unit or a 

Person) to a Function. 

 

3.6.1. Adding Person, Position or Organizational Unit Shapes 

 

Add a Person, Position or Organizational Unit Shapes to the process and then connect 

them with the Function using the “executes” connector or the toolbar connector tool. 

The disadvantage of adding extra shapes to a diagram is that diagrams often get 

overloaded with symbols and become difficult to read.  However, adding shapes is 

recommended when the control-flow is more important than the exchange between 

actors. 
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3.6.2. Create a New eEPC Diagram 

 

Using your Diagram tab ribbon menu, create a new eEPC diagram using ‘Diagram – New’: 

 

   
 Or right mouse clicking on the Diagram and select eEPC or right click on the eEPC in your 

Explorer and select New: 
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A new Visio Page of diagram class “eEPC” will open. You can rename that page directly by 

clicking on the default name found at the bottom of the Diagram , by right mouse clicking on 

the blank background of the Diagram and selecting Edit or by right clicking on the name in 

the Explorer and selecting Edit. Use the "Edit" command to modify existing diagrams and the 

"Remove" command to delete the selected diagram.  

 

3.6.3. Using Swimlanes 

 

In your Home tab, select a Horizontal or Vertical Swimlane from the ribbon menu.  

 

        
 

When the Swimlane appears, click on the label you want to name, If you have already 

modeled your OrgChart, you can right mouse click on the label and use the Select command 

to assign a HumResource (e.g. Position, OrgUnit or Person). If the HumResource is not listed, 

select the New button in the dialog and add your new HumResource along with its class type 

(e.g. Position, OrgUnit or Person).  

 

 
 

If you click to select your Swimlane title, you can assign new People, Positions or OrgUnits 

or you can assign an existing Person, Position or OrgUnit using the right mouse Select 

Command. 
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If you move a Function to a Swimlane, SemTalk detects that a HumanResource has been 

assigned via the Swimlane. The Swimlane role is automatically assigned to the Function.  

 

If you select the Swimlane column header, you can create new roles just by renaming the 

Swimlane. Click on the Swimlane column header and type the new name.  Use the Select 

option to choose existing roles or to edit the object. 

 

3.7. Adding Other EPC information 

 

Functions, Inputs and Outputs of are further specified using the following shapes from the 

EPC stencil: 

 

• "Entity",  

• "Technical term",  

• "Class",  

• "Data" (from Data Objects) or  

• "Package".  

 

Add the shape to the drawing space and click on the default name to rename your new object 

or, to select an existing name from a list of previously modeled objects or use the right mouse 

click “Select” option.  

 

If you want to select a name from the list of existing business objects, Edit the shape and 

select the pull-down menu in "Name" field and select the name from the pull-down list. 

 

An eEPC diagram using the elements mentioned above might look like: 
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3.8. Using Object-Oriented Process Modeling with EPCs 

 

SemTalk is designed to create semantically consistent models built on reusable object names. 

The Compose feature allows you to create object names based on Classes (nouns) and Methods 

(verbs) names. This object naming tool forms the basis of an object-oriented controlled 

vocabulary to represent your objects. Since Class and Method names are classes, if either the 

Class or the Method name is changed, those changes will then be propagated throughout your 

model. Note that Methods (as well as Attributes and States) can be inherited from super classes.  

 

Classes are business objects related to your Function or Event. If a class has already been 

created, you can reuse existing classes when creating new Functions/Events.  If the class is new, 

after you create it, the class will be available when describing future Functions or Events.  For 

example, you will only need to create “invoice” once as a class object.  Because “invoice” is 

available on the class pick list, it is more likely that you or your modeling team will always use 

the term “invoice”.  It is much less likely that inconsistent synonyms such as “bill” will be used 

in the future.  All related objects also stay consistent such as “Create invoice” or “Mark invoice 

as paid” 

 

The options State and Attribute allow you to specify which of features will be used to create 

the Function name. In the EPC methodology, only Methods are relevant for Functions and only 

States are relevant for Events. 

 

 

Turn on the Compose function in SemTalk Options to get the Compose dialog every time a new 

function or event is dropped onto the drawing space. “Compose” can be selected from the 

Object pull-down menu as well. When you drag and drop a new Event or Function object onto 

your diagram or if you right-click on your new object and select the “Compose” option.   
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After opening a Compose dialog, a select box will list the names of all of the existing objects 

and the names of all of the object + method combinations.  

 
 

 

If your desired object + method combination is already available, simply select the name and 

your dialog box will close automatically. Otherwise, select or enter the object name such as 

“Payment”. A new dialog box will open for you to either select the desired Method (verb) 

from a pull-down list or you can enter a new Method. In this example the Method ‘transfer” 

was added. 

       
 

If Classes and Methods do not already exist in the database, SemTalk will add them to the 

database. In our example the class named “Payment” is now associated with the Method 

“Transfer”. Now if we want to add another Transfer Payment object into our model, it is 

available in the picklist as Payment Transfer.   



SemTalk EPC Tutorial   October 2017 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2010-2017                Page 22 of 63 

 
 

 

The correct layout for the Method-Object is defined in the Language tab of SemTalk Options. 

The order of how the name of the Function will be generated is language specific.  For example, 

„Order Enter” is German word order and “Enter Order” is English word order. You can change 

the term order as a general setting in the SemTalk options dialog. For English you will use 

“Method Object” and your object will appear as Transfer Payment in your eEPC diagram. 

 

 
 

 

 

Information Objects and Method/State Objects can be managed in Object Model Diagrams.  

 
 

If you create an Object Model Diagram and right mouse click on the diagram and select Insert, 

objects that you have created will appear.  
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Inserted objects are shown with all associated Methods and States: 

 

   
 

SemTalk ensures consistency between objects created in the eEPC model and objects in the 

Object Model. If you rename a Class and/or Method, all Functions that contain renamed 

elements will be updated. 

 

We recommend object-oriented process modeling, especially for large projects. Start by first 

defining the most important business objects in your organization (key terms such as Invoice 

and Payment) and then build a catalog of associated Methods (commonly used verbs such as 

Send and Create). This structured vocabulary helps to build consistent, easy to understand 

process models.  

 

If you are going to use the same business objects in multiple projects, we recommend storing 

such objects in Libraries in SharePoint or by saving them as separated files so that everyone in 

the organization is using the same consistent terminology.  

 

3.9. Editing process elements 

 

You can edit objects in your diagram: 

 

1. By double clicking, 

2. Right Click “Edit”, 

3. Select & Menu “Object->Edit”, 

4. Finding it in the explorer as a child of “Diagrams->EPC->X” or by 

5. Finding it in the explorer as a child of “Objects->X”. 

 

If  you just want to rename the object, you can select it and type in the new name.  
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You may also use the Properties Window, which allows review and edit of values directly. 

(Home->Properties) 

 

  

3.9.1. Edit Function Dialog 

 

The Function Edit dialog looks like: 

  
 

NOTE 1:  The Edit command in an eEPC diagram changes the name of the instance of the 

Function. If you want to change all instances, you must edit the Class itself by editing the 

Class in the Object tree in your Model Explorer or by using the Edit Class command found in 

the Object menu. 

 

 
 

NOTE 2: In SemTalk’s EPC Method implementation, the term Function Call refers to a 

process step.  Each Function Call is an anonymous instance of its Function. e.g. Enter 
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Payment Dispatch Details is the Function and Execute Payment Dispatch a Function Call in a 

process. 

 

3.9.2. Attachments and Visio Hyperlinks 

Attachments (Hyperlinks, documents) are used to assign external information such as 

documents, hyperlinks or non-SemTalk Visio pages to an object.   

Attachments can be added by right clicking on the object and selecting Edit - General tab or 

by selecting Hyperlink from the ribbon Home menu. In the bottom left of the object’s General 

tab dialog box, there is a “+” button to add attachments. 

 
  

 
The Hyperlink dialog will pop up. In the Address text box users can directly add URLs or use 

the “…” button to choose a document from their local file system. The “SP” button opens the 

SharePoint Explorer and enables the user to select document from SharePoint libraries. 

 

The “+” button extends the dialog by some properties. Label is used so that you can give your 

link a name that is easy for the average user to understand. Language marks the document for 

a certain model language. You may attach as many documents as you desire.  Please visit the 

general tutorial for further information. 

 

Navigation to links is via CTL click on the paperclip or right mouse click on the object with a 

hyperlink and select it from the menu: 
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3.9.3. Function: “Hum. Resource” Tab 

 

  
 

“Human Resources” can be assigned to Functions using the “Hum. Resource” tab.  Human 

Resources are the People, Roles or OrgUnits that actually execute the Function.  The left-hand 

of the list box shows currently assigned resources and the right-hand list box shows the list of 

all available human resources. 

 

Use the arrow buttons to add / remove resources.  Double clicking on the list boxes allows 

you to edit the resource. 

 

The right combo box lists defined “Human Resources”.  This list can be filtered by class. 

 

 The left combo box with “executes” allows users to specify certain types of execution such as 

“controls” or “supervised by”.1  

 

Using the “New” button you can add new Human Resource Instances and new Human 

Resource Classes. 

The new Instance will automatically be linked to the Class selected in the combo box. 

 

                                                 
1 These could be defined as subclasses of the relation “executes” 



SemTalk EPC Tutorial   October 2017 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2010-2017                Page 27 of 63 

  
 

You can visualize and Edit all existing Resources in the Explorer as child nodes of “Human 

Resource”. 

Please look at chapter 3.6 to see the other ways of adding Human Resources.  

 

3.9.4. Function: “Simulation” Tab 

 

 
Simulation allow you to set values for the attributes that are relevant in Simulation, Reports 

and interfaces (e.g. work plan report), MS-Project etc.  “Processing Time” is particularly 

important, especially when determining process performance. Please see the Simulation 

Tutorial for further information. 

 

 

3.9.5. Simulation Tab in Process Control Flow Dialog 

 

If you double-click on the Control flow connector between Functions, the following dialog 

will appear. 
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The Control Flow “Simulation” tab allows Transportation time, Fixed Cost, Variable Cost and 

Probability to be specified. 

  

3.10. Deleting Process Elements 

 

When using SemTalk’s object-oriented modeling approach, there are different ways to delete 

process elements. Depending on the process element type being deleted, different results may 

occur. 

 

Before discussing the delete functionality in detail, it is important to stress that SemTalk is 

only able to perform a single Undo. Only the last action can be restored. Therefore, users 

should use extreme caution when deleting objects. 

 

In the Object tab in Visio ribbon, users will find multiple options to delete a process element. 

The DEL key on the keyboard can be used also as well as the Delete option in the context 

menu (right click on a shape or object in SemTalk Explorer). 

      
 

1. Delete an object from the process document (including shape and SemTalk 

object)  

 

If the “Delete” button in the Object ribbon or the Delete right click in the context 

menu is used, an object will be deleted from the entire model! (An object must first be 

selected before it can be deleted.) The associated shapes and the SemTalk object will 

be removed from all diagrams and from the SemTalk object tree. SemTalk will prompt 

a confirmation dialog before performing the action. 

 

For example, if a user has assigned the role “Team Leader” on different diagrams and 

then decides to delete that role, it is sufficient to select the “Team Leader” shape and 

then select Delete from the Object ribbon or use the context menu to delete “Team 

Leader” to completely delete the object from the process model. 
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2. Delete shape from a Diagram 

Sometimes users may want to keep an Object in their model but just delete it from a 

single diagram. This can be done by using the “Delete Shape” button found in the 

Object ribbon or the DEL key. The selected shape will be removed but the SemTalk 

object will still exist. Exceptions are the Function and the Event object as these are not 

reusable instances.  If a Function or an Event is deleted from a page the SemTalk 

instance will be gone as well. The class which holds the instances however will be 

preserved. All Function or Event instances have classes with the same name. Deleting 

those classes is covered in point 4. 

3. Delete multiple shapes from the process page  

When the delete action is desired for all object of a specific type on a single page the 

“Delete from page” button can be used. Following the example from before all “Team 

Leader” shapes would be deleted from the diagram where the object is selected but the 

Object will still exist as SemTalk object and as an Object on all of the other diagrams 

where it is used. As in the above example, Function and Event instances have classes 

with the same name. Deleting classes is covered in point 4. 

4. Delete Multiple Objects 

The “Delete Multiple” button allows users to delete multiple objects at once. It also 

shows all unused objects that are available for deletion. In the following screenshot, 

the Function Class is selected and the user gets a list of unused Function classes, 

which can be selected and deleted by using the “Delete” button on the bottom right. If  

“Show and Remove used Objects” is checked, all used Functions will be displayed as 

well.  

In the Class pull-down list, all SemTalk classes are selectable. Human resources, 

systems and all other EPC information can be deleted with this dialog as well. 

 

 
 

 

4. Value Chains 
 

Using a Value Chain diagram (Right click on the Diagram Folder in your Explorer or use the 

“Diagram – New - Value Chain” pull-down menu option) processes can be described which 

are directly creating value for your company. Value Chain Elements (Functions) have “is 

superior of” and “has Successor”connectors.  
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Create a "Value Chain" diagram of type by selecting "Diagram - New - Value Chain 

Diagram" or right click on the Diagram Folder in your Model Explorer. Then add value chain 

elements. 

 

  or    

 

 

  
 

Value Chains do not contain Events or other symbols. This type of diagram is intended to be 

used as a general overview of the process landscape. 

 

Each Function may be refined by another Value Chain or an EPC diagram.  EPC diagrams 

must be created before they can be attached to Value Chain elements. Value Chain elements 

that have attached diagrams are underlined. They also have a Visio Hyperlink in the context 

menu for navigation. 

5. Organizational Charts (OrgCharts) 
 

Create a new Org Charts by right clicking on the Diagram Folder in your Explorer and 

selecting OrgChart or use the “Diagram – New – OrgChart pull-down menu. OrgCharts are 

used to graphically describe the organizational structure of your company.  Add new elements 

to your OrgChart by dragging and dropping Org Unit, Position or HumanResource shapes 

from your Stencil. Connect them with a “superior of” connector.  

 

If you have already modeled organizational elements in your EPC diagrams or Swimlanes, 

these elements can be inserted into your OrgChart using the right mouse click Insert 

command.  
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Org Unit or Position can be edited to add Persons to the object. 

 

 
 

The person can be edited directly by double clicking on the name in the list. Organizational 

units are resources with similar Measures as other resources such as fixed costs, variable costs 

and capacity. 

 

  

6. Class Diagrams 
 

SemTalk objects are object-oriented so that objects can be easily managed, edited and so that 

they can have attributes that can be inherited by other objects of the same type. As you model 

in SemTalk, especially when using Compose, information entered in EPC diagrams is 

automatically stored as information Objects. 

 

Create a new Object Model by right mouse clicking in your Explorer on the Diagram Folder 

and selecting Object Model or use the “Diagram – New – Object Model pull-down menu. 

Right mouse click on your new Object Model diagram and select Insert - All.  
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Everything that has been modeled is now entered into a UML view diagram that shows the 

information Objects and the Methods and/ or States associated with those objects. These 

objects can now be managed and edited in the Object Model. 

 

7. Physical Resources 
 

If you would like to add physical resources to your model, you will have to create a new Class 

Diagram. Go to Options – SemTalk Options – Explorer tab and click on 

 
 

Now go to your Model Explorer, right mouse click on the Diagrams folder and select Class 

Diagram. 
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Rename your new Class Diagram PhysResources. We will now create a few Resources to add 

to our diagram. In your Explorer, expand Objects and EPC Objects. There you will see the 

class Resource. Right mouse-click on the UML Resource object and select New Subclass. 

Call this subclass Telephone. Right mouse-click on Telephone and create another Subclass 

and call it Mobile Phone. Go back to your Resource object and create a second Resource 

Subclass and call it Printer. 

 

Right mouse-click on your new PhysResource diagram and Insert – All. The Resource objects 

created in your explorer will be inserted, along with any defined class structures. 

 
Drag a Printer Resource shape from your Explorer onto your process diagram.  SemTalk 

automatically creates a Printer Instance in your EPC diagram.  

 

Instead of creating classes as you model, you can also use predefined resources using top 

down approach in your PhysResource Model diagram or by adding subclasses and instances 

in your Explorer. Once modeled, PhysResources can be connected using the subclass or 

superclass association so that attributes are inherited by their subclasses.  

 

 

In your PhysResource diagram create a new ‘All-In-One Printer’ subclasses. Using the Auto-

Connect function click on the UML icon and select Subclass from the pull-down menu in the 

dialog box. Now double-click on the new UML object and name it ‘All-In-One Printer’. 

 

New Resources can also be added by dragging and dropping a “UML Class” shape onto your 

PhysResouce diagram.  Resource classes are connected using the Subclass, Superclass and 

Property connectors. The Property connector is used to show a consists of relationship 

between an object and its component parts. For example, a ‘Tire’ is a ‘Property’ of a ‘Car’.   

 

A special behavior of each of the class diagrams is that every class is automatically added as a 

subclass of its root class. This is also visible in your Explorer. Whatever objects you model in 

your PhysResource Model diagram will automatically appear as Resource subclasses. 
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NOTE: Resources are objects which are required to execute Functions. Functions can only be 

executed if the resource has available capacity. There are basically two kinds of resources: 

Concrete physical resources such as printers and Human Resources such as People & Org Units. 

 

 
 

Drag a Resource from your Stencil. Double-click on the new Resource to create a new 

instance. Select ‘All-In-One Printer’ as the Class and ‘ACME Printer No.123’ and the 

instance name. 

 

   
 

 

Now the PhysResource instance ACME Printer No.123 will have all of the attributes of All-

In-One Printers and it is available as an instance to be added in other EPC diagrams using the 

Insert command.  
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The Measures Tab of PhysResource has fields that are mainly used mainly when running 

simulations. Variable Costs depend on the length of time the resource is used. Fixed Cost is a 

cost that occurs each time the resource is accessed. 

 

For PhysResources it makes sense to have a class model where you can specify all the types 

of resources you use in your model and assign shapes how to display them.  

 

 
 

Class models can be created for every object type. In order to take full advantage of object-

oriented modeling, it is best to define attributes on a common superclass rather than defining 

them in classes created from Visio masters. 

 

NOTE:   You may also depict subclasses of an activity by creating special symbols or by 

changing the layout of system shapes.  

8. Refinements 
 

The EPC method implemented in SemTalk Visio is broadly compatible with given EPC 

methodology standards.  However, process references to Refinements have been solved 

differently.  SemTalk does not have a special symbol to denote that there is a sub-process/ 

refinement. Even though there is no designated symbol, Functions can be refined by attaching 

an EPC diagram.  In the SemTalk version, refined Functions are drawn with underlined object 

names similar to a hyperlink in a browser. If the standard process path shape is required, users 
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may select that shape for a specific function call.  Then each sub-process will automatically 

get copies of the start and end Events that have been inherited from the refined Function.  

 

Right Click on “Assign Customer” and select “Refine”. A dialog pops up asking for the name 

of the sub-process: 

 

 
 

A new eEPC diagram will open with its attached start and end Events: 

 

          

 

You can see in the Explorer the addition of a new process as a child node of “eEPC- #”.  In 

the shown example “eEPC.X” “Create Customer Account” is now underlined to inform you 

that this Function has a refinement. Any time you select “Refine” you open the refinement. 

Navigation is also available on the “Home” tab. It allow to go from the refinement to the 

refined process. 

 

 
 

NOTE: If you use the option “External” on the refine dialog, you can assign a process from a 

different model. In this case the refinement works like a hyperlink to the other model. But 

using this method you cannot connect entry and exit points. 

 

9. Customizing Colors 
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You have the option to change the color of shape types without touching Visio Master shapes. 

Change the color of a Function, OrgUnit or Event type by selecting the Object type in your 

Model Explorer (single click) and selecting Customize Shape in the Object menu. Go to the 

Graphics tab and select the color of your choice. Individual objects can be changed by 

clicking on the object and selecting Format Shape. 

 

10. Simulation 
 

Simulation is available for SemTalk EPC Edition. Simulation allows testing the logical 

behavior of your process to identify behaviors such as possible bottlenecks or modeling 

errors.  Using colored Petri-Nets you can investigate your process in a dynamic environment 

with multiple inputs processed in parallel.  Due to limits in EPC semantics, SemTalk’s 

simulation in eEPC has some limitations compared to its capabilities in other methodologies.  

For example, you are allowed to place multiple tokens, each having its own color, on one 

event.  Due to methodological constraints, you cannot place tokens with the same color on 

multiple events. Please refer to the SemTalk Simulation Tutorial for details. 

 

 

11. Distributed Modeling 
An important feature of SemTalk is its ability to structure and decompose models so that 

SemTalk distributed modeling is possible. Multiple users use shared reference models within 

the same, or in unrelated modeling projects. Model information is available for continual 

updates and editing by all modelers. 

 

Reference models are especially well-suited for class models  (e.g. Object Model diagrams, 

OrgCharts and Applications) since the same objects are often used throughout the 

organization. 

 

SemTalk objects can be joined and/or combined based on two different techniques: 

1. Global unique names - URNs (Uniform Resource Names) are a combination of name 

and namespace.  The same, unambiguous name is used in different models to 

communicate the same concept.  Models are merged based on this unique name. 

Highlight the 
object type in 
the Object 
Explorer  
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2. References between objects from different files.   An object with an external reference 

has a reference to a source from which it is to be updated.   References are based on 

fixed path names.  Referenced model that are HTML pages should not be moved or 

renamed so that the reference is not lost.  Such reference models should be on the 

Internet or Extranet. 

 

Use of external objects requires loading an external reference model (using File -> Open & 

Import -> External models).  When loading an external model, the XML file of the external 

model is used.  External objects are greyed out in the Explorer. Right-click "Import" from the 

tree, or "Object -> Import" is used to insert the shown objects into the current model.  

"HTML" opens any existing HTML representation of the model so that you can look at it 

before importing it again. 

 

Referenced objects cannot be renamed.  Remove the reference by deleting the text in the 

"Reference" field.  The class "Search " in the picture has a URL, the file from which the 

object has come.  This example is an ITIL reference model.  As an example, you can use the 

demo model from our server http://www.semtalk.com/pub/tools.xml (File -> Open & Import -

> External URL, and then enter the link.) 

 

        
 

The most efficient way to share models and modeling data is to use external SemTalk models 

and to take advantage of SemTalk’s SharePoint integration.  Besides SemTalk files, 

ontologies in the Semantic Web Format OWL can be used for business object models.  

 

You can use multiple external models simultaneously and save them to your file/template.  

The referenced models automatically display when you open your models.  Showing multiple 

external models is possible using the "Options" dialog from the options in the SemTalk 

Options menu. 
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Objects from external models can be easily inserted or referenced by drag and drop.  Many 

SemTalk dialogs such as Insert, Expand or Refine provide external objects automatically 

when you select “Always show external objects” in Options->SemTalk Options->Ext. 

Models". 

 

Note: 

A reference model located in the Internet is similar to open as a local reference model ( File -

> Open & Import -> External URL) .  Just enter the web address.  If you are connected to the 

Internet, try displaying an External Model by loading the following URL: 

http://www.semtalk.com/models/biztalk.xml 

Update external objects using the menu “Refresh” to replicate the values from the external 

model. The entire chart (with all external objects) is updated via the main menu Diagram -> 

Update. 

 

Note: 

If references were created to external models, they are replicated by SemTalk . 

A detailed discussion of distributed modeling with SemTalk see 

http://www.semtalk.com/pub/richard.ernst.pdf 

 

12. XPDL Export 
 

The XML Process Definition Language (XPDL) has it origin in the text-based workflow 

exchange format of the Workflow Management Coalition (WfMC Interface 1).  WfMC was 

created to: 

 

• Allow tools to exchange process models, and 

• Formatted to exchange Process Definitions between  

o Components within Workflow/BPM Products 

o Different BPM/Workflow Products 

o Process Modelling/ Simulation tools and BPM/Workflow Products 

 

 

 

 



SemTalk EPC Tutorial   October 2017 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2010-2017                Page 40 of 63 

 

Figure 1: XPDL Export 

 

13. Importing and Exporting of ARIS and EPML4 
 

The import and export of ARIS models is possible using the ARIS XML format named AML 

or EPML.  

You will find the Import/Export interfaces in your model File menu. 

 

 
 

 

 

• AML is the ARIS XML Export format. 

                                                 
4  ARIS is a trademark of Software AG 
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• EPML is a vendor-independent exchange format for EPC (EPC Markup Language) 

http://www.mendling.com/EPML/index2.html).  AML can be converted to EPML and 

vice versa.  

13.1. AML 

 

SemTalk can read/ write the ARIS XML format (AML).  Select the diagrams (Model) of 

choice in ARIS5 then export the model/model components using the context menu 

‘Export/Import->XML Export’.  AML Explorer shows the ARIS folder structure of the AML 

file you have selected.  Use the check boxes to mark the objects you would like to import into 

SemTalk.  Right-Click “Import” will import the selected objects into SemTalk. 

  

The AML Import Options can be opened via a right click menu in the AML Explorer window. 

If available, ARIS models can be imported for existing languages.  Simply select all of the 

languages you would like to import.  In order to review ARIS XML in IE, or to use it in 

SemTalk and/or other programs, you need a file named “ARIS-Export.dtd”.  This can be 

found in the ARIS program folder in a directory named ‘aml’.  Please copy the DTD to the 

directory where the XML export is located. 

 

The Import Option allows you to specify which object type(s) are mapped to specific 

SemTalk classes and which symbols are mapped to specific Visio masters. 

 

SemTalk imports all languages available in the ARIS export file.  You may choose the actual 

language for viewing the model after import. “Primary language” is the language that will be 

used to create internal object names. 

 

                                                 
5 Supported versions for import are 6.1, 6,2 and 7.x. For other versions please contact support@semtalk.com 
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Figure 2: ARIS Import Options 

 

Select the diagrams of your choice and import them to SemTalk.  ARIS diagrams are often 

very large so it is recommended to adjust to page size to “Resize to fit Contents”. 

ARIS has more than 100 diagram types with more than 200 object types.  Since we want to 

keep our EPC version easy to use and understandable, we do not include all of the available 

objects in the delivered version. New diagram and object types will be created dynamically 

during import based on the content of the imported model. The import will not create any new 

Visio Shapes from ARIS.  Unknown object types are assigned the “Instance” Shape (gray 

ellipsis). However, if you add the right shapes with the right ARIS import names to the 

Visio/SemTalk document stencil before import, they will be recognized.  Please contact 

support@semtalk.com if you need assistance. 

 

If you use the option ‘Import Shape Size’ positioning and size will be taken form ARIS. 

SemTalk & Visio shapes are usually much smaller. 

 

mailto:support@semtalk.com
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The export to ARIS AML is available using  File -> Save & Send -> EPC. 

 

A YouTube video explaining AML Import is available in English at: 

 

http://www.youtube.com/watch?v=D0mB843RRYY 

 

 

 
 

http://www.youtube.com/watch?v=D0mB843RRYY
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14. General SemTalk Features 
 

14.1. Extras and Tools 

 

Microsoft Office Export 

 

 

14.2. Microsoft Office Word Export 

Generating documentation of your models is quite easy with SemTalk and Microsoft Office 

Word.  Select FileExportMicrosoft Office Microsoft Word 
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A tree view of existing model diagrams classified by diagram type is shown in the top left 

corner. Simply select which diagrams are to be exported using the arrow buttons found 

between the two boxes. Use the Insert->Add Text File button to insert text files (.doc, .txt, 

etc.) or Insert->Add Reports to add reports into the Word export. The items’ sequence on 

the list on the upper left corner determines the order of the diagrams and text in the Word 

export. 

 

Use the File menu option of the dialog, if you want to do the following: 

Load Diagram List Load a predefine diagram list to generate as Word document. 

Save Diagram List As Save the current diagram list as .txt file. You may load this file 

and generate a custom Word export. 

Open Document Template SemTalk loads the Word Normal.dot as default template, but 

you may select a custom template with this command. 

Clear Document Template Removes any assigned Template 

Load Settings Loads a Word Setting File 

Save Settings Saves a Word Setting File 

 

Use the Insert menu option to do the following: 

Insert a Text File Inserts a text file into your export. 

Insert a Report Inserts a report into your export. 

 

More layout options are available in the Word export dialog: 

Caption Format Used to define the heading format according to your MS 

Word. 

Table Format Used to define the layout format of your tables.  

Drawings Used to include diagrams in the Word export. 

New Page for Each Diagram Used to define to insert one or more than one diagram in a 

page. 

Include Background Used to include the diagrams’ background (e.g. company’s 

logo), if they have any. 

Include TOC Used to include a Table of Contents at the beginning of the 

Word document. 

Include Text Used to include tables in your Word document. 

Include Title Document Title 

Include Cover page Document Title on an extra page 

Generate PDF Automatically generate PDF using Word2007 save as PDF 

 

In the Instance and Class tabs, select which object properties and information to include in 

the Word export. 
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14.3. Microsoft Office PowerPoint Export 

The Microsoft PowerPoint interface makes it easy to present models quickly and effectively.  

Open the export dialog for PowerPoint using the menu item File → Export → Microsoft 

Office → PowerPoint to generate a PowerPoint presentation from a SemTalk model. You 

should see the following dialog now: 

 
You have the following options: 

Type Use to filter the diagrams after their diagram type. 

Create Title Use to give or not each presentation’s slide a title matching the 

SemTalk’s page titles. This is not recommend if you have a 

background page which also shows the page title 

Include Background Use to include or not the diagrams’ background (e.g. company’s 

logo), if they have any. 

New Document If this option is not checked AND a PowerPoint presentation is 

open, the slides are added to the open presentation 

 

14.4. Microsoft Office MS Excel Import 

The MS Excel Import function can be very handy when creating big models with lots of 

classes and or instances. Instead of creating every single class and/or instance in SemTalk, 

you can import them from a MS Excel spreadsheet. The only condition is that the spreadsheet 

must reflect SemTalk’s logical structure.  

 

To import objects from a MS Excel spreadsheet into a model, select Tools. 
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Then select MS Excel. Then select an appropriate MS Excel spreadsheet (e.g. bulk-

import.xlt). Once you are ready to import the objects and information in the spreadsheet, 

select the Tools - Table menu. You will see the following dialog: 

 

 
 

14.5. Bulk Import Spreadsheet 

 

Access the Bulk Import Spread sheet in the File – Export – Microsoft Office – Excel menu. 

Use the checkboxes to select which objects and information SemTalk should Import/ Export 

to Excel. First Export SemTalk model data to create an Excel file format that is capable of 

importing the data back into SemTalk.  “Import” imports the current elements back into 

SemTalk. “Clear” removes all content from the Excel. “Process” is a sample data formal 

intended for process modeling notations to create a simple process hierarchy from the 

spreadsheets data.  

 

All macros are included in the document as source code. The intension of Bulk Import is to 

provide you with an API sample how to read and write SemTalk content. If you copy/change 

the macros to match your requirements, it is easy to export/import mass data from virtually 

any other application. 

 

 

    
 



SemTalk EPC Tutorial   October 2017 
Email: support@semtalk.com 

Copyright: Semtation GmbH 2010-2017                Page 48 of 63 

 
 

14.6. Copying Flow Elements from Document to Document 

 

Flow elements can be copied from one Visio file to another. Shapes need to be selected and 

copied by using Copy in the context menu or by using CRTL C. Content can then be pasted 

into a different EPC document. Copied content will still contain defined attributes and objects 

found in its original source object. 

 

NOTE: Both documents need to be opened in the same Visio instance! 

 

14.7. Managing Variants and ClusterIDs 

 

For reporting purposes, it can be useful to compare/connect different EPC Functions found on 

different documents. ClusterIDs can be used to match Functions.  

Cluster ID is an EPC Function attribute and can be edited via the Attribute tab in the Edit 

dialog (right click on Function  Edit  Attribute tab) or by using the Variant manager 

(Ribbon  Tools  Variant Manager). 

In order to cluster different Functions, each Functions needs to have the same ClusterID. 

 
Variant Manager reads all open documents in the current Visio instance. In the top left list 

box, all documents are displayed and can be selected. When selected, the Functions list box is 

triggered to display all available Functions in the selected document. 

 

New ClusterIDs are created by the “New ClusterID” button. The Function ClusterID and the 

target Function ClusterID need to be selected before using the “Add Function” button. The 

ClusterID Attribute of the added Function will then be set to the selected ClusterID. Each 

Function can have only one ClusterID. 

 

By using the “Save All” Button all documents in the current Visio instance will be saved. 
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14.8. Delete unused elements before saving 

 

In order to clean up the process models from unused data, SemTalk can be setup to delete 

specified objects with reference to Share Point Lists. 

 

In SemTalk Options  General check “Delete unused objects before saving“. 

 

  
 

Information about the kind of objects that will be deleted can be customized in 

C:\ProgramData\SemTalk\ClearModel.xml. The default setting will delete unused Functions, 

Events, Decisions, Resources and Attachments. 

 

14.9. HTML Generator 

In order to create an HTML version of your model go to File – Export: 

 

 
 

NOTE:  Remember to save your diagram before using the HTML generator. 
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Title Specifies the name of the Website. In case of working with 

multilingual models, the next field is used to specify the language in 

which the Website will be saved.  

Start page Determines the file path of the start page to be generated. Do not 

generate to network drives. Always generate to a local directory such 

as C:\myhtml and transfer the html afterwards to the fileserver. 

Select the following options to add elements and functionalities to the HTML export from the 

General tab. 

Goto Page Facilitates a fast navigation across the diagrams. 

Pan Zoom Allows zooming of the diagrams. 

Search Enables the search in the website. 

Property Pages Shows the properties of a selected object in a diagram 

Properties 

(Diagram) 

Even if you have not used Property Pages for all objects, you may 

want a Property Page for each diagram for navigation purposes. 

SemTalk Tree Reproduces the SemTalk Explorer in the Website 

VML / Silverlight Specifies how Visio will generate graphics 

Language Use to define the language of preference for the model attached 

objects. 
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The Multi-HTML tab allows you to decide which models to connect to your HTML export. 

Include external 

Diagrams 

Select to generate links to from objects in the to-be HTML model to 

other external HTML diagrams.  NOTE:  When you open the HTML 

files of the external models from a HTML model, all the start pages 

(not the supporting files) must be located in the same directory. 

Ext. References in 

new Window  

If selected, external referenced HTML models or documents (e.g. 

Word documents, forms, etc.) open in a new internet browser instance. 

Add files Used to add and search files yourself to the list of files for the multi-

html export. 

Search files Used to search and to automatically add files which have a reference 

in the current model to the multi-html list. 

NOTE: The linking of HTML files works only when the index files (i.e. HTML start files) of 

the linking web pages (models) have the same name as their XML files, since the intern 

referencing uses the XML file names of the external models. Please notice that the name of 

the index file should not exceed 38 characters. 

Under Tree Details, you can choose which object types are to be displayed. Normally, you 

will want to display classes and diagrams but you can also choose associations, attributes, 

synonyms or instances.  
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Diagrams, Classes, 

Hyperlinks, 

Associations, 

Attributes 

(Caption) 

Normally, you will want to display classes and diagrams, but you can 

also choose hyperlinks, associations and attributes. You may also 

change the node name of these objects in the tree view. (e.g. Classes -

> Concepts or Associations -> Relations). 

Show Refinements 

on Top-Level 

Specify if diagrams that are refinements of other elements should 

become root nodes in the tree. If not checked, user have a more 

hierarchical navigation, if it is checked users get a complete list 

Generic Diagrams In many cases generic (or “Untyped”) pages are used for displaying 

the meta model. These pages should often be excluded from the html 

representation. 

Show Subclasses on 

Top-Level 

Use to display in the tree view a hierarchical structure (subclass of) for 

each class. 

Instance List Use to display in the tree view only a list of instances and no classes. 
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In the Property Details tab, you can choose which properties are to be shown in the property 

frame in the HTML export. 

  
 

Visible Properties Select the object properties that you would like to see for an object in 

the property frame in the HTML export. 

Visible Attributes Select specific properties and associations that you would like to see 

for an object in the property frame in the HTML export.  Simulation 

and BPEL allow you to select a common set of attributes.  Often only 

some attributes are of interest.  This allows attributes that are not 

wanted to be hidden. 

Show Comments in 

a Popup Window 

Specify if an extra menu entry for the comment should be generated. 

The menu will popup an extra window showing to comment. 

MouseOver 

Comments 

Specify if the comment of an object will be shown if a user hoover 

over the shape 
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Use the Hyperlinks tab to edit the path of the referenced objects in the current model. 

   
Find 

Replace 

You may search and replace up to three sub paths. The button Search 

Hyperlinks will search for existing paths in your model and display 

them in the Find text field. You may replace absolute paths with 

relative paths (“../”). Please remember that the relative path does not 

begin with the “Start Page” directory, but with the subdirectory “xxx 

files”. The “../” in the HTML tag tells the browser to go up one 

directory level (i.e. to the “Start Page” directory in this case.  

Copy Attachments Used to indicate that files attached to objects in the model will be 

copied to the target directory of the HMTL export. 

New Window for 

Attachments 

Used to indicate that the attached files should be opened in a separate 

instance of your internet browser. 

Popup Window Attachments will open in a limited Popup Window instead of a new 

browser window. 
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Use the Filter tab to select those pages to be included in the HTML export.  

  
Organization unit, 

Buffer 

(If modeling method applies) Select one of the options to file the 

adjacent combo box with the corresponding objects. Select one of the 

object’s filters from the list of diagrams below. Mark only those 

diagrams where the object is present. 

Diagram Type Selecting one of the diagram types filters the list of diagrams below, 

marking only diagrams of that type. 
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The PDF tab allows you to specify that for each page a printable copy in the desired format 

will be created.  This simplifies the printing of individual pages. You may choose from 

Bitmap formats such as WMF, SVG, JPG or use PDF. You can also use Word (-Export) to 

generate the PDF. Please select a template for your use case. 

Other options can be found at the Tools tab. 
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Other Browsers 

(Not IE) 

Visio generates HTML for IE 6 or higher. HTML export for other 

browsers has limited functions and generates a large number of small 

html pages. 

External Start 

Pages 

For each object, SemTalk generates an individual start page, where 

external models can be referenced. 

Sub- Process 

Navigation 

Navigate between lower level diagrams in process models 

Process Path Breadth crumb navigation for process models. You’ll see a shape with 

text REFINEMENTPATH on the background page 

Visio Document SemTalk generates additionally a Visio document with the selected 

properties for the Visio Viewer. SemTalk object attributes are 

transformed into Visio User attributes. 

Support Files Specify how the folder for support files will be named. “Files” is not 

allowed for SharePoint 

Link to SharePoint 

Viewer 

A menu entry with a link to a specific webpage will be added. The ID 

of the object will be passed as an argument. The intended use is to link 

elements to SharePoint forms 

 

The resulting HMTL: 
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14.10. Report Generator  

In addition to the various possibilities to view your business process, SemTalk also offers you 

a comfortable way to generate reports about the content of your models. 

Open SemTalk Report Editor selecting Report  Report Editor.  

 

 
 

With SemTalk Report Editor you can create reports, save and reuse report formats. The tree 

structure shows the logical structure of the query and the attributes included. The right part 

shows the result of the query as XML or as a table. 

 

In the left combo box, select “User”. The option “All Instances” will list direct and indirect 

instances of User. You can now see the attributes and related objects in a tree view. 

Now select in the tree view User / System Attributes /Name, User / System Attributes / Class, 

User / System Attributes / OnDiagram and uses / Product /Name to see a list of the Banks and 

the name of the treasurer who works there and in which page they can be found. 
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Attributes can be used to filter report results. Select an entry in the explorer, e.g. Name or 

some measurement attribute and now chose Customize Column in the Adjust Column menu. 

The text box RegEx-Filter can process regular expressions for filtering or just simple string 

and numbers. Using filtering the report results can limited to a sub-set in regards to specific 

function names or other measurements. 

 
 

 
Model Objects, Attributes and Associations determine the structure of the reports. Queries can 

be nested to as many levels as needed. 

 

The XML output can be saved as an XML file, as html table, which can be opened in many 

tools including MS Excel, directly to Excel or to a SharePoint list. 
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Use the menu option File  Load Model to specify additional options for report.  

Allows the selection of other models to be included when running multi model reports. Other 

models will be merged before the report is being executed. Please make sure that you are 

using models with a compatible meta models. 

 

14.11. Table Editor 

 

Table Editor tool offers another way to edit information in your models. You can create and 

use Microsoft Excel tables to visualize and edit information about classes and instances in 

your models. 

 

 
 

 

Type Used to filter SemTalk’s abstract objects: Attribute, Class, Method, 

Relation, State 

Namespace Use to filter according to namespaces. <None> for classes with no 

namespace. <All> for classes regardless their namespace. 

Class Select a class to see a list of its attributes (if any). <All> to list the 

attributes of every class in the model. 

Diagram Select a diagram as filter argument. <All> to take into account every 

diagram. <None> to list those object that do not appear in any 

diagram, but exist in the object base. 

Comment Check to include the corresponding ‘comment’ in the table. 
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Instances Select to generate a table with the instances of the class(es) you set as 

filter arguments.  

Classes Select to generate a table with the subclasses of the class(es) you set 

as filter arguments. 

Export Generates an Excel table according to the filter arguments. 

Import Imports the values you changed in the generated table. 

Language Use to translate the objects name in different languages and import 

them in the model. 

 

 

You may edit attribute values now in Excel: 

 

14.12. Macros 

 
 

Macro commands allows you to run small, SemTalk complementary applications written in a 

script language. 

 

The above example shows three subroutines contained in the file count.vbs. You can open a 

new macro file by clicking Open. Edit will open a script editor (not part of SemTalk). 

Execute will run the selected subroutine. 

 

14.13. Replace 
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The Replace command is used to globally replace strings (rename) in different object 

properties.  The following options are available: 

Name Replace the name of an object with another character string globally. 

Location Globally replaces a location path of referenced objects with a 

character string.  

Document Path Globally replaces a location path of attached files (e.g. documents) 

with a character string 

Namespace Globally replaces the name of an object with another character 

string. 

Refinement This globally replaces the location of a refinement with another 

character string. (e.g. used after moving the file of an external 

refinement to another directory) 

Substring This checkbox must be checked if you do not want to match single 

documents e.g. changing a directory path 

ReadOnly Include ReadOnly objects 

 

 


