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1. About Business Process Modeling Notation (BPMN) 
 
The Business Process Modeling Notation (BPMN) specification provides a graphical notation 
for expressing business processes. This notation has been proposed by the Business Process 
Management Initiative (www.bpmi.org).  
Standard specification can be found at http://www.bpmn.org  
 
The objective of BPMN is to support business process management by both technical users 
and business users by providing a notation that is intuitive to business users yet able to 
represent complex process semantics. The main focus of BPMN is on interacting systems 
that interrupt one another, especially where there are many deeply nested independent, but 
coordinated, interacting execution threads. 
 
This tutorial 1is intended to be used for Business Process Analysis, rather than the design 
and orchestration of web services. Please refer to our other documentation if you are 
interested in generating BPEL Code.  
  

                                                 
1 All screenshots in this tutorial are taken with Windows7 and Visio 2013. Other OS such as XP  and Visio 
versions (2003 or 2007) may look slightly  different 

http://www.bpmi.org/
http://www.bpmn.org/
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2. Starting SemTalk BPMN Edition 
There are two ways to use SemTalk. You can either use a version which embeds Visio into a 
SemTalk User Interface or SemTalk can be used as a Visio 2013 Addin. The second approach 
is recommended if SemTalk is used together with SharePoint. Please make sure that you 
have installed the “SemTalk Addin for Visio 2013”.  
 

 

Figure 1 SemTalk Addin for Visio 2010 

In order to start SemTalk simply open Visio. The “New SemTalk” menu presents an overview 
of preinstalled templates. Please select “BPMN20 for Visio2010” if you have Visio 2010 
installed. 

\ 
Figure 2: Selection of BPMN 2.0 
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If you do not have Visio 2013 or Visio 2016 and need to use Visio 2010 or 2007 you will use 
“Start->Programs->SemTalk->SemTalk4”  with a slightly different user interface. Use File-
>New to select the template: 

 
 
Visio SemTalk appears as follows: 
 

 

Figure 3: Starting SemTalk BPMN Edition 

You can open the SemTalk Explorer by pressing the Explorer Button found on the Home Tab: 
  

 
The Explorer gives you structured access to objects contained in your model. 
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For this tutorial please make sure that you are not using BPMN 2.0 in the Expert Mode which 
is only needed when generating BPEL.  
 

 

Figure 4: BPMN Settings 

 
Visio’s Pan & Zoom Window located in the lower right corner: 
 

  
The Explorer, the Stencil Windows and the Pan & Zoom Window can be “docked” to the 
Borders of the Visio pane with or without the auto-hide mode. 
 

 
 
One of the major advantages of using the SemTalk Addin for Visio is that you can customize 
the ribbon to match your needs. 
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3. Editing a Process 

3.1. Adding Process Elements 

Please add elements to the existing process by dragging them from the stencil to your 
diagram (or “Process”). Objects can be renamed by double-clicking on the object and 
entering the new name. 
 
A process is a sequence of process steps (Tasks). It has well defined interfaces. These are Start 
Event and End Event. Between those two elements is the Sequence flow.  
 

 

A Task is an atomic activity that occurs within a 
Process.  A Task is used when the work in the 
Process is not broken down into a finer level of 
Process detail. Generally, an end-user and/or an 
application are used to perform the Task when 
it is executed 

 

An Event is something that “happens” during 
the course of a business process. These Events 
affect the flow of the Process and usually have a 
cause or an impact. BPMN has restricted the use 
of events to include only those types of events 
that will affect the sequence or timing of 
activities of a process. Start and most 
Intermediate Events have “Triggers” that define 
the cause for the event. End Events may define 
a “Result” that is a consequence of a Sequence 
Flow ending. 

 

Gateways are modeling elements that are used 
to control how Sequence Flows interact as they 
converge and diverge within a Process. It implies 
that there is a gating mechanism that either 
allows or disallows passage through the 
Gateway. As Tokens arrive at a Gateway, they 
can be merged together  and/or split apart on as 
Gateway mechanisms are invoked. 

 

 

Data objects do not have any direct effect on 
the Sequence Flow or Message Flow of the 
process but they do provide information about 
what the Process does. They describe how 
documents, data, and other objects are used 
and updated during the Process. While the 
name “Data Object” may imply an electronic 
document, they can be used to represent many 
different types of objects, both electronic and 
physical. 
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System

 

Pool 
Pools represents major participants in a process.  
Typically they are separate  organizations or 
groups. A pool contains one or more lanes (like 
a real swimming pool). A pool can be open (i.e. 
shows internal detail) when it is depicted as a 
large rectangle showing one or more lanes, or 
collapsed (i.e. internal detail is hidden) when it 
is depicted as an empty rectangle stretching the 
width or height of the diagram. Pools are 
realized in SemTalk using Visio Swimlanes 
Lane 
Lanes are used to organize and categorize 
activities within a pool according to a function 
or role. They are depicted as a rectangle 
stretching the width or height of the pool. A 
lane contains Flow Objects, Connecting Objects 
and Artifacts. If you do not plan to model Tasks 
within a lane, we recommend use of the 
“System” symbol instead of the lane view of 
Systems. 

 
Adding connectors is quite simple. Drop the “Sequence flow” shape somewhere on your 
diagram. If you hover over the end of the sequence flow object, you can move the sequence 
flow to connect the source object with the target object  over an object’s “connections 
point” you are notified by a colored square that you can glue the relation to that object. 
Select an ending point and glue your relation to the objects of your choice. 
 
After adding some elements and connecting them with the “Sequence flow” connector your 
diagram looks like this one: 
 

 

Figure 5: Adding Process Elements 
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Quick shapes and the connector tool are very useful ways to speed up the creation of 

diagrams. The connector tool is also available on the Home-toolbar .  
 
BPMN does not display human resources graphically as nodes in a process (even if it could 
be easily customized to do so).  In order to add human resourses, you must use the Edit 
Dialog and assign a resource on the “Performers” tab. This will be explained in later 
chapters. Let us first begin with Swimlanes. 

3.2. Using Swimlanes 

Let us first create a new process page: 

 or  
 
This will create a new diagram class Visio Page titled  “Business Process Diagram”. You may 
rename that page directly by renaming the Visio tab or via a SemTalk dialog (Right Click-> 
Edit on the background or the menu item “Diagram->Edit”.  
 
Swimlanes are a component of Visio’s Flowcharting stencil. They can be used via the 
command buttons on SemTalk’s “Home” tab. 
 

 
Or just drag the Pool / Lane master from the stencil 
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More options can be found on Visio’s “Cross-Functional Flowchart” tab. 
 

 
 
After dropping functional lanes on your drawing, select the pool area of the Swimlane and 
simply type in the label name, or, alternatively, you can select existing Roles or Org. Units via 
the right-click menu “Select”. 
 

 

Figure 6: Process with Swimlanes 

If you move a Task to a Swimlane this is detected by SemTalk and the Task is automatically 
assigned the role specified by the Swimlane. If you select the head of a swimlane, you can 
create new Roles just by renaming the Swimlane. Via the right-click menu on the Swimlane 
you can select existing Roles and edit objects. 
Between Tasks located in different pools, a special link (“Message flow”) must be used. You 
may not relate a gateway on one pool with a task on another pool. 
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Figure 6: Message flow 

Inputs and outputs of task are specified as data objects. A process with data objects might 
look like: 
 

 

Figure 7: Process with Swimlanes and data objects 
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In BPMN you can attach Events to a Task to express that something happened while the Task 
was executed. The Event shape must be added to the task shape.  You might need to move it 
a bit until it is recognized and shows the double lined border.  

 

Figure 7: Attaching an Event 

Double-click on the Event and in the pull-down menu next to name and change the trigger 
typeto “Process Error”:  

 
Similar to the trigger type of an event you can change the type of a Gateway: 
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Figure 8: Intermediate Event and Error handling 

Note for owners of Visio 2010 Premium Edition: You can use all Visio BPMN Shapes including 
lanes & pools. 
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3.4 Consistency checking 

SemTalk 4.3 has a consistency checking feature.  Go to the BPMN tab and select Check Rules 
continuously and hit the Consistency Check refresh button. 

 
Issue descriptions will be visible when you hover your mouse over those objects where an 
issue was found.  Continuous error checking will search for issues each time any object in the 
model is edited. You may specify to keep all elements with issues marked in red until the 
issue is resolved. “Check Model Consistency” will open the issue window and recheck all 
elements. If you double-click on an issue found in the issues window, you will navigate to the 
place in the model where the object has an issue. 
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3.5. Object-oriented process modeling 

If you select the menu item „Object->Compose“ or right click compose, you have the option 
to specify tasks and events in an object-oriented way. 
 

  

Figure 9: Composing object-oriented tasks 

Class is the super-class (parent) object of the selected task. You can reuse existing classes or 
create new classes in a bottom-up manner e.g. “Bid” is the Class at “make Bid” 
 
The options State and Attribute allow you to specify which of these feature will be used to 
create the activity name. In BPMN methodology only methods are relevant for Tasks. 
 
In the combo box Method the name of the method (or verb) can be created newly or it can 
be selected from previously defined methods of the class 
 
SemTalk automatically creates the class and method if they do not already exist in the 
database. In our example a class named “order” with the method “enter” will be created. 
 
The idea behind compose is to generate the Task name by combining the name of the “class” 
combined with the name of the “method”. If classes or methods are being renamed, the name 
of the activity is updated. Note that method (as well as attributes and state) can be inherited 
from super classes.  
 
The order of terms generated is often language specific („Order Enter” or “Enter Order”). You 
can change language order in general settings in the SemTalk options dialog. For example, the 
English language generally uses the order  “Method Object”. 
 
SemTalk Options (on the tab “Options”) allows you to specify if you want to use “Compose” 
when creating new Tasks. 
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Here is a newly created Process with object-oriented components. 
 

  

Figure 10: An object-oriented Process 

The objects “Order” and “Customer” are created by SemTalk in the background.  A diagram 
of these types of class objects looks like this: 
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Figure 11: Object Diagram 

If you make „Special Offer“ a subclass of „Offer“, “Special Offer” will inherit all methods from 
“Offer”. In the compose dialog those inherited methods will be shown in the method combo 
box. 
SemTalk ensures the consistency between object models and process models. If you rename 
a class or method all objects that use these classes will be automatically updated. 
 
We recommend object-oriented process modeling especially for large projects. First create 
most important business objects and build a catalog of methods (verbs). This catalog will act 
as the basis for consistent process models.  
 
If you are going to use the same business objects in multiple projects we recommend to store 
object libraries in separated files and publish them on intranet or extranet.  

3.6 Editing process elements 

Once objects are created, you can edit the objects in your diagram: 
 

1. By double-clicking or 
2. Right-click “Edit” or 
3. Select & Menu “Object->Edit” or 
4. Find it in the explorer as a child of “Diagrams->Process->Process-6” or 
5. Find it in the explorer as a child of “Objects->”. 

 
If you want to rename an object, just select it and type in the new name.  
You can also use the Properties Window to review and edit values directly. (Home-
>Properties) 
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Figure 12: Properties Window 

BPMN 2.0 Visio’s Shape Data window is also useful: 
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3.6.1 Task Dialog 

The task dialog looks like this: 
 

  

Figure 13: Task Dialog  

Links (hyperlinks, attachments & documents) are added using the right-click menu “New” 
(“+” button)  and deleted by the right-click menu “Remove” (“-“ button) on the background 
of the links list. Double clicking the link in the listbox opens that document with the (for 
windows) associated application.  Activities with  links have a  marker in the upper left 
corner of the object. 
 
NOTE: In order to change all occurrences of a task, you must edit the base class  using 
“Object->Edit Class”. 
 
NOTE: The “General” tab is a generic SemTalk tab and not one specific to BPMN.  

3.6.2 Task: “Hum. Resource” Tab 

 

  

Figure 14: Task: Hum. Resource 
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Using the “Hum. Resource” tab you can assign “Participants” to a task. These are the people, 
roles or organizational units which actually execute the task. The left hand list box shows the 
currently assigned resources and the right hand list box shows a list of all available human 
resources. 
Use the arrow buttons to add / remove resources. Double-clicking in the list boxes will edit 
the resource. 
 
The right combo box “Human Resource” selection allows you to filter resources by class. 
 The left combo box “uses hum.resource” allows” you to specify certain types of execution 
such as “controlled by” or “supervised by”.2  
 
The “New” button adds new “Human Resources” and new “Human Resource” classes. 
The new instance will automatically be assigned the class which is selected in the combo 
box.  

 

Figure 15: Adding new Human Resources 

You can view and Edit all existing Resources that are child nodes of “Human Resource” in the 
Explorer. 

  

                                                 
2 These could be defined as subclasses of the relation “executes” 
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3.6.3 Task “Measures” Tab 

 
The “Measures” tab allows Processing Times, Fixed Cost, Variable Cost and Probabilities. 
Some of these attributes are used in reports and in the MS Project export. 

 

Figure 16: Task: Measures 

Relevant for simulation are the Work Plan Report, MS-Project and especially  “Processing 
Time”. For all others please see the Simulation Tutorial. 
 
Specific for BPMN is the Task type which can be selected on then BPMN tab. The Task type 
can also be changed using the menu or Property window. 

3.6.4 Sequence Flow Dialog 

Note on BPMN Methodology: 
A Sequence Flow is used to show the order that activities will be performed in a Process. 
Sequence flows can be associated with conditions. To add a condition please select the 
sequence flow shape and type in the Condition text. 
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Conditions can also be changed using the following dialog: 
 

 
 
The “Object Flow” tab  specifies which Data object, is “flowing” between the two connected 
tasks.  

 
 
You can select existing objects from the combo boxes. If you select an existing object, or 
enter a new one, you must push the “Add” button in order to add it to the list of flow 
objects. 
 
Object composition is similar to  “Compose” for Tasks. 
 
Class is the object. You can reuse existing classes or create new classes in a bottom up style. 
 
State (and Attribute) is the state of the object which is being sent e.g. “Order entered”. 
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You can remove an object from the list by double-clicking on it or by using the “Del” button. 

Object flow on sequence flows can also be specified using data objects. Editing the data object itself, 
will open the Sequence flow dialog. 

 

  

Figure 17: Sequence Flow: Measures 

The “Measures” tab allows the specification of Transportation Times, Fixed Costs, Variable 
Costs and Probabilities. 
 
NOTE: You can glue relations to any point on the object if you select the Visio option “Glue 
to geometry” (View -> Visual Aids) 
 

  

Figure 18: Visio: Snap & Glue Options 
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4 Org Charts 
Org Charts are used to graphically describe the organizational structure of your company. 
New elements are added using shapes for Org Unit and Position that are then connected by 
the “superior of” connector.  
 
Using Diagram->Insert (Model) you can add the existing org units “Sales” and “PD” to the org 
chart. 

 

Figure 19: Org Chart 

If you change the “Class” of PD and Sales to “OrgUnit” using the Edit dialog, you also change 
their shape in the OrgUnit Master (Object->Change Master).  
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Figure 20: Org Chart 

When you edit an Org Unit or Position, you can also add persons to the object.  
 

   

Figure 21: Adding Persons 

The person can be edited directly by double-clicking in the list. Organizational units are 
resources with measures such as Fixed Costs, Variable Costs and Capacities. 
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Figure 22: Org Chart with Persons 

5 Class Diagrams and Mastershapes 
Open a Visio Stencil using More Shapes.. Please open the Visio Stencil „Enterprise 
Application“ (ENTAPP_M.VSS, ENTAPP_U.VSS) for additional Visio Masters. You will find the 
stencil for Visio 2007 at „C:\Program Files\Microsoft Office \1031“ or for Visio 2003 at  
„C:\Program Files\Microsoft Office\VISIO11\1031“.i 
 
For Visio 2010 & 2013 users it is found under “More Shapes->Software and Databases-
>Software-> Enterprise Application” 
 
It is important to use the above instructions for accessing Visio shapes because if you drag 
an arbitrary Visio master onto your process sheet, SemTalk does not recognize the shape in 
the context of the current modeling method. A dialog is shown, which allows users to select 
the appropriate modeling construct. For example, you could make a Laptop an alternative 
symbol for System. If you “Ignore” a warning when using normal Visio shapes, Semtalk just 
accepts it as a Visio shape and does not add it to the SemTalk database. 
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Figure 23: Adding an arbitrary Visio Shape to a process 

Once you have used a Visio master as alternative Visio master, you will no longer be able to 
use that master for new classes.  
 
Instead of this bottom-up approach we can also define new classes of systems top-down on 
class pages. Create a new diagram of type “System Model” and drop some shapes there 
again. In the new diagram you can create classes and subclasses with attributes and 
associations. To add a new class, please use the “UML Class” shape.  A “subClassOf” relation 
between two classes is created with the “subClassOf” connector.  Associations are made 
with the “Property” connector.  It is a special behavior of class diagrams, that every class is 
automatically a subclass of their root class, which is in this case they are all “subClassOf”  the 
class System. 
You can also add new classes by opening a Visio stencil or by searching for a shape. Drop the 
shapes onto a System Model.  Now you can create further subclasses and superclasses. 

 

Figure 24: Classes of Systems 
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In the above example we have used the Visio shapes for Data store, Server etc.3 Computer 
using the UML Class master. 
 
The properties of the Visio master now have the attributes of the class. In the following 
picture you can see the attributes coming from Visio such as “Serial Number” and “Asset 
Number” and the inherited attributes coming from the root class “Participant” marked with 
a “*”. 

 

Figure 25: Attributes imported from Visio Masters 

Now let us assume we need a class named CRM System. Simply define it as a subclass of 
Data Store.  

 

Figure 26: CRM System Class 

                                                 
3 These shapes are much easier to use if you turn of “Snap to Member”  
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Since CRM System is a subclass of Data Store, SemTalk will use the Data Store shape for CRM 
Systems.   
 
Visio does not contain a specific master for CRM System, but we can easily create a new 
master shape in Visio or reuse another Visio master for our purpose. The document stencil 
(Shapes ->More Shapes-> Show Document Stencil) contains copies of used Visio masters. 
Copy the Database master (Shapes  More Shapes  Network  Active Directory Sites and 
Services) to the document stencil. Using right click master properties on the master you can 
rename the master to a class name of your choice. Please make a copy of “Database” and 
rename it  “CRM System”. 

 

Figure 27: Shapes for resources in the Document Stencil 

The CRM System master can now be used in the process model. 
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Figure 28: Renamed Visio Master 

NOTE: A good object-oriented model defines attributes on a common superclass rather than 
using classes created from Visio masters. 
If your new CRM does not have a text, you must customize the appearance of CRM Systems. 
Select “CRM System” in the Explorer and use Object->Customize (Shape). 
 

  

Figure 29: A System with a Visio Shape in a Process 
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6 Systems 
Please add a System to the process. For example, a CRM System or simply a “Service” if you 
skipped the preceding chapter and did not create a CRM System. 
 

 

Figure 30: A System with a Visio Shape in a Process 

Connect it to “Assign Customer” with a “Message flow” connector. These relations describe 
whether you store information to the system or whether you read information from the 
system. 
  
NOTE: You may insert the same System more than once into a process by using the right-
click menu  “Show Existing” and insert the desired system into your model. You may not 
insert an identical Task (same name, same ID number) more than once, but you can execute 
multiple instances of a Tasks.  They will have the same name but different ID numbers. 

 
A System is a Storage Device for Information or in general for objects. Objects can be stored 
in a system and afterwards be read from that system. Typical systems are the inbox of a mail 
client or a database. A system has a dedicated type. 
 
When you edit the system, you can specify which type of information is stored in the system. 
The general tab is identical to other dialogs. 
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Figure 31: System: Measures 

Fixed Cost is used to assign a cost to each information object stored in the system. Capacity 
settings set limits for the amount of information objects that are able to be stored in the 
system. Flush level and flush number are used to specify how information is sent through 
and outbound “Message flows” and times when the buffer should be flushed. 
 
In the “Message flow” relation you can select the type of information which is accessed or 
stored. 
 
Note: You can also edit the label of “Message flow” connectors directly to specify the 
information that is transferred. 
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As an alternative presentation to the “Service” master or cutomized master such as “CRM 
System” you can use the “System Lane” master shape and drop process elements onto this 
lane.  

 

 Figure 32: Service Masters 

7 Refinements (Sub-Process) 
Note: BPMN Methodology 

 
Breaking down a task into more detailed sub-tasks is expressed in the BPMN with 
multiple shapes such as “Sub-Process”. In SemTalk a refinement is more dynamic.  A 
(sub-) process for the detailed tasks can be attached to any task. For every inbound 
sequence flow link an (internal) entry point is added to the refined process. For 
outbound Sequence flows an (internal) exit point is added.  

 
Right Click on “Assign Customer” and select “Refine”. A dialog pops up asking for the name 
of the sub-process: 
 

 

Figure 33: Creating a Refinement 
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A new empty process with entry and exit point is generated: 
 

 

Figure 34: A new Refinement 

You can see in the Explorer the new process as a child node of “Business Process Diagram-0”. 
In Business Process Diagram-0” “Assign Customer” is now marked with a “+” to inform you 
that is has a refinement.  Any time you select “Refine” you open the refinement. Navigation 
is available on the “Home” tab. It allow to go from the refinement to the refined process. 
 

 
Refinements may have incoming and outgoing message flows. The events for those flows 
will use the message symbol instead of the link symbol. 
NOTE: If you use the option “External” you can assign a process in a different model as the 
refinement. In this case the refinement works like a hyperlink to the other model. But if this 
is done, there will not be any connected Entry or Exit points. 
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7.1 Attachments and Visio Hyperlinks 

Refinements are used for a unique structured decomposition of processes. Attachments are 
used to assign unstructured information such as documents, hyperlinks or arbitrary Visio 
pages to an object. In order to add an attachment please use the edit dialog or “Home-
>Hyperlink”. 

 

Figure 35: Editing Hyperlinks 

Use Sub address to attach other Visio pages to your model. Address will be used to attach 
documents or Hyperlinks. Language marks the document for a certain model language. If 
you select external documents you can decide to use a relative path. 
You may attach as many documents as you need. Please visit the general tutorial for further 
information. 
 
Navigation in the document and its HTML representation is realized via Visio-Hyperlinks: 
 

 

Figure 36: Navigation with Hyperlinks 
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On Visio shapes which are not SemTalk objects (e.g. Visio->Drawing->Rectangle) you can use 
standard Visio Hyperlinks. 

8 Customizing Colors 
In Visio you can assign design to your diagrams. Each design is a combination of a colorset 
and different effects. By applying a standard to a drawing all shapes will follow the same 
design. 
 

 
 
SemTalk has the option to assign colors by type (on the BPMN tab). After selection of this 
option Activities, Events and Gateways will get a specific color. 
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In order to change the colors for each type you can pick from existing colorset, modify a 
colorset or create new colorsets. 
 

 
Figure 37: Colored Process 

 
We have added 2 colorsets named “BPMN White” and “BPMN Colors” to the template. 

9 Simulation 
Simulation is available for SemTalk BPMN Edition. This allows testing the logical behavior of 
your process. Using colored Petri-Nets you can investigate your process in a dynamic 
environment with multiple inputs with Tasks that are processed in parallel so you can find 
out where bottlenecks will occur. 
 
Please refer to our Simulation Tutorial for details. 

 

Figure 38: Simulation 
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10 XPDL Export / Import 
The XML Process Definition Language (XPDL) has its origin in the text-based workflow 
exchange format of the Workflow Management Coalition (WfMC Interface 1) 
 

• Allow tools to exchange process models 

• Format to exchange Process Definitions between  
o Components within Workflow/BPM Products 
o Different BPM/Workflow Products 
o Process Modelling/ Simulation tools and BPM/Workflow Products 

 
In SemTalk you’ll find XPDL Export at File->Save & Send->BPMN-> XPDL Export 
(File->SaveAs->BPMN for the not Addin version). 
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Figure 39: XPDL Export 

A simliar XML based export format is specific for BPMN 2.0.  
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