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1. About Communication Structure Analysis (CSA) 
 

CSA („Communication Structure Analysis“)
1
 was described in the late 1980s at the Technical 

University of Berlin by Prof. H. Krallmann and his research team. 

 

CSA methodology was developed to represent and then optimize critical information flows, 

process flow sequences, and the organizational structures that support them.  CSA includes a 

sequence of phases such as analysis, simulation and optimization.  Each is performed in an 

iterative manner. A company model is created based on the definition of key objects and their 

relationships to one another such as activities performed, the role performed by each 

participant and a description of the information needed to complete an activity.  This model is 

then used to reengineer the organization.  An important aspect of creating this company model 

is the definition of key objects by using an object-oriented classification system for all of the 

different elements used within the company model.  

 

 

Figure 1: Company Model of CSA [UBIS 92] 

 

There are two primary diagram types used to describe different scenarios about how a 

company operates or should operate.  The first is the Organizational chart. The Organizational 

Chart shows how people or groups of people related to one another.  It also shows all of the 

management structures that support these relationships and the mechanisms that control 

performance quality.  This includes a description of who does what and the names given to 

the roles used to define people in the organization supported by a list of the names of 

everyone working in the organization.  The second type of scenario diagram is the Process 

Diagram.  Process diagrams show the sequence of activities, along with all of the physical and 

human resources used to perform these activities including the flow of information through 

the process.  

 

Organizational charts show the relationships between jobs or roles, business entities and 

actual employees as well as their job descriptions. Operators or groups are associated with 

hourly or fixed costs and capacities such as the hours they are available to work.  These 

people or groups are then assigned activities to perform.   

                                                 
1
 This methodology was first described in German as „Kommunikationsstrukturanalyse“ (KSA). 
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Process diagrams represent process flows, and include connections between each activity 

referred to as associations.  Input triggers are defined to show how often these activities are 

performed and their relative importance to one another so that processing priorities can be set.  

These input triggers also describe the relationship that this sequence of activities has to the 

outside world or to other process flows.   The activities are either assembled from pre-existing 

activity lists stored in a task library (functions model) or they are dynamically created as 

people directly define the flow of what they do within a Process diagram.  Information flows 

are represented using information classes that define the exact information used and info 

transfer device classes that define how the information is moved from one place to another. If 

the information flows to more than one activity or output, output conditions can be assigned 

to show the probability of the information flowing one way or another.  Information methods 

allow users to create information dependent models so it is possible to move information 

differently based on the information involved.  For example, contracts over $10,000 may need 

additional credit checks. Settings within model objects are able to recognize special 

information and reroute a process flow to an external diagram that handles the credit check 

process. 

 

Part of the CSA methodology is the use of refinements of activities or objects so that models 

do not become too complicated.  The general flow is described on the highest level diagram.  

If users want to see more detail, they simply open up the refinement to see all of the details.  

All of the relationships between these objects and their refinements are kept consistent by the 

methodology. 

 

In SemTalk CSA is the foundation for add-on solutions developed by IbWanner GmbH 

(Business Communication Platform), Knowlogy Solutions AG (SemTalk for E-Government) 

and Heidorn IT-Consulting GmbH (hispret for SAP). 
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2. Starting SemTalk CSA Edition 
 

In order to start SemTalk you can use “Start->Programs->SemTalk->SemTalk 2” or the icon 

on your desktop. The first time you start SemTalk it will come up with the following dialog, 

which gives new users quick access to available modeling methods.  

 

 

Figure 2: SemTalk Welcome Screen 

 

Please select “New” to start SemTalk CSA Edition. If have already used SemTalk, please 

open an CSA template with “File->New” and select “ksa.vst”. File menu options such as 

“Save”, “Save As” etc. are very similar to other MS Office applications especially to Visio. 

Most of the Visio commands used by SemTalk can be found in the “Visio” Menu. 

 

SemTalk shows up as shown on the following picture. 
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Figure 3: Starting SemTalk CSA Edition 

 

You can show the SemTalk explorer using the  Button or “Tools->Explorer->Show”. 

In the Explorer you will get a structured access to those objects contained in your model. 

 

Visio’s Pan & Zoom Window can be shown also:   

 

I  

 

The Stencil Windows and the Pan & Zoom Window can be “docked” to the Borders of the 

Visio pane with or without the Auto hide mode. 
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It also can be attached to a border of the Visio document. See Visio’s Help for details. 
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3. Describing a process 
 

3.1. Adding Process Elements 

 

You can add elements to the existing page: Simply drag them from the stencil to your diagram 

(or “Process”). Objects can be renamed by selecting the object and entering the new name. 

 

A process is a sequence of activities (Activity). It has well defined interfaces. These are Entry 

Point and Exit Point. Between every two of those elements the can be a flow a information 

(sends info). You can specify which information is exchanged between these process 

elements.   

 

 

 

 

 

We are using the term activity to refer to a step in a process.  

Breaking down an activity into more detailed activities is known in 

the KSA as refinement. A (sub-) process for the detailed activities is 

being attached to that activity. For every inbound sends info link an 

(internal) entry point is added to the refined process. For outbound 

sends info links an (internal) exit point is added. The yellow shape 

will be used, if resources must be displayed in the activity. The 

diamond shape may be used for decisions. 

 

Begin of a process. Information comes from a different process. 

 

End of a process. Information goes to a different process. 

 

 

A resource is an object which is required to execute the activity. The 

activity can only be executed if enough capacity of the resource is 

available. There are basically to kinds of resources: Physical 

resources such as laptops and human resources like an organizational 

unit.  

 

A Buffer is a storage device for information or in general for objects. 

Objects can be stored in a buffer and afterwards be read from that 

buffer. Typical buffers are the inbox of a mail client or a database. A 

buffer has a dedicated type. 

 

 

Adding links is quite simple. Drop the “sends info” shape somewhere on the background. If 

you hover its ends over an object’s “connections point” you are notified by a red square that 

you can glue the relation to that object. Select an ending point and glue your relation to the 

objects of your choice. 
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After adding some elements and connecting them with the “sends info” connector your 

diagram looks like this one: 

 

 

Figure 4: Adding Process Elements 

 

To speed up the creation of diagrams the stamp tool and the connector tool are very useful 

(both from the Visio-Menu). The connector tool is also available from the toolbar .  

 

CSA does not display human resources graphically in a process (even it could be easily 

customized to do so).  In order to do that you must use the Edit Dialog and assign a resource 

on the “Hum. Resources” tab, which will be explained later on. Let first begin with Swim 

lanes. 

 

3.2. Using Swim lanes 

 

Let’s first add another page: 
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This will create a new Visio Page of diagram class “Process”. You can rename that page 

directly by renaming the tab or a via a SemTalk dialog (Right Click-> Edit on the background 

or the menu item “Diagram->Edit”  

 

Swim lanes are well known from Visio’s Flowcharting stencil. They can be used via the 

command buttons  or the Visio Menu of SemTalk. 

 

 
 

 

After dropping functional bands on the drawing you select the title area of the Swim lane and 

go ahead typing. Alternatively you can select existing roles or org. units via the right click 

menu. (“Select Resource”). 
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Figure 5: Process with Swim lanes 

 

If you move an activity to a Swim lane, this is detected by SemTalk and the activity will be 

assigned automatically to the role of the Swim lane.  

If you select the head of a swim lane, you can create new roles just by renaming the swim 

lane. Via the right-click menu on the swim lane you can select existing roles and edit the 

objects.  

 

Inputs and outputs of activities are specified on the information flow. Select a link and type in 

the request. 

 

A process with information flow might look like: 
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Figure 6: Process with Swim lanes and information 

 

 

3.3. Object oriented process modeling 

 

If you select the menu „Object->Compose“ or right click compose, you will have the option 

to specify object oriented activities and entry/exit points. 
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Figure 7: Composing object oriented activities 

 

Root Class is the base object type: Object, physical resource, media etc. The most used type 

is “Information” for the business objects, but there are also other cases as “open letter” 

(media) or “boot Laptop” (physical resource). Please make sure you have selected 

“Information” for this tutorial. 

 

Class is the object the activity is related to. You can reuse existing classes or create new 

classes in a bottom up style. E.g. “Bid” is the class at “make Bid” 

 

The options State and Attribute allow to specify which of these feature will be used to create 

the activity name. For the KSA methodology only methods are relevant for activities. 

 

In the combo box Method the name of the method (or verb) can be entered newly or be 

selected from the already defined methods of the class 

 

SemTalk creates the class and method in case they are not existing yet in the database. In our 

example a class named “order” with the method “enter” will be created. 

 

The whole idea about compose is, that the name of the activity is generated from the 

name of the class and the name of the method. If classes or methods are being renamed, 

the name of the activity is being updated. Note that method (as well as attributes and 

state) can be inherited from super classes.  

 

The order of how the name of the activity will be generated is language specific („Order 

Enter” or “Enter Order”). You can change it as a general setting in the SemTalk options 

dialog. For English you will use “Method Object”. 

 

You can also specify to use “Compose” on any new activity: 
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A newly created Process with some object oriented activities (using no Swim lanes but the 

yellow activity shape): 
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Figure 8: An object-oriented Process 

 

The information objects “Order” and “Customer” are created in the background. A diagram of 

these (and some others) will look like this one: 
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Figure 9: Object Model 

 

If you make „Special Offer“ a subclass of „Offer“. “Special Offer” will inherit all methods 

from “Offer”. In the compose dialog those inherited methods will be shown in the method 

combo box. 

SemTalk ensures the consistency between object models and process models. If you rename a 

class or method all depending activities will be updated. 

 

We recommend object oriented process modeling especially for large projects. It is a good 

idea to define in a first step the most important business objects and build a catalogue of 

methods (verbs). This is the foundation of consistent process models.  

 

If you are going to use the same business objects in multiple projects we recommend to store 

such object libraries in separated files and publish them on intranet or extranet. The SemTalk 

Wizard will ensure, that those libraries are used consistently. 

 

3.4. Editing process elements 

 

You can now edit the objects on your diagram: 

 

1. By double clicking or 

2. Right Click “Edit” or 

3. Select & Menu “Object->Edit” or 

4. Find it in the explorer as a child of “Diagrams->Process->Process-6” or 
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5. Find it in the explorer as a child of “Objects->”. 

 

In case you just want to rename to object, you can select it and type-in the new name.  

You may also use the Properties Window, which allows to review and change the values 

directly. (Tools->Explorer->Properties) 

 

 

Figure 10: Properties Window 

3.4.1. Activity Dialog 

 

The activity dialog looks like this: 
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Figure 11: Activity Dialog 

  

Links (hyperlinks, attachments, documents), can be added with the right click menu “New” 

(“+” button), changed and removed by the right click menu “Remove” (“-“ button) on the 

background of the links list. Double clicking the link in the list box opens that document with 

the (for windows) associated application. Activities having at least one link will show up with 

a little marker in the upper left corner. 

 

NOTE: In order to change properties of all occurrences of the activity you must edit the class 

itself using “Object->Edit Class”. 
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Figure 12: Edit & Compose an Activity Class 

 

  

NOTE: The “General” tab is a generic SemTalk tab and not a KSA specific one.  

 

3.4.2. Activity “Hum. Resource” Tab 

 

 

Figure 13: Activity: Hum. Resource 
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On the “Hum. Resource”-tab you can assign “Human Resources” to the activity. These are 

people, roles or organizational units which actually execute the activity. The left hand list box 

shows the currently assigned resources and the right hand list box shows the list of all 

available human resources. 

You may use the arrow buttons to add / remove resources. Double clicking in the list boxes 

will edit the resource. 

 

The right combo box having the selection “Human Resource” allows to filter resources by 

class. 

 The left combo box having the selection “uses hum.resource” allows” to specify certain types 

of execution such as “controlled by” or “supervised by”.
2
  

 

Using the new button you can add new human resources and new human resource classes. 

The new instance will automatically get the class which is selected in the combo box. 

 

 

Figure 14: Adding new Human Resources 

 

You can see / edit all existing resources in the explorer as child nodes of “Human Resource” 

 

In the process the resources are now displayed in the lower section of the activity shapes: 

 

                                                 
2
 These could be defined as subclasses of the relation “executes” 
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Figure 15: Activity with Roles 

 

3.4.3. Activity “Condition” Tab 

 

The condition tab allows the specification of input and output conditions. Input and output 

conditions are relevant for simulation. 
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Figure 16: Activity "Condition" Tab 

 

Input condition: 

 

AND The process is waiting until a token came from all inbound sends-info links. 

OR The process is waiting until a token came from one inbound sends-info links. 

AND (sync) The process is waiting until a token with the same color (same original input) 

came from all inbound sends-info links. The option is used for 

synchronization. 

  

Output condition: 

 

AND A token will be send to all outbound sends-info links 

OR To all outbound sends-info links a token will be send if a random number is 

lower than the probability specified on the sends-info link. 

XOR To the first outbound sends-info link a token will be send if a random 

number is lower than the probability specified on the sends-info link. 

Otherwise the next link is being tested 

INFO A token is send to the outbound sends-info link if the incoming object is an 

(direct or indirect) instance of the class specified on the link. 

 

The conditions are not displayed in KSA. Some users prefer to show explicitly which 

activities are decision point. This can be done with the “Decision” Shape (similar to 

“Gateway”) in BPMN. 
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Figure 17: Using the Decision Shape 

 

3.4.4. Activity “Measures” Tab 

 

The “Measures” tab allows the processing time, fixed cost, variable cost and probability. 

Some of these attributes are used in reports and at MS Project export. 
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Figure 18: Activity: Measures 

 

 

Relevant for simulation, the work plan report, MS-Project etc. is especially the attribute 

“Processing Time”. For all others please see the Simulation Tutorial. 

 

3.4.5. Activity “ERP” Tab 
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Figure 19: Activity: ERP 

Using this tab transaction IDs and input / outputs can be specified. If you use the SAP R/3 

import transactions will be associated from the reference model. Activities that have at least 

one transaction will be drawn with a thicker border. 

3.4.6. Information Flow Dialog 

 

Note on KSA Methodology: 

  

Activities are related by flows of information („Sends Info“). A control flow of type 

“Sends Info” determines the sequence or order in which activities are executed. A 

sends info link is also an object- or dataflow which specifies the information or output 

exchanged between to activities. An output of one activity will be a precondition for 

the next activities. 

In order to analyze media breaks it is essential to model additionally the media which 

are used to transport the information. Typical classes of media are email, letters or 

other documents. 

The KSA method has third level colored Petri Net semantics, which can be 

implemented in simulation engines. Activities have preconditions like synchronization 

and output behavior like parallelization. 
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Figure 20: Object Flow 

 

The “Object Flow” tab allows you to specify the information or object which is “flowing” 

between the two connected activities. 

 

You can select existing information (or media) from the combo boxes. If you select an 

information type or enter a new one, you must push the “Add” button in order to add it to the 

list of information that flows. 

 

Object composition is done similar to the “Compose” for activities. 

 

Root Class is the base object type: information, physical resource, media etc. The most used 

type is information for the business objects. 

 

Class is the object. You can reuse existing classes or create new classes in a bottom up style. 

 

State (and Attribute) is the state of the object which is being send e.g. “Order entered”. 

 
You can remove an object from the list by double clicking it or by using the “Del” Button. 

 

NOTE: In SemTalk KSA Edition you may assign more than one information for each relation.  
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Figure 21: Information Flow: Measures 

 

The “Measures” tab allows the specification of transportation time, fixed cost, variable cost 

and probability. 

 

 

NOTE: You can glue relations to any point on the object if you select the Visio option “Glue 

to geometry” 
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Figure 22: Visio: Snap& Glue Options 

 

 

 

 

4. Org Charts 
 

Org Charts are used to describe the organizational structure of your company graphically. 

You may add new element using shapes for Org Unit and Position and connect them with 

then “superior of” connector.  

Using Diagram->Insert (Model) you can add the existing Org Units “Sales” and “PD” to the 

org chart. 

  

Before you can use the resources, which are created in Swim lanes (“Sales” and “PD”) in 

an Org Chart, they must be classified to be either of type “OrgUnit” or of type 

“Position”. Please use the Edit Dialog to change the class: 
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Figure 23: Org Chart 

 

If you edit an Org Unit or Position, you may add Persons to the element. 
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Figure 24: Adding Persons 

 

The person can be edited directly by double clicking in the list. Any organizational unit is a 

resource with measures like fixed cost, variable cost and a capacity. 
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Figure 25: Org Chart with Persons 

 

 

5. Class Diagrams 
 

Open as Visio Stencil using File->Open Stencil or search for a Visio shape. Please open the 

Visio Stencil „Networks and Peripherals“ (PERIPH_M.VSS, PERIPH_U.VSS) for additional 

Visio Masters. You will find the stencil for Visio 2007 at „C:\Program Files\Microsoft Office 

\1031“ or for Visio 2003 at  „C:\Program Files\Microsoft Office\VISIO11\1031“.
3
 

 

If you drag an arbitrary Visio master onto your process sheet SemTalk does not recognize the 

shape in the context of the current modeling method. A Dialog is shown which allows 

selecting the appropriate modeling construct. For example a Copier should be made a subclass 

of resource. “Ignore” just accepts it as a Visio shape and does not add it to the SemTalk 

database. 

 

                                                 
3
 If you are using Visio Shapes frequently it make sense to change file path for stencils (2003) or “My Shapes” 

(2007) using Visio’s options dialog. 
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Figure 26: Adding an arbitrary Visio Shape to a process 

 

Instead of this bottom up approach we can also define new classes of resources on class 

pages. Create a new diagram of type “Phys. Resource Model” and drop some shapes there 

again. 

 

In the new diagram you can create classes and subclasses with attributes and associations. To 

add a new class, please use the “UML Class” shape. A “subClassOf” (or is a) relation 

between two classes is created with the “subClassOf” connector. Associations are made with 

the “Property” connector. 

It is a special behavior of class diagrams, that every class is automatically a subclass of their 

root class, which is in this case the class Physical Resource. 

 

You can add new classes by opening a Visio stencil or search for a shape. Drop the shapes 

onto a PhysResource Model or drop onto the document stencil in case the shapes does not 

exactly have the intended name. If the shape does not have the right name it must be renamed 

in the document stencil and afterwards dropped on the page. 

 

The document stencil (Visio-> View->Document Stencil) will now contain copies of the used 

Visio masters. Using right click master properties on the master you can rename the master to 

a class name of your choice. Please rename “CRT projector” to “Beamer”. 

 

The properties of the Visio master are becoming attributes of the class. 
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Figure 27: Visio Shapes for resources in the Document Stencil 

 

Now you can create further subclasses and super classes. 

 

 

Figure 28: Classes of Physical Resources 
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We have used the Visio shapes for Printer, Plotter and Multi-function Device
4
. Printing 

Device has been created using the UML Class master. 

In the following picture you can see the attributes coming from Visio such as “Cost” and 

“Asset Number” and the inherited attributes coming from the root class “PhysResource” 

marked with a “*”. 

 

 

Figure 29: Attributes imported from Visio Masters 

 

The Printer is now known as a physical resource and can be used in the process model. 

 

                                                 
4
 These shapes are much easier to use if you turn of “Snap to Member” (Format->Behavior) 
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NOTE: A good object oriented model has the definition of attributes on a common super class 

rather than classes created from Visio masters. 

 

6. Resources 
 

Please add a resource to the process: 

 

 

 

Figure 30: A Resource with a Visio Shape in a Process 

 

Connect it to “Assign Customer” with a “uses phys.resource” connector.  

  

Note on KSA Methodology: 

A resource is an object which is required to execute the activity. The activity can only 

be executed if enough capacity of the resource is available. There are basically to 

kinds of resources: Physical resources such as laptops and human resources like an 

organizational unit. 

 

NOTE: You may insert the same physical resource more than once into a process using right-

click insert and check “Show Existing”. You may not insert the same activity call more than 

once, but you can make multiple calls to the same activity. 

 

Next step is to edit the Resource. The general tab is identical to other dialogs. 
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Figure 31: Physical Resource: Measures 

 

The measures tab of a physical resource has some fields used mainly for simulation purposes. 

Variable cost is depending on the time the resource is used. Fixed cost is a cost factor per 

access. 

 

For physical resources it makes sense to have a class model where you can specify all the 

types of resources you use in your model and assign shapes how to display them. 

 

If you edit the Printer object, you may change its class to any subclass of Printer, but not to a 

subclass of Beamer. 

 

Class models can be created for every other base type. 

 

NOTE: assigning shapes does not make sense if instances of that type are never created such 

as object or media, or never shown as such person and manager.  

 

NOTE2: you may also depict subclasses of activity by special symbols or change the layout of 

system shapes. 

7. Buffers (Information Storage Devices) 
 

Drag a “Buffer” onto your process sheet and connect it to “enter order” with “store to” or 

“read from” connectors. These relations describe whether you store information to the buffer 

or whether you read information from the buffer. 
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Figure 32: A Buffer in a Process 

 

Note KSA Methodology: 

 

A Buffer is a storage device for information or in general for objects. Objects can be 

stored in a buffer and afterwards be read from that buffer. Typical buffers are the 

inbox of a mail client or a database. A buffer has a dedicated type. 

 

If you edit the buffer you can specify which type of information is stored in the buffer. 

 

Buffers may have classes and graphical class in the same manner we have seen it in the last 

chapter for physical resources. 
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Figure 33: Buffer "Measures" Tab 

 

Fixed Cost is used to assign a cost for each information object, which is stored in the buffer. 

Capacity limits the amount of information objects that can be stored in the buffer. Flush level 

and flush number are used to specify that the information is send through and outbound 

“sends info” link if a certain number or time is exceeded.  

 

For the “read from” relation you can select the type of information which is accessed. 
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Figure 34: Access to a Buffer 

 

“store to” looks pretty similar. 

 

Note: You can also edit the label of “read from” or “store to” connectors directly to specify 

the information. 

 

8. Refinements 
 

Note KSA Methodology: 

 

Breaking down an activity into more detailed activities is known in the KSA as 

refinement. A (sub-) process for the detailed activities is being attached to that 

activity. For every inbound sends info link an (internal) entry point is added to the 

refined process. For outbound sends info links an (internal) exit point is added.  

 

Right Click on “Assign Customer” and select “Refine”. A dialog pops up asking for the name 

of the sub process: 
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Figure 35: Creating a Refinement 

 

A new empty process with entry and exit point is generated: 

 

 

Figure 36: A new Refinement 

 

You can see in the explorer the new process as a child node of “Process-8”. In “Process-8” 

“Assign Customer” is now underlined to inform you that is has a refinement. Any time you 

select “Refine” you open the refinement. The menu “SemTalk->Diagram->Go Up” navigates 

from the refinement to the refined process. 

 

NOTE: If you use the option “External” you can assign of process in a different model as the 

refinement. In this case the refinement works like a hyperlink to the other model. But you can 

not connect entry- and exit points. 

8.1. Attachments and Visio-Hyperlinks 

Refinements are used for a unique structured decomposition of processes. Attachments are 

used to assign unstructured information such as documents, hyperlinks or arbitrary Visio 

pages to an object. In order to add an attachment please uses the edit dialog. 
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Figure 37: Editing Hyperlinks 

 

Use Subaddress to attach other Visio pages. Address will be used to attach documents or 

Hyperlinks. Language marks the document for a certain model language. You may attach as 

many documents as you need. Please visit the general tutorial for further information. 

 

Navigation in the document and its HTML representation is realized via Visio-Hyperlinks: 
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Figure 38: Navigation with Hyperlinks 

 

 

 

9. Customizing Colors 
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Figure 39: Colored Process 

You have the option to change the color of shape for each type separately without touching 

the Visio Master shapes. Select Activity, OrgUnit or Decision in the “Objects” part of the 

SemTalk Explorer and select a color of your choice. 

 

 

10. Simulation 
 

Simulation is available for SemTalk KSA Edition. KSA is actually the only SemTalk method 

using all of the simulation functions. Simulation allows testing the logical behavior of your 

process in order to find possible deadlocks. 

Using colored Petri-Nets your can investigate your process in a dynamic environment with 

multiple inputs processed in parallel, in order to find out bottlenecks. 

 

Please refer to our Simulation Tutorial for Details. 
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Figure 40: Simulation 

 

 

11. Dialog View 
 

Dialog View allows controlling one Visio document from another. Every time you select a 

process shape in the main Visio document a shape (or “Control”) in the other Visio Document 

will be selected. This is intended to be used for the specification of IT-Systems, Workflows or 

Portals. It might be used in conjunction with the stepping mode of simulation. 

 

Dialog View can be opened from Tools->Dialog View->New/Open. The workspace will be 

split in two areas. You may create or modify user interfaces here. Any Visio document can be 

used. It does not have to be created with SemTalk.  
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Figure 41: Dialog View 

In order to connect a process element with a shape in the drawing please select both shapes 

and choose the option Tools->Dialog View->Capture. Each process element can only be 

assigned to one shape. Each time you select the process the shape will also be selected. This is 

actually what the Simulator does in Single-Step Mode. 
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Abb. 1: Dialog Tab 

 Using the dialog tab you can review and change your settings. Instead of 

connecting the Visio shapes, you may also connect the process element to 
hyperlinks. In order to do that you MUST open the browser via Tools->Dialog 

View->Browser.   

SaveAs Webpage will retain the links to an HTML representation of the 2nd Visio 
document. 

 

12. XPDL Export Import 
 

The XML Process Definition Language (XPDL) has it origin in the text-based workflow 

exchange format of the Workflow Management Coalition (WfMC Interface 1) 

 

 Allow tools to exchange process models 

 Format to exchange Process Definitions between  

o Components within Workflow/BPM Products 

o Different BPM/Workflow Products 

o Process Modelling/ Simulation tools and BPM/Workflow Products 

 

In SemTalk you’ll find XPDL Export at File->Export/Import->WfMC XPDL Export. 
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Figure 42: XPDL Export 

 

13. Importing from SAP
5
 

 

13.1. Import data from SAP Solution Composer 

You may use content from SAP Solution Composer in SemTalk KSA Edition and Visio 

(http://www.sap.com/solutions/businessmaps/composer/index.epx) in a pretty simple way. 

 

In order to get the SAP Look & Feel it is recommended to use the template „cview.vst“, 

which has the right colors and shapes. Supported diagram types are Component View and 

Collaborative Business Map. 

 

Copy (Crtl+C) a process at  Solution Composer and paste it at SemTalk (Crtl-V). Do not use 

Insert (Model) but Visio’s Paste command. Please select vertical swim lanes. 

 

                                                 
5
  R/3 and AcceleratedSAP are registered trademarks of SAP AG 

http://www.sap.com/solutions/businessmaps/composer/index.epx
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Figure 43: SAP Solution Composer (1) 

 

If you paste it into a process, the same process looks like this: 

 

 

Figure 44: SAP Solution Composer (2) 
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Via simple Copy & Paste you may also add variants and web service definitions of the ESA 

Preview System. 
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