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1. About Event-driven Process Chains (EPC)

»Event driven Process Chains®“ (EPC) have been introduced by Keller, Niittgens and Scheer
and they have become a de facto industry standard in German speaking countries.

For users of Microsoft Office products, EPC shapes are being shipped with the diagramming
tool Visio. A pure Visio-based creation of business processes using Visio’s EPC shapes is a
great bargain and very easy to use. For use in larger projects, some basic functions of
professional modelling tools are needed. Especially important is the ability to show a
distinction between model objects and how they are shown in drawings, navigation tools,
export / import interfaces and reports. Standard Visio shapes have no rules and they can be
connected without regard of EPC methodology rules. Interfaces and reports require the
syntactical correctness offered by SemTalk.
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2. Starting SemTalk EPC Edition

In order to start SemTalk you can use “Start->Programs->SemTalk->SemTalk3” or the icon
on your desktop. The first time you start SemTalk it will come up with the following dialog,

which gives new users quick access to available modeling methods.

-

—

n SemTalk Methed: epcvst

g

Welcome to SemTalk

Sem Talk comes with some predefined notations for popular modeling tasks. More notations such as

solutions by customizing these templates.

[~ Busines Process Modeling E——
- BPMM (Business Process Modeling Motation) S
- CSA [Communication Structure Analysis) [”ﬂ:;:r
- RACI [Quality Management) —
- SAP (Solution Manager / Composer) -L.':;w_
- Flow Chart (Visiao) -
- OrgChart (Visio) P

=~ Knowledge Modeling |
- QWL (Web Ortology Language) x
- T-Adapt (Sem. Datawarehouse Modeling) N.T.:HJ

= Cthers —

‘... No meta model [zemtallc vst) 'If"”m;

PROMET@wark ar SemTalk for E4Govemment available from our partners. You may also create your own

EPC i= a popular notation which has been
used by ERF vendors to define reference

models. i consists of Functions, Everts and
Operators. EPC emphasizes the control flow.
Sem Talk has interfaces to other EPC based

tools.

New ] [ Tutorial ] [ Cancel Do not show this dialog ag

ain

Figure 1: SemTalk Welcome Screen

Please select “New” to start SemTalk EPC Edition. If you have already used SemTalk, please
open an EPC template with “File->New” and select “epc.vst”. File menu options such as
“Save”, “Save As” etc. are very similar to other MS Office applications especially to Visio.

Most of the Visio commands used by SemTalk can be found in the “Visio” Menu.

SemTalk shows up similar to the following screen shot:
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Figure 2: Starting SemTalk EPC Edition
You can show the SemTalk explorer using the

s Button or “Tools->Explorer->Show”.

In the Explorer you will get a structured access to those objects contained in your model.

Visio’s Pan & Zoom Window can be shown also:

I
- SemTalk EPC Edition . .
t Diagram | Visic | Simulation Teools  Help
= EN:.: ‘ﬂ| View * m@ Pan and Zoom |ierman
L Drawing r Docurnent Stencil m
Shape L Search for Shapes
Format P 1= | aver Bronertiec

The Stencil Windows and the Pan & Zoom Window can be “docked” to the borders of the

Visio pane with or without the Autohide mode.
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It also can be attached to a border of the Visio document. See Visio’s Help for details.
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3. Editing a process
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3.1.

Adding Process Elements

You can add elements to the existing process: Simply drag them from the stencil to your
diagram (or “process”). Objects can be renamed by selecting the object and entering the new

name.

Note on EPC Methodology:

A process is a sequence of functions, events, operators and other elements. A function
is activated by one or more preceding events and it can create one or more events. But
a function can have only one incoming link (Control Flow) and one outgoing link. If
there are multiple events involved operators such as AND, OR; XOR must be used.

Borrowed from http://en.wikipedia.org/wiki/Event-driven_process_chain (Jan. 2007):

Event

Events are passive elements in EPC. They describe under what
circumstances a function or a process works or which state a function or a
process results. Examples of events are “requirement captured”, “material
on stock”, etc. In the EPC graph an event is represented as hexagon

Function

Functions are active elements in EPC. They model the tasks or activities
within the company. Functions describe transformations from an initial
state to a resulting state. In case different resulting states can occur, the
selection of the respective resulting state can be modeled explicitly as a
decision function using logical connectors. Functions can be refined into
another EPC. In this case it is called hierarchical function. Examples of
functions are “capture requirement”, “check material on stock”, etc. In the
EPC graph a function is represented as rounded rectangle. In general, a

EPC diagram 'must’ start with event and end with event.

OrgUnit.831

Organization units determine which person or organization within the
structure of an enterprise is responsible for a specific function. Examples

are “sales department”, “sales manager”, “procurement manager”, etc. It
is represented as an ellipse with a vertical line.

Entity.832

In the EPC, the information, material, or resource objects portray objects
in the real world, for example business objects, entities, etc., which can be
input data serving as the basis for a function, or output data produced by a
function. Examples are “material”, “order”, etc. In the EPC graph such an
object is represented as rectangle.

Branch and merge correspond to making decision of which path to choose
among several control flows. A branch may have one incoming control
flow and two or more outgoing control flows. When the condition is
fulfilled, a branch activates exactly only one of the outgoing control flows
and deactivates the others. The counterpart of a branch is a merge. A
merge may have two or more incoming flows and one outgoing control
flow. A merge synchronizes an activated and the deactivated alternatives.
The control will then be passed to the next element after the merge. A
branch in the EPC is represented by an opening XOR, whereas a merge is
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represented as a closing XOR connectors.

®

Fork and join correspond to activating all paths in the control flow
concurrently. A fork may have one incoming control flow and two or
more outgoing control flows. When the condition is fulfilled, a fork
activates all of the outgoing control flows in parallel. A join may have two
or more incoming control flows and one outgoing control flow. A join
synchronizes all activated incoming control flows. In the EPC diagram
how the concurrency achieved is not a matter. In reality the concurrency
can be achieved by true parallelism or by virtual concurrency achieved by
interleaving. A fork in the EPC is represented by an opening ‘AND”’,
whereas a join is represented as a closing ‘AND’ connectors

An ‘OR’ relationship corresponds to activating one or more paths among
control flows. An opening ‘OR’ connector may have one incoming
control flow and two or more outgoing control flows. When the condition
is fulfilled, an opening ‘OR’ connector activates one or more control
flows and deactivates the rest of them. The counterpart of this is the
closing ‘OR’ connector. When at least one of the incoming control flows
is activated, the closing ‘OR’ connector will pass the control to the next
element after it.

Adding links is quite simple. Drop the “Control Flow” shape somewhere on the background.
If you hover its ends over an object’s “connections point” you are notified by a red square that
you can glue the relation to that object. Select an ending point and glue your relation to the
objects of your choice.

After adding some elements and connecting them with the “Control Flow” connector your
diagram looks like this one:
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Figure 3: Adding Process Elements

To speed up the creation of diagrams the stamp tool and the connector tool are very useful

(both from the Visio-Menu). The connector tool is also available from the toolbar & .

SemTalk performs a syntax check on the following rules:

e Functions and Events may have only one outgoing control flow.

e Functions and Events may have only one ingoing control flow

e Each control flow must connect two different objects

e Itis not allowed to use an OR or XOR operator after an event, since events are passive
elements, which can make no decisions as functions do

e Operators may have multiple inputs (Join) or multiple outputs (Split), but not both

e Outputs of an operator must be of all of type function or all of type event

e Inputs of an operator must be of all of type function or all of type event

e Events and functions must be used alternating

SemTalk does NOT check the following useful rules in order to make graphical modeling
possible:

e Joins and Splits are modeled by operators. If a process was split by an operator, the
process may only be joined be the same type of operator

e Each EPC must start and finish with an event. (exception: process path)

e There are no isolated nodes

e At least one event must precede a function and at least one event must follow each
function.
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You may turn off EPC syntax checking via Tools->SemTalk Options->EPC. This is
recommended if you import EPC from 3™ Party Tools or certain reference models ;-)

There are basically two ways how to express that a function is executed by a Person, Position
or an Organizational Unit:

1. Add their Shapes to the process and connect them with the function using the
“executes” connector or the connector tool. The disadvantage of this “classical”
approach is that diagrams often get overloaded with symbols and become difficult to
read. This approach is recommended, if the control-flow itself is more important than
the exchange between actors.

2. Using Swim lanes

~
H Document - SemTalk EPC Edition E@g
File  Object Diagram Visic  Tools Help
DEHSAATEXD + » kA Eo@DHE & ww * English M
Explorer x (] 1 1 i 1+ | Pan &Zoom 8 x I
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(I [=1-{£% Diagrams E -[-
| E-iy eEPC = HE
E-&F EPK-1] E |
i @ Customer called 735 = ‘Customer called @ e
i 1 Talk to Customer "“T:: HEs
Customer is interested. 740 || 5 ! o] e
Customer is not interested. 7, 15| H @
w2 Develop Solution = - - 8
- Sales = |- 8
H H = Talk to Sal
- FD E Customer ales —f
fl 4 Objects E
l = ; -
E | --
3 /!\ a
I 3 @ Shapes [ 2
N —‘:f Search for Shapes El R
(| =
| iE More Shapes b
E Customer ks ustomer is not Quick Shapes
| interested interested [ e

EPC -

Drop Quick Shapes here

Develop
Solution 2

'
ProcessPath 'I Cantrol Flow
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XOR D Comment

------- = definition0f  [__] Person
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4 » M| EPK-1 ¥ 4 [T » DPﬂs\tmn ;lﬂrgam;at\o... v

oL A0 AR R 1 R

T

=%

< 1 |
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Figure 4: Classical eEPC

3.2. Using Swimlanes

Let us first add a new EPC diagram:
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ent - SemTalk EPC Editic

bject | Diagram | Visic Tools Help
gl New v [ eepc I
S Edit Object Model
del | ¥ Delete OrgChart
Diagra PhysResource Model
= oF T Insert (Model)

This will create a new Visio Page of diagram class “eEPC”. You can rename that page
directly by renaming the tab or a via a SemTalk dialog (Right Click-> Edit on the background
or the menu item “Diagram->Edit”

Swimlanes are well known from Visio’s Flowcharting stencil. They can be used via the

i

command buttons or the Visio Menu of SemTalk.

nent - SemTalk EPC Editio

Object  Diagram | Visio | Toels Help
daa @ T View b |@  Panand Zoom nglish
Drawing r Docurment Stencil B8 s

odel Shape s Search for Shapes

7 Diagrams Format ¥ |5 Layer Properties

5'"%.%?:;:“_1“ 3 Undo Strg+Z | Swimlanes 4 | I” Horizontal
@ Customef Select Al Strg+A = m
: g:uTsEtlLkr;:i ¢  Pointer Tool Strg+1 Connection Points 2 T
i@ Custome| P Connector Tool Strg+3 Rulers

After dropping functional bands on the drawing you can select existing roles or org. units via
the right click menu. (“Select Resource”).
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Figure 5: EPC with swim lanes

If you move a function to a swim lane this is detected by SemTalk and the function will be
assigned automatically to the role of the swim lane.

If you select the head of a swim lane, you can create new roles just by renaming the swim
lane. Via the right-click menu on the swim lane you can select existing roles and edit the
objects.

Inputs and outputs of functions are specified using entitytype shape. The same entitytyp
element can be used multiple times in the model and on a page (such as events, org. units,
persons etc.)

An EPC diagram using the elements mentioned above might look like:
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Figure 6: EPC with swim lanes and input / output

3.3. Object oriented process modeling

If you select the menu ,,Object->Compose* or right click compose, you will have the option
to specify object oriented functions and events.
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Class: Solution - Al @
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> [ Al
Method: Develop - Al
[ OK ]| Cancel |

Figure 7: Composing object oriented functions

Class is the business object the function is related to. You can reuse existing classes or create
new classes in a bottom up style. E.g. “Bid” is the class at “make Bid”

The options State and Attribute allow to specify which of these feature will be used to create
the function name. For the EPC methodology only methods are relevant for functions and
states are relevant for events.

In the combo box Method the name of the method (or verb) can be entered newly or be
selected from the already defined methods of the class

SemTalk creates the class and method in case they are not existing yet in the database. In our
example a class named “order” with the method “enter” will be created.

The whole idea about compose is, that the name of the function is generated from the
name of the class and the name of the method. If classes or methods are being renamed,
the name of the function is being updated. Note that methods (as well as attributes and
state) can be inherited from super classes.

The order of how the name of the function will be generated is language specific (,,Order
Enter” or “Enter Order”). You can change this as a general setting in the SemTalk options
dialog. For English you will use “Method Object”.

You can also specify to use “Compose” on any new function or event:
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A new created eEPC with some object oriented functions and events:
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Figure 8: An object-oriented EPC

The objects “Order” and “Customer” are created in the background. A diagram of these (and
some others) will look like this:
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Figure 9: Object Model

If you make ,,Special Offer” a subclass of ,,Offer”. “Special Offer” will inherit all methods
from “Offer”. In the compose dialog those inherited methods will be shown in the method
combo box.

SemTalk ensures the consistency between object models and process models. If you rename a
class or method all depending functions will be updated.

We recommend object oriented process modeling especially for large projects. It is a good
idea to define in a first step the most important business objects and build a catalogue of
methods (verbs). This is the foundation of consistent process models.

If you are going to use the same business objects in multiple projects we recommend to store
such object libraries in separated files and publish them on intranet or extranet. The SemTalk
Wizard will ensure, that those libraries are used consistently.

3.4. Editing process elements

You can now edit the objects on your diagram:

By double clicking or

Right Click “Edit” or

Select & Menu “Object->Edit” or

Find it in the explorer as a child of “Diagrams->EPC->EPC-3” or
Find it in the explorer as a child of “Objects->".

orwdPE
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In case you just want to rename to object, you can select it and type-in the new name.
You may also use the Properties Window, which allows to review and change the values
directly. (Tools->Explorer->Properties)

u Document - SemTalk EPC Edition Elﬁu
File  Object Diagram  Visioc Tools Help
D EHdSARATEXD + 4+« i F @ OE & 00% ~ English -
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Figure 10: Properties Window

3.4.1. Function Dialog

The function dialog looks like:
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u Function: Enter Order.l &0 S ’ E@ﬂ

General | Hum, Resource | Measures | ERP | Audit |
MName Erter Order T
[ndex: 1
Comment:
Links: :
[ Fead Cnly
[ QK ] [ Cancel ]

| : -

Figure 11: Function Dialog

Note EPC Method:

We are using the term function call to refer to a step in a process. Each function call is
an (anonymous) instance of its function. E.g. enter Order is the function and enter
Order.123 a function call in a process.

Links (hyperlinks, attachments, documents), can be added with the right click menu “New”
(“+” button), changed and removed by the right click menu “Remove” (‘- button) on the
background of the links list. Double clicking the link in the listbox opens that document with
the (for windows) associated application. Functions having at least one link will show up with
a little marker in the upper left corner.

NOTE: In order to change all occurrences of the function you must edit the class itself using
“Edit Class”.
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Figure 12: Edit & Compose a Function Class

NOTE: The “General” tab is a generic SemTalk tab and not an EPC specific one.

3.4.2. Function “Hum. Resource” Tab
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-
u Function: Enter Order.l S5 S ) EM

General | Hum. Resource | Measures | ERF |.P-.|.|d'rt |

[Human Resource v]
Mumber of Resources:
Hum. Resource:
FD
Sales

h

| ok || cancsl |

| -

Figure 13: Function: Hum. Resource

On the “Hum. Resource”-tab you can assign “Human Resources” to the function. These are
people, roles or organizational units which actually execute the function. The left hand list
box shows the currently assigned resources and the right hand list box shows the list of all
available human resources.

You may use the arrow buttons to add / remove resources. Double clicking in the list boxes
will edit the resource.

The right combo box having the selection “Human Resource” allow to filter resources by
class.

The left combo box having the selection “executes” allows” to specify certain types of
execution such as “controls” or “supervised by”.l

Using the new button you can add new human resources and new human resource classes.
The new instance will automatically get the class which is selected in the combo box.

! These could be defined as subclasses of the relation “executes”
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u Function: Enter Crder.1 | = = 22 |

General | Hum. Resource | Measures | ERP | Audit |

[ Human Resource -

Mumber of Resources:
Hum. Resource:

”
Human Resource

=
||
i

reernew teme

| oK || Canesl |

Figure 14: Adding new Human Resources

You can see / edit all existing resources in the explorer as child nodes of “Human Resource”

3.4.3. Function “Measures” Tab
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Cost Driver:
Priority: 0 =
Distribution: Constant Value -
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Figure 15: Function: Measures

Relevant for simulation, the workplan report, MS-Project etc is especially the “Processing
Time”. For all others please see the Simulation Tutorial.

3.4.4. Function “ERP” Tab
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u Function: Enter Order.l S » E@gj
| General | Hum. Resource | Measures | ERF |.P-.|.|d'rt |
Relation [has Transaction v]
TR123 TR123
|
| ok || cancsl |
U
\ — . |

Figure 16: Function: ERP

Using this tab transaction I1Ds and input / outputs can be specified. If you use the SAP R/3
import transactions will be associated from the reference model. Functions have at least one
transaction will be drawn with a thicker border.

3.4.5. Control Flow Dialog
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Figure 17: Control Flow: Measures

The “Measures” tab allows the specification of transportation time, fixed cost, variable cost
and probability.

NOTE: You can glue relations to any point on the object if you select the Visio option “Glue
to geometry”
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Figure 18: Visio: Snap& Glue Options

4. Value Chains

Using a Value Chain diagram (“Diagram->New->Value Chain”) you can describe processes
which are directly creating value for your company. Value Chain Elements (Functions) are
connected with the connectors “is superior of”” and “has Successor”

Mo ]
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File  Object Diagram Visio  Tools Help
DEHSIATEXRXI v+« F rE0@IDTE & 0% - English =
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Figure 19: Value Chain
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Value Chains do not contains events or other symbols. They are intended to be used as a
general overview of the process landscape.

Each function may be refined by another Value Chain or an EPC diagram. EPC diagrams
must be created before they can be attached to value chain elements. Value Chain elements
which have an attached diagram are being drawn underlined. They also got a Visio Hyperlink
in the context menu for navigation.

5. Org Charts

Org Charts are used to describe the organizational structure of your company graphically.
You may add new element using shapes for Org Unit and Position and connect them with
then “superior of”” connector.

Using Diagram->Insert (Model) you can add the existing Org Units “Sales” and “PD” to the
org chart. After insertion you can change the shape using Object->Shape to the one used in
the next screenshot:
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Figure 20: Org Chart

If you edit an Org Unit or Position, you may add Persons to the element.
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Figure 21: Adding Persons

The person can be edited directly by double clicking in the list. Any organizational unit is a
resource with measures like fixed cost, variable cost and a capacity.
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Figure 22: Org Chart with Persons

6. Class Diagrams

Open as Visio Stencil using File->Open Stencil or search for a Visio shape. Please open the
Visio Stencil ,,Networks and Peripherals* (PERIPH_M.VSS, PERIPH_U.VSS) for additional
Visio Masters. You will find the stencil for Visio 2007 at ,,C:\Program Files\Microsoft Office
\1031* or for Visio 2003 at ,,C:\Program Files\Microsoft Office\VISIO011\1031¢ .2

For Visio 2010 use “More Shapes->Network->Network and Periphals”

If you drag an arbitrary Visio master onto your process sheet SemTalk does not recognize the
shape in the context of the current modeling method. A dialog is shown which allows
selecting the appropriate modeling construct. For example a Copier should be made a subclass
of resource. “Ignore” just accepts it as a Visio shape and does not add it to the SemTalk
database.

2 If you are using Visio Shapes frequently it make sense to change file path for stencils (2003) or “My Shapes”
(2007) using Visio’s options dialog.
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Figure 23: Adding an arbitrary Visio Shape to a process

Instead of this bottom up approach we can also define new classes of resources on class
pages. Create a new diagram of type “Phys. Resource Model” and drop some shapes there
again.

In the new diagram you can create classes and subclasses with attributes and associations. To
add a new class, please use the “UML Class” shape. A “subClassOf” (or is a) relation
between two classes is created with the “subClassOf” connector. Associations are made with
the “Property” connector.

It is a special behavior of class diagrams, that every class is automatically a subclass of their
root class, which is in this case the class Physical Resource.

You can add new classes by opening a Visio stencil or search for a shape. Drop the shapes
onto a PhysResource Model or drop onto the document stencil in case the shapes does not
exactly have the intended name. If the shape does not have the right name it must be renamed
in the document stencil and afterwards dropped on the page.

The document stencil (Visio-> View->Document Stencil) will now contain copies of the used
Visio masters. Using right click master properties on the master you can rename the master to
a class name of your choice. Please rename “CRT projector” to “Beamer”.

The properties of the Visio master are becoming attributes of the class.
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Figure 24: Visio Shapes for resources in the Document Stencil

Now you can create further subclasses and super classes.
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Figure 25: Classes of Physical Resources

Copyright: Semtation GmbH 2001-20010



SemTalk EPC Tutorial 04/12/2010
Email: support@semtalk.com

We have used the Visio shapes for Printer, Plotter and Scanner®. Printing Device has been
created using the UML Class master.

In the following picture you can see the attributes coming from Visio such as “Cost” and
“Asset Number” and the inherited attributes coming from the EPC root class “Resource”
marked with a “*” (visible only after checking ‘System’ checkbox).

u Class: Printer [ = | E ihj

General | Attibutes |5tates |.ﬁssociatinns Language | Methods | Audit |

MName Walue

ShapelClass
Shape Type
SubShape Type
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Administrative Intedace
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MALC Address
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Metwork Description
* Strategy (Ressource)
* SetupTime (Ressource)
* FiedCost (Ressource)
* VarableCost (Ressounce)
* Capacity (Ressource)

* 0T (Ressource) *QOT_APPL_SYS

| MNew || Edt || Vaue || Delete |

| ok || cancel | [¥] Svstem

Figure 26: Attributes imported from Visio Masters

The Printer is now known as a physical resource and can be used in the process model.

NOTE: A good object oriented model has the definition of attributes on a common super class
rather than classes created from Visio masters.

¥ These shapes are much easier to use if you turn of “Snap to Member” (Format->Behavior)
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7. Resources

Please add a resource to the process:
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Figure 27: A Resource with a Visio Shape in a Process

Connect it to “assign customer” with a “is used by” connector.

Note on EPC Methodology:
A resource is an object which is required to execute the function. The function can
only be executed if enough capacity of the resource is available. There are basically to
kinds of resources: Physical resources such as laptops and human resources like an
organizational unit.

NOTE: You may insert the same physical resource more than once into a process using right-
click insert and check “Show EXisting”. You may not insert the same function call more than
once, but you can make multiple calls to the same function.

Next step is to edit the Resource. The general tab is identical to other dialogs.

Copyright: Semtation GmbH 2001-20010



SemTalk EPC Tutorial 04/12/2010
Email: support@semtalk.com

r'u Ressource: Printer.858 & - = l — | (=) |_i“3-]1
General | Measures | Adit

Fieed Cost: 10

Wariable Cost: 15

Capacity: 1 =

Strategy: FIFO

Setup Time: 1|
|
|

| ok || cancsl |

Figure 28: Physical Resource: Measures

The measures tab of a physical resource has some fields used mainly for simulation purposes.
Variable cost is depending on the time the resource is used. Fixed cost is a cost factor per
access.

For physical resources it makes sense to have a class model where you can specify all the
types of resources you use in your model and assign shapes how to display them.

If you edit the Printer object, you may change its class to any subclass of Printer, but not to a
subclass of Scanner.

Class models can be created for every other base type.

NOTE: assigning shapes does not make sense if instances of that type are never created such
as object or media, or never shown as such person and manager.

NOTEZ2: you may also depict subclasses of activity by special symbols or change the layout of
system shapes.

8. Refinements

The EPC method in SemTalk is basically compatible with the given standard.
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The concept of process references has been solved slightly different. There is no special
symbol to denote a reference to a sub process. Functions can be refined by attaching an EPC
diagram. Refined functions are being drawn with underlined characters similar to a hyperlink
in a browser. If the standard process path shape is required a user may select that shape for a
specific function call. Each sub process automatically gets copies of the start and end events
inherited from the refined function.

Right Click on “Assign Customer” and select “Refine”. A dialog pops up asking for the name
of the subprocess:

- T
u Attach Reﬁnement- E@g
Dizgram: v | Edemal

| ok | | cancsl |

b - - -

Figure 29: Creating a Refinement

A new empty EPC with start and end events is generated:
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Figure 30: A new Refinement

You can see in the explorer the new process as a child node of “eEPC-5”. In “eEPC-5”
“Assign Customer” is now underlined to inform you that is has a refinement. Any time you
select “Refine” you open the refinement. The menu “SemTalk->Diagram->Go Up” navigates
from the refinement to the refined process.
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NOTE: If you use the option “External” on the refine dialog, you can assign a process from a
different model. In this case the refinement works like a hyperlink to the other model. But you
cannot connect entry- and exit points.

8.1. Attachments and Visio-Hyperlinks

Refinements are used for a unique structured decomposition of processes. Attachments are
used to assign unstructured information such as documents, hyperlinks or arbitrary Visio
pages to an object. In order to add an attachment please uses the edit dialog or Object-
>Hyperlink.

r w  TE—— —
BHyperIink =RNC X

Address: | E]

Use relative path for hypedink

Subaddress: -

Properties
Label:

Language: -

Type: Attachment - ]

Properties for HTML view
Frame: [] Mew Window
Bxdralnfo:

| oK || cancel |

Figure 31: Editing Hyperlinks

Use Subaddress to attach other Visio pages. Address will be used to attach documents or
Hyperlinks. Language marks the document for a certain model language. You may attach as
many documents as you need. Please visit the general tutorial for further information.

Navigation in the document and its HTML representation is realized via Visio-Hyperlinks:
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Figure 32: Navigation with Hyperlinks
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Figure 33: 16 Bit Colored Process

You have the option to change the color of shapes for each type separately without touching
the Visio Master shapes. Select Function, OrgUnit or Event in the “Objects” part of the
Explorer and select a color of your choice.

10. Simulation

Simulation is available for SemTalk EPC Edition. Simulation allows testing the logical
behavior of your process in order to find possible deadlocks.

Using colored Petri-Nets you can investigate your process in a dynamic environment with
multiple inputs processed in parallel, in order to find out bottlenecks. According to EPC
semantics SemTalk’s simulation is a bit limited: You can place multiple tokens having each
its own color on one event, but you can not place tokens with the same color on multiple
events.

Please refer to our Simulation Tutorial for Details.
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Figure 34: Simulation

11. Dialog View

Dialog View allows controlling one Visio document from another. Every time you select a
process shape in the main Visio document a shape (or “Control”) in the other Visio Document
will be selected. This is intended to be used for the specification of 1T-Systems, Workflows or
Portals. It might be used in conjunction with the stepping mode of simulation.

Dialog View can be opened from Tools->Dialog View->New/Open. The workspace will be

split in two areas. You may create or modify user interfaces here. Any Visio document can be
used. It does not have to be created with SemTalk.
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Figure 35: Dialog View

In order to connect a process element with a shape in the drawing please select both shapes
and choose the option Tools->Dialog View->Capture. Each process element can only be
assigned to one shape. Each time you select the process the shape will also be selected. This is
actually what the Simulator does in Single-Step Mode.
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Figure 36: Dialog Tab

Using the dialog tab you can review and change your settings. Instead of connecting the Visio shapes,
you may also connect the process element to hyperlinks. In order to do that you MUST open the
browser via Tools->Dialog View->Browser.

SaveAs Webpage will retain the links to an HTML representation of the 2" Visio document.

12. XPDL Export

The XML Process Definition Language (XPDL) has it origin in the text-based workflow
exchange format of the Workflow Management Coalition (WfMC Interface 1)

e Allow tools to exchange process models
e Format to exchange Process Definitions between
o Components within Workflow/BPM Products
o Different BPM/Workflow Products
o Process Modelling/ Simulation tools and BPM/Workflow Products

In SemTalk you’ll find XPDL Export at File->Export/Import->WfMC XPDL Export.
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Figure 37: XPDL Export

13. Importing and Exporting of ARIS and EPML*

The import and export of ARIS models is possible using the ARIS XML format named AML.
You will find the interfaces at File -> Export/Import -> EPML, AML “.

e AML is the XML Export format of ARIS.

e EPML is a vendor independent exchange format for EPC (www.epml.de ). AML can
be converted to EPML and vice versa.

13.1. AML

* ARIS is a trademark of IDS Scheer AG
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Using SemTalk you can read and write the ARIS XML format (,,AML®). Select in ARIS® the
diagrams (,,Models*) of your choice and export them with the context menu ,,Export/Import-
>XML Export“. AML Explorer shows the ARIS folder structure of the AML file you have
selected. Use the check boxes in the docked window to mark the objects you intend to import
to SemTalk. Right-Click SemTalk will import the objects to SemTalk.
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Figure 38: AML Explorer

The AML Import Options can be opend via a right click menu in the AML Explorer window.
Select all languages you need. ARIS models can be imported for multiple languages. In order
to review ARIS XML in IE or to use it in SemTalk and other programs you need a file named
,,ARIS-Export.dtd*, which can be found in the ARIS program folder in a directory named
,,aml®“. Please copy the DTD to the directory where the XML export is located.

The Import Option allow to specify which object type are mapped to specific SemTalk classes
and which symbol are mapped to specific Visio masters.

SemTalk imports all languages available in the ARIS export file. You may choose the actual
language for viewing the model after import. “Primary language” is the language for creating
internal object names.

® Supported versions for import are 6.1, 6,2 and 7.x. For other versions please contact support@semtalk.com
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Figure 39: ARIS Import Options

Select the diagrams of your choice and import them to SemTalk. ARIS diagrams are often
very large so that it makes sense to adjust to page size with “Resize to fit Contents”.

ARIS has more than 100 diagram type with more than 200 object types. Since we intend to
keep our EPC version easy to use and understandable, we do not include them in the delivered
version. New diagram and object types will be created dynamically while import. The import
will not create new Visio Shapes from ARIS. All unknown types use the “Instance” Shape
(gray ellipsis). If you add the right shapes with the right names to the document stencil before
import, they will be recognized. Please contact support@semtalk.com if you need assistance.
If you use the option “Import Shape Size” positioning and size will be taken form ARIS.
SemTalk & Visio shapes are usually much smaller.
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Figure 40: Imported EPC

The export to ARIS AML may be done using: File -> Export/Import -> EPML, AML-
>AML Export.

13.2. EPML

EPML (Event driven Process Chain Markup Language) was proposed by Mendling und
Nittgens in the year 2002. Compared to the XML export format of ARIS named AML, it has
human readable tags for the process elements. While AML is a method independent format
exporting internal ARIS structures as there are nodes, definitions and links, EPML exposes
the elements of EPC as tags.

In order to export / import EPML you can simply open EPML files.
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Figure 41: Import of EPML

If you need to convert ARIS EPC to EPML, you have to save the EPC diagrams of your
choice in ARIS to the ARIS XML format.

The ARIS export file can be transformed to EPML with the xsl transform “AML2EPML.xs|”
which is located in the SemTalk directory or by the Menu entry “ARIS -> EPML”.
Conversions of AML to EPML take some minutes.

14. Importing from SAP®

14.1. Importing from SAP R/3

AcceleratedSAP (ASAP) is SAP's standard implementation methodology. It contains the
Roadmap, a step-by-step guide that incorporates experience from many years of
implementing R/3. Along with that, AcceleratedSAP contains a multitude of tools,
accelerators and useful information to assist all team members in implementing R/3. Quality
checks are incorporated at the end of each phase to easily monitor deliverables and critical

® R/3 and AcceleratedSAP are registered trademarks of SAP AG
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success factors. ASAP is delivered as a PC-based package, so that - if required - an
implementation project can begin prior to having an R/3 System installed.

The R/3 Reference Model contains comprehensive graphical process flows describing the R/3
functionality from different points of view. It contains scenarios, processes and functions, as
well as components. The R/3 Reference Model can be viewed using SAP's Business
Navigator and the Business Navigator Web, or using third-party modeling tools available
from modeling partners.

The R/3 Reference Model can be imported into SemTalk if the database is installed on the
system. You need to have an SAP Value SAP CD, Edition 1 or Edition 2. Copy the file
Drive:\Viewers\Intellicorp\English_mdb\DiagramExplorer46C.mdb to your disk. Open the
SAP R/3 4.6¢ Import interface from “File->Export / Import” and select the database file using
“File-> ASAP Repository”. There is no need to install the ASAP toolkit for importing
processes to SemTalk.
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Figure 42: SAP R/3 Import

EPC are drawn in the drawing pane of the import interface if you select their title in the
explorer. The explorer can filter by “Enterprise Area”, “Scenario”, “Process Group” or
“Process”.

Check some (but not too many) processes and import them using “File->Import”. If there is
information regarding transaction, inputs, output are technical object numbers in the database,
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this information will be imported to SemTalk. EPC containing this information will be
marked with a (“*”) in their title after selection.

14.2. Import data from SAP Solution Composer, ESR and
Solution Manager

The SAP import interface can be opened via File->Export/Import->SAP Explorer. It consists
of the parts:

SAP Solution Composer

SAP Enterprise Service Repository

SAP Solution Manager

Content from SAP Solution Composer covers reference processes for a broad range of SAP
solutions. It can be used in SemTalk EPC Edition and Visio after installing SAP Solution
Composer locally on your machine:
(http://www.sap.com/solutions/businessmaps/composer/index.epx)

Content from Enterprise Service Repository is only available via the Internet. It contains a set
of services and service descriptions which are usefull to SOA oriented process models.
Content from Solutions Manager describes your current SAP implementation. If you save a
business blueprint from SAP solution manager, you may use its content from within SemTalk.

All these entry points into the SAP world are presented jointly in SemTalk’s SAP Explorer.
Use Drag&Drop or check parts of the objects shown in the SAP Explorer and import them
into process modells. Beyond process steps you will find information about SAP Systems,
Business objects, transactions and organisational units.

In order to get the SAP Look & Feel it is recommended to use the template ,,cview.vst*,

which has the right colors and shapes. Supported diagram types are Component View and
Collaborative Business Map.
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Figure 43: SAP Solution Composer (1)

Imported into EPC, the same process looks like this:
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Figure 44: SAP Solution Composer (2)

Via simple Drag & Drop you may also add variants and web service definitions of the
Enterprise Service Repository (needs Internet Access) and from a SAP Solution Manager
Blueprint.

If you have installed the Solution Composer not in the default place or if you would like to
use Solution Manager, you should update your SAP setting at Options->SAP:
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Figure 45: SAP Import Options

Copyright: Semtation GmbH 2001-20010




SemTalk EPC Tutorial 04/12/2010
Email: support@semtalk.com

15. Figures

Figure 1: SemTalk WEICOME SCIEEN..........oiiiiiiiiiiieie e 4
Figure 2: Starting SemTalk EPC EdItION ......cccocoiiiiiie e 5
Figure 3: Adding ProCess EIBMENTS ..........coiiiiiiiiiiieiecee e 9
Figure 4: ClasSiCal BEPC ...t re e 10
Figure 5: EPC With SWIM LANES .......ocviiiiiiiiiiieiee e 12
Figure 6: EPC with swim lanes and input / QUIPUL...........ccooieiieii i 13
Figure 7: Composing object oriented fUNCLIONS ..........ccoiiiiiiiiiiieeeee e 14
Figure 8: An object-0riented EPC ..o 16
Figure 9: ODJECT MO ........oouiiic s 17
Figure 10: PropertieS WINUOW ........ccooieiioiiiie et sne e e 18
Figure 11: FUNCLION DIAIOG ....c.veuiiiiiiieiitcit ettt 19
Figure 12: Edit & Compose a FUNCLION ClaSS........ccccoviieiiiieiiecece e 20
Figure 13: FUNCLION: HUM. RESOUICE .......oiviiiiiiiiiieieieie ettt 21
Figure 14: Adding new HUMaN RESOUICES .......cceeiuiiieiieie e sieesie e sre e e et 22
FIQUIe 15: FUNCLION: IMBASUIES........ocviitiitiitisieeiieieete ettt bbbt 23
FIQUIE 16: FUNCLION: SAP .. .ottt et e te e te e snaesreeneanes 24
Figure 17: Control FIOW: MEASUIES .........ciiiiiieiieieiieie ettt 25
Figure 18: Visio: SNap& GIUE OPLIONS ......ccuvcieiieieiie et 26
FIQUre 19: ValUE ChaIN ..ottt 26
FIQUIE 20: OFg CRAIt ......eeieeee ettt e e te e be e esraesreennennes 27
FIQUIe 21: AQUING PEISONS .....cuviiiiiitiiteste sttt bbbttt 28
Figure 22: Org Chart WIith PEISONS.........ccviiiiii e 29
Figure 23: Adding an arbitrary Visio Shape t0 @ PrOCESS .........cccvrveieerierierienieniesiesesieeeeeenas 30
Figure 24: Visio Shapes for resources in the Document Stencil..........c.cccooevieiieeie e, 31
Figure 25: Classes of PhySiCal RESOUITES ..........cuiiiiiiieiiiieiisieseeee e 31
Figure 26: Attributes imported from Visio MaSters..........ccccoevieieiieiiie i 32
Figure 27: A Resource with a Visio Shape iN @ PrOCESS ..........ccvvreeiieiieieniese s 33
Figure 28: Physical RESOUICE: IMBASUIES ........c.coveiueiieiieeiieeeeseeste e st e ste et re e srae e ens 34
Figure 29: Creating @ REFINEMENT ..ot 35
Figure 30: A NeW REfINEMENT .........coviiieiie e 35
Figure 31: EAiting HYPErliNKS.........coo i 36
Figure 32: Navigation With HYPerlinkS...........cccovveiiieiicie e 37
Figure 33: 16 Bit COlOred PrOCESS ........ccuiiuiiiiiieiiiieiesie ettt 38
FIgUIe 34: SIMUIALION .......ooiiie et sre e ens 39
FIQUIE 35: DIAI0G VIBW .....cciiiiieiiiieeeee ettt bbbt 40
FIgUIE 36: DIAl0G Tab .....eeieeie et e sre e e 41
FIQUIE 37: XPDL EXPOIT ....cueeiiiiieiiieiee ettt 42
FIgUIE 38: AML EXPIOTEL ...oveiiieieee ettt ettt ettt steene e 43
Figure 38: ARIS IMPOIT OPLIONS. .....c.oiuiiiiiiiiiieieie ettt 44
Figure 39: IMPOrtEd EPC .......ooeeeee ettt sre e 45
Figure 40: IMPOrt OF EPIMIL ......ooviiiiic et 46
Figure 41: SAP RIS IMPOIT ...ccvviiiie ettt be et e e 47
Figure 42: SAP SolUtion COMPOSET (1) ...oiveieiiieiieieiieie ettt 49
Figure 43: SAP SOIUtION COMPOSEN (2) .veivveeieeiieeiiie et iie sttt sbe e e ee e 50
Figure 44: SAP IMPOIt OPLIONS ...c..oviiiiiiiiiiiisiieieie ettt 51

Copyright: Semtation GmbH 2001-20010



