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For all, who have learned that using Protégé might be perfect for engineers but not for end users
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What is an Ontology?

� An ontology is a formal explicit description of concepts (i.e. classes) in a domain of discourse, properties of each 
concept describing various features and attributes, and restrictions on properties and attributes (i.e. relation and 
data types). 

� In simple words, an ontology is a formal model for a specific domain of knowledge. An ontology together with a 
set of individual instances of classes constitutes a knowledge base.

� Ontologies are developed to provide a machine-understandable semantics of information sources that can be 
communicated between different agents (software and humans). 

� We do not refer here to the philosophical sense of Ontology here http://en.wikipedia.org/wiki/Ontology but to 
the computer science sense http://en.wikipedia.org/wiki/Ontology_%28computer_science%29

(from Wikipedia)
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What is SemTalk OWL Edition?

� SemTalk is a simple UML-style graphical editor for Semantic Web ontologies in Visio. 

� Using Visio in Ontology workshops feels more like mind mapping rather than programming

� OWL is W3C’s recommendation to specify ontologies

� OWL is a complex logical language. While modeling it makes sense to make sure that the 
statements which a user makes are consistent. E.g. From “Each A is a B” and “Each A is a C”
and “Nothing can be a B and also a C at the same time” one can conclude that A will never exist. 

– This actually means that the user made a mistake, because he usually wanted to make a point about 
A. In most cases the model is wrong and not reality is wrong. Since there might be an A directly in 
front of the user

– Those inconsistencies occur pretty often in real world using complex logical languages. We use 
reasoners such as Pellet to analyze the model for logical inconsistencies

– The problem is similar to process modeling where a certain branch of a process will never be 
reached. Simulation is used for processes in the same way.

� Ontologies made with SemTalk OWL Edition are used in other SemTalk applications such as 
BPM, EAI etc.
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Getting Started with SemTalk

The explorer contains diagrams, objects, 

relationships and data types. The drawing window

Initially a SemTalk document stencil will 

contain predefined symbols for class and 

instance modeling.

Start SemTalk with it’s icon on the desktop or select Start 

���� Programs ���� SemTalk ���� SemTalk to begin working. 
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Visio Pages are Views on the Knowledge Base

� Each page displays a set (or scenario) of classes and instances in a context which is meaningful 
for a human reader

� Each object can be displayed on multiple pages

� An object can be shown using various symbols available in Visio

� Classes are mostly shown using a UML style notation

Let us start with Instances, which a ordinary Visio shapes.
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Instance Diagrams

� Using instance diagrams in SemTalk you will create diagrams for concrete objects having a 
specific identity. Instance diagrams are used in SemTalk solutions for business processes, org. 
charts, data warehouse cubes, product models etc. 

� Virtually any Visio drawing containing real world objects such as buildings or a subway map 
would be an instance diagram. 

� Diagrams which are not instance diagrams are called class diagrams. Class Diagrams contain 
abstract objects like data types and classes. 

� In the Visio world classes correspond to masters and instances to the shapes in the drawing. 

Most of the millions of existing ordinary Visio documents contain just instances! 

But each of them has a class: The Visio master which is used
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Creating Instances

� File->New OWL.vst

� File->Open Stencil

� Browse to “C:\Program Files\Microsoft 
Office\OFFICE12\1033”

� Select Workflow Shapes: 
“WRKFLO_M.VST” or 
“WRKFLO_U.VST”

� Change the type of the page to 
“Instance” (Right Click on the 
background)

� Drag a Bank shape to the drawing

� Rename the object

– Select and type

– Right Click Edit

� Change the name of the shapes to 
“Acme Bank” & “IOU Bank” for the 
Banks and “John Doe” & “Mary Smith”
for the “Treasurers” respectively.
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Delete / Remove / Insert

� Two different objects can not 
have the same name

� Copy/Paste or Insert can 
display the same object more 
than once

� “Del” deletes an object from the 
diagram but keeps it in the 
database

� “Remove” removes it from the 
database and all diagrams

� Use “Insert” or Drag & Drop 
from the explorer to add 
shapes to the drawing

� Drag&Drop from the stencil 
creates a new object

� Undo works only for Delete and 
NOT for Remove
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Class Diagrams

� The meaning of the Visio shapes we previously used is defined in class diagrams. 

� In our example, we used Visio shapes related to banks and treasurers and we gave them 
individual names. 

� In a class diagram we can now extend the definition of our model by defining that a treasurer 
works at a bank. This declaration is valid for the instances we modeled before. Furthermore, in 
the class diagram you can define attributes that are inherited by subclasses of your class. 

� For example, the subclass “Central Bank” will inherit attributes and relationships (e.g. employs -
inverse relationship of “works at” - and number of branches) from the class “Bank”. Abstract 
classes, e.g. “financial institution”, have no Visio-shape (yet) and therefore, you can use the 
general class symbol.
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Adding a Class Diagram

� Add a new page with 
Diagram->New->OWL 
Diagram

� Add some new Classes 
such as “Financial 
Institution” using the UML 
Class shape.

� Already existing classes 
such as Bank can be 
added using Drag&Drop
from the Explorer or using 
the Insert Dialog
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Editing a Class

� Name & Namespace = 
URI

� If you believe your 
understanding of “Bank”
is the same as described 
in Wikipedia, you might 
add this as a namespace

� You could also use any 
other namespace of your 
choice or leave it blank

� Use “Links” to add  
documents as hyperlinks

� Audit provides some 
information who created 
or changes the class
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Comments & Links

� With the yellow Comment 
shape you can easily 
visualize the Comment (or 
Definition) field of an object

� Editing the text of the 
comment shape will change 
directly the Comment in the 
object

� Use the “subClassOf”
Connector to specify that 
each Bank is a financial 
institution and each Central 
Bank is a Bank

� For Object Properties the 
“Property” connector may 
be used

� If you use the dynamic 
connector tool, you will be 
asked which type of relation 
you want
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Attributes

� Attributes are inherited by 
Subclasses and Instances

� They are called “DataProperties”
in OWL

� Weak typing (as in Case-Tools)

� Editor shows a list of inherited 
Attributes

� Multiple value Attributes

� Attribute Options
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Inheritance

� Change the Class of an instance using the Class Combobox

� Inherited Attributes and Values are marked with a “*”

� Inherited Attributes become local, once they get a value
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Associations & Subclassing

� Use “subClassOf” and 
“Property” connectors

� Properties are used for OWL 
“ObjectProperties”

� “subClassOf” Hierarchy is 
shown in the Explorer

� Editing Association types

� Inverse Names are specified 
in the Edit Dialog of an 
Association

� Association Details: Unique, 
Transitive, Tree (no cycles),..

� See (inherited) Properties in 
the Edit dialog

� You can add non-graphical 
Associations on the 
Associations tab of a Class or 
Instance
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Instances  & Associations

� In most SemTalk Methods 
associations on instances are 
only allowed if they are 
defined on their classes

� Since OWL covers RDF you 
can use any Property 
between instances (“foos”)

� In OWL mode SemTalk 
recommends only those 
properties which are defined 
for the instances

� In OWL mode you can show 
instances in class diagrams
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Reasoning � So far we have no chance to create any 
logical errors, since we have no logical 
constraints such as disjointness or 
equivalence used

� With a disjointWith link, it is specified that 
nothing can be any instance of a Bank and a 
Treasurer at the same time

� To check if the model is still consistent we will 
use the Reasoner Pellet 
(http://pellet.owldl.com/)

� Please make sure that SemTalk has the right 
path to Pellet at Tools->SemTalk Option-
>OWL
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Using a Reasoner for Consistency Checking

� Start Pellet using 
OWL->Reasoner

� (It takes a while to 
start Java for the first 
time)

� OWL -> Refresh starts 
the Reasoner again

� OWL -> Output File 
shows the generated 
temporary OWL file
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Graphical OWL

� Developed with Cerebra 
Inc

� Extending the Class 
Shapeset with 
additional shapes 
designed for OWL

� Anonymous Classes for 
“UnionOf”, 
“IntersectionOf”, 
“OneOf”

� Object- and 
DataProperties can be 
nodes in the Drawing 
with “hasDomain” and 
“hasRange” links

� Classes & Instances 
often in one Diagram

� Intended to be used 
with reasoners such as 
Pellet, Cerebra or 
Ontobroker
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OWL Shapes

An abstract class describing that instances of that class are not 
instance of another class. Use the complementOf relation to 
specify that other class. Ignored by SemTalk Engine but 
exported to OWL

OWL ComplementOf

Relation from a OWL Intersection class to other classesintersectionOf

An abstract class describing the intersection of a set of other 
classes. Use the intersectionOf relation to specify that set. 
Ignored by SemTalk Engine but exported to OWL

OWL Intersection

Relation from a OWL Union class to other classesunionOf

An abstract class describing the union of a set of other classes. 
Use the unionOf relation to specify that set. Ignored by SemTalk 
Engine but exported to OWL

OWL Union

Two instances are denoting different objects. Default for 
SemTalk

differentFrom

Two instances denote the same object. Ignored by the SemTalk 
Engine, which assumes closed world semantics

sameIndivudualAs, sameAs

Graphically displays that the object is instance of a class. An 
instance can be instance of multiple classes. Supported by the 
SemTalk Engine. 

instanceOf

Just an instanceInstance

No instance is allowed to be instance of both classes. Ignored 
by SemTalk Engine but exported to OWL

disjointWith

Two classes actually denote the same concept. Ignored by the 
SemTalk Engine but exported to OWL

equivalentClass
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OWL Shapes (2)

Relation from a property to its range. This 
can also be specified using the edit 
dialog Details tab. Supported by the 
SemTalk Engine

hasRange

Relation from a property to its domain. This 
can also be specified using the edit 
dialog Details tab. Supported by the 
SemTalk Engine

hasDomain

Subclassing of properties. Partially 
supported by SemTalk Engine but 
exported to OWL

subPropertyOf

Two AttributeTypes or RelationTypes have 
same meaning. Ignored by SemTalk 
Engine but exported to OWL

equivalentProperty

Graphically displays an Association Class 
(“ObjectProperty” in OWL)

RelationType

Graphically displays an Attribute Class 
(“DataProperty” in OWL)

AttributeType

Member of an AllDifferent SetdistinctMember

Operator specifying that all related 
instances are different. (Default in 
SemTalk)

OWL AllDifferent

Relation from a OWL OneOf class to 
instances defining that class

oneOf

An abstract class describing that instances 
of that class are one of a set of other 
instances. Use the oneOf relation to 
specify that set. Ignored by SemTalk 
Engine but exported to OWL

OWL OneOf

Relation from a OWL ComplementOf class 
to other classes

complementOf
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OWL Import

� File->Export / Import -> Semantic Web

� Import of existing OWL Files

� E.g. from ProtegeOntologiesLibrary: 
http://protege.cim3.net/cgi-
bin/wiki.pl?ProtegeOntologiesLibrary

� SemTalk objects will be created for the OWL 
objects

� Merged by name (incl. namespace)

� A Base Class (new Superclass) for the 
imported classes may be specified

� Single Objects can be selected

� Included ontologies will also be imported

� OWL files have no graphical information

– Create a new page and add objects using drag 
& drop

– Use the Insert Dialog (later slide)

– Single objects may be expanded (later slide)
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OWL Export

� File->Export / Import -> Semantic Web

� Save the selected objects to an OWL 
File

� If nothing is selected, the complete 
model will be exported
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Insert Objects in a Drawing

� Create a new diagram

� Right-Click on the Background 
and choose “Insert”

� Show existing Objects on 
multiple Pages

� Choose a Shape (Visio or 
UML)

� Automatically inserts links

� Filtering by Object Filter

� Insert “Bank”
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Expand Objects on a Drawing

� Similar to Insert

� Right-Click in the Class 
Bank and choose 
“Expand”

� Expand inserts related 
Objects (Properties and 
Subclasses) into the 
drawing

� Optimize Layout using the 
Visio->Shape Menu
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Context Browsing

� Right Click-> Context on 
an object

� This will clear the page 
and insert all related 
object on the page: 
Subclasses, 
Superclasses etc

� Allows to navigate 
through an ontology 
which has no 
visualization yet

� Right Click-> Context+ 
just adds the context of 
a current object without 
clearing the page

� If you want to keep a 
picture, just add a new 
page to continue
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(Hyper-) linking Models

� You may work with 3rd party ontologies without 
importing the complete ontology into SemTalk / 
Visio

� File->Open External Model

� Open http://www.semtalk.com/pub/urban.xml

� The explorer contains new gray colored objects. 
These objects exist in the “to-be-imported”
model. Until now, they exist only virtually in the 
“urban“ model. To make them part of your model 
you have to import them. There are 4 ways to do 
this:

– Drag & drop the object(s) in your diagram.

– Menu Object->Import

– Right-click over the grey colored object in 
explorer

– Right-click over the drawing area of the 
diagram, where you want to insert the 
external objects and select “Insert”. Once 
you see the dialog box click the “External”
button

� External Objects can be  updated from their 
source using „Refresh“

� Sources can be OWL or SemTalk files

� This creates a networks of linked ontologies 
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Browse

� Navigate to the same Object on different pages

� Navigate to related objects on different pages

� Often used the check if an objects found in the explorer is still used
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Find

� Find an Object by 
Name, Substring etc.

� Lots of Options where 
to search:

– Name

– Attributes, Values…

– By Type

– Comments

– …

� You may edit objects 
directly from the result 
list

� Drop them on the 
drawing area

� Find in Files will 
search on your file 
system
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Refine / Detach

� You can attach a 
diagram as a hyperlink 
to an object for purpose 
of navigation

� Objects with a 
refinement are usually 
underlined (not for UML 
Shapes)

� External Refinements 
are Diagrams in a 
separate Visio Drawing

� If there is no refinement 
yet, “Refine” attaches a 
new diagram

� If there is already a 
refinement, it will be 
opened. “Go Up” will 
navigate upward from 
the refinement to the 
refined object
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Customize

� Customize Behavior

– What happens on drop

– What happens on deletion

– Displayed in the Explorer

� Customize Dialog Tabs

� Customize what and how 
information is shown in a 
shape

� Specify this for (sub-) classes 
and for instances

� Customizing Information is 
inherited
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HTML Export

� Export to HTML

� IE preferred

� Lots of Options what is going 
to be included

� Relative Path to external 
documents

� “Merging” of multiple 
SemTalk HTML Models, 
linked together

� PDF, SVG…
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Reports

� Meta Model driven 
Reporting Tool

� Exports to XML and 
HTML

� Select objects and 
related objects in a 
XPATH style from the 
left hand treeview

� Preview on the right 
side
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Merging: SemTalk Import

� Merging of SemTalk 
Models with or without 
graphical information

� Additional to “Open 
External Model”

� Can be used to convert 
SemTalk Class Diagrams 
to new diagram classes. 
Especially useful for 
Ontologies

� Import as copy or as 
reference
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Association Classes

� If you edit an Association 
(OWL Object Property) you 
can specify some OWL 
relevant features:

– Transitive

– Unique

� You can also specify global 
from domain and to domain 
restriction

� SemTalk relevant features 
are

– Aggregation

– Cyclic

– Symmetric

– Multiple
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Table Editor

� Edit attribute values of 
classes and instances 
in MS Excel

� Translate the objects 
easily to multiple 
languages
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Do you want to test drive SemTalk?

Please download our 30 day demo free of charge. 

Or make an appointment for an online demo:

www.semtalk.com

If you do not have Visio, you may download a trial version from Microsoft's website. Please let us know if you need assistance.

These slides are intended to be used in a tutorial session. Please refer to our manuals for written details not mentioned here

Semtation GmbH

Am Neuen Garten 4

14469 Potsdam, Germany

+49 331 58139-36

sales@semtalk.com


